summaryrefslogtreecommitdiff
path: root/math/libocas/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/libocas/Makefile')
-rw-r--r--math/libocas/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/math/libocas/Makefile b/math/libocas/Makefile
index 94d0750909e9..7631cbe35288 100644
--- a/math/libocas/Makefile
+++ b/math/libocas/Makefile
@@ -21,15 +21,7 @@ MAKE_ENV= CLIBS="${CLIBS}" MEXDETECTED=no
PLIST_FILES= bin/linclassif bin/msvmocas bin/svmocas lib/libocas.so \
lib/libocas.so.1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == sparc64
-PICFLAG= -fPIC
-.else
-PICFLAG= -fpic
-.endif
-
-CFLAGS+= ${PICFLAG}
+CFLAGS+= -fpic
post-patch:
@${REINPLACE_CMD} \
@@ -55,4 +47,4 @@ do-test:
${WRKSRC}/linclassif -e -v 1 -o ${WRKSRC}/data/riply_tst.pred \
${WRKSRC}/data/riply_tst.light ${WRKSRC}/data/svmocas.model
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>