summaryrefslogtreecommitdiff
path: root/mail/neomutt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/neomutt/Makefile')
-rw-r--r--mail/neomutt/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/mail/neomutt/Makefile b/mail/neomutt/Makefile
index 7758a1fe5579..46b603a052eb 100644
--- a/mail/neomutt/Makefile
+++ b/mail/neomutt/Makefile
@@ -1,5 +1,6 @@
PORTNAME= neomutt
PORTVERSION= 20230322
+PORTREVISION= 1
CATEGORIES= mail
MAINTAINER= bapt@FreeBSD.org
@@ -13,7 +14,7 @@ RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:misc/mime-support \
urlview:textproc/urlview
LIB_DEPENDS= libpcre2-posix.so:devel/pcre2
-USES= cpe iconv:translit localbase ncurses perl5 pkgconfig shebangfix ssl
+USES= cpe iconv:translit localbase ncurses perl5 pkgconfig python:env shebangfix ssl
USE_GITHUB= yes
USE_PERL5= build
@@ -22,7 +23,9 @@ MAKE_JOBS_UNSAFE= yes
HAS_CONFIGURE= yes
OPTIONS_SUB= yes
-SHEBANG_FILES= contrib/smime_keys
+SHEBANG_FILES= contrib/smime_keys \
+ contrib/oauth2/mutt_oauth2.py \
+ data/account-command/macos-keychain/keychain.py
OPTIONS_DEFINE= NLS DOCS SASL IDN FLOCK GPGME NOTMUCH
OPTIONS_DEFAULT=SASL TOKYOCABINET NOTMUCH GPGME LMDB NCURSES GSSAPI_BASE
@@ -46,6 +49,7 @@ CONFIGURE_ARGS= --with-ssl="${OPENSSLBASE}" \
--fmemopen \
--pcre2 \
--disable-idn \
+ --prefix=${PREFIX} \
--mandir=${PREFIX}/man \
${ICONV_CONFIGURE_ARGS}
CONFIGURE_ENV= CC_FOR_BUILD="${CC}"
@@ -90,6 +94,7 @@ GSSAPI_HEIMDAL_USES= gssapi:heimdal
GSSAPI_HEIMDAL_CONFIGURE_ON= --with-gss=${LOCALBASE}
GSSAPI_MIT_USES= gssapi:mit
GSSAPI_MIT_CONFIGURE_ON= --with-gss=${LOCALBASE}
+GSSAPI_NONE_CONFIGURE_ON= --disable-gss
DOCS_CONFIGURE_OFF= --disable-doc
DOCS_BUILD_DEPENDS= xsltproc:textproc/libxslt \