summaryrefslogtreecommitdiff
path: root/lang/rust/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/rust/Makefile')
-rw-r--r--lang/rust/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 3ec21e199654..b690b7bfdd37 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rust
-PORTVERSION?= 1.45.1
+PORTVERSION?= 1.45.2
PORTREVISION?= 0
CATEGORIES= lang
MASTER_SITES= https://static.rust-lang.org/dist/:src \
@@ -37,7 +37,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
USES= pkgconfig python:3.3+,build ssl tar:xz
-MAKE_ENV= LIBGIT2_SYS_USE_PKG_CONFIG=1 \
+MAKE_ENV= DESTDIR=${STAGEDIR} \
+ LIBGIT2_SYS_USE_PKG_CONFIG=1 \
LIBSSH2_SYS_USE_PKG_CONFIG=1 \
OPENSSL_DIR="${OPENSSLBASE}" \
RUST_BACKTRACE=1
@@ -180,11 +181,8 @@ do-build:
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} x.py build --jobs=${MAKE_JOBS_NUMBER}
do-install:
-# DESTDIR not in MAKE_ENV as it would cause the bundled LLVM to be
-# staged into it during do-build.
@cd ${WRKSRC} && \
- ${SETENV} ${MAKE_ENV} DESTDIR=${STAGEDIR} ${PYTHON_CMD} \
- x.py install --jobs=${MAKE_JOBS_NUMBER}
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} x.py install --jobs=${MAKE_JOBS_NUMBER}
# We autogenerate the plist file. We do that, instead of the
# regular pkg-plist, because several libraries have a computed
# filename based on the absolute path of the source files. As it