summaryrefslogtreecommitdiff
path: root/lang/php70/Makefile.ext
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php70/Makefile.ext')
-rw-r--r--lang/php70/Makefile.ext42
1 files changed, 14 insertions, 28 deletions
diff --git a/lang/php70/Makefile.ext b/lang/php70/Makefile.ext
index 043949cc8cb8..2d1b83128c47 100644
--- a/lang/php70/Makefile.ext
+++ b/lang/php70/Makefile.ext
@@ -1,7 +1,6 @@
COMMENT= The ${PHP_MODNAME} shared extension for php
-USE_PHP= yes
-USE_PHPEXT= yes
+USES+= php:ext
PHP_MODNAME= ${PKGNAMESUFFIX:S/-//}
PHP_DEFAULT= 7.0
IGNORE_WITH_PHP= 55 56
@@ -225,8 +224,7 @@ CONFIGURE_ARGS+=--enable-pdo
.if ${PHP_MODNAME} == "pdo_dblib"
CONFIGURE_ARGS+=--with-pdo-dblib=${LOCALBASE}
-USE_PHP= pdo
-USE_PHP_BUILD= yes
+USE_PHP= pdo:build
OPTIONS_DEFINE= MSSQL
@@ -237,16 +235,14 @@ MSSQL_DESC= Enable Microsoft SQL Server support
CONFIGURE_ARGS+=--with-pdo-firebird=${LOCALBASE}
USES+= firebird
-USE_PHP= pdo
-USE_PHP_BUILD= yes
+USE_PHP= pdo:build
.endif
.if ${PHP_MODNAME} == "pdo_odbc"
LIB_DEPENDS+= libodbc.so:databases/unixODBC
CONFIGURE_ARGS+=--with-pdo-odbc=unixODBC,${LOCALBASE}
-USE_PHP= pdo
-USE_PHP_BUILD= yes
+USE_PHP= pdo:build
.endif
.if ${PHP_MODNAME} == "pdo_mysql"
@@ -255,8 +251,7 @@ OPTIONS_DEFAULT=MYSQLND
MYSQLND_DESC= Use MySQL Native Driver
-USE_PHP= pdo
-USE_PHP_BUILD= yes
+USE_PHP= pdo:build
.endif
.if ${PHP_MODNAME} == "pdo_pgsql"
@@ -264,16 +259,14 @@ USES+= pgsql
CONFIGURE_ARGS+=--with-pdo-pgsql=${LOCALBASE}
-USE_PHP= pdo
-USE_PHP_BUILD= yes
+USE_PHP= pdo:build
.endif
.if ${PHP_MODNAME} == "pdo_sqlite"
USES+= sqlite
CONFIGURE_ARGS+=--with-pdo-sqlite=${LOCALBASE}
-USE_PHP= pdo
-USE_PHP_BUILD= yes
+USE_PHP= pdo:build
.endif
.if ${PHP_MODNAME} == "pgsql"
@@ -286,8 +279,7 @@ CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
CONFIGURE_ARGS+=--enable-phar \
--with-pcre-dir=${LOCALBASE}
-USE_PHP= hash
-USE_PHP_BUILD= yes
+USE_PHP= hash:build
.endif
.if ${PHP_MODNAME} == "posix"
@@ -300,8 +292,7 @@ LIB_DEPENDS+= libaspell.so:textproc/aspell
CONFIGURE_ARGS+=--with-pspell=${LOCALBASE}
# Ugly hack to load session before psell to avoid crashes
-USE_PHP= session
-USE_PHP_BUILD= yes
+USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "readline"
@@ -349,8 +340,7 @@ CONFIGURE_ARGS+=--enable-soap \
USE_GNOME= libxml2
-USE_PHP= session
-USE_PHP_BUILD= yes
+USE_PHP= session:build
.endif
.if ${PHP_MODNAME} == "sockets"
@@ -396,8 +386,7 @@ CONFIGURE_ARGS+=--enable-wddx \
USE_GNOME= libxml2
-USE_PHP= xml session
-USE_PHP_BUILD= yes
+USE_PHP= xml:build session:build
.endif
.if ${PHP_MODNAME} == "xml"
@@ -413,8 +402,7 @@ CONFIGURE_ARGS+=--enable-xmlreader \
USE_GNOME= libxml2
-USE_PHP= dom
-USE_PHP_BUILD= yes
+USE_PHP= dom:build
.endif
.if ${PHP_MODNAME} == "xmlrpc"
@@ -427,8 +415,7 @@ USE_GNOME= libxml2
PHP_HEADER_DIRS=libxmlrpc
-USE_PHP= xml
-USE_PHP_BUILD= yes
+USE_PHP= xml:build
.endif
.if ${PHP_MODNAME} == "xmlwriter"
@@ -442,8 +429,7 @@ USE_GNOME= libxml2
CONFIGURE_ARGS+=--with-xsl=${LOCALBASE}
USE_GNOME= libxslt
-USE_PHP= dom xml
-USE_PHP_BUILD= yes
+USE_PHP= dom:build xml:build
.endif
.if ${PHP_MODNAME} == "zip"