summaryrefslogtreecommitdiff
path: root/irc/thales/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/thales/Makefile')
-rw-r--r--irc/thales/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/irc/thales/Makefile b/irc/thales/Makefile
index 7a2e6c28657d..732b36344937 100644
--- a/irc/thales/Makefile
+++ b/irc/thales/Makefile
@@ -41,6 +41,9 @@ post-patch: .SILENT
${FIND} -d ${WRKSRC} -type d -name CVS -exec ${RM} -r {} \;
${REINPLACE_CMD} -e 's,thales.conf,${PREFIX}/etc/&,' \
${WRKSRC}/src/conf.h
+# Fix the build with -fno-common (for Clang 11 and GCC 10)
+ ${REINPLACE_CMD} -e '/total_read, total_written/s,^,extern ,' \
+ ${WRKSRC}/src/sockutil.h
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}