summaryrefslogtreecommitdiff
path: root/irc/bitlbee-mastodon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/bitlbee-mastodon/Makefile')
-rw-r--r--irc/bitlbee-mastodon/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/irc/bitlbee-mastodon/Makefile b/irc/bitlbee-mastodon/Makefile
new file mode 100644
index 000000000000..e8fbb731ed94
--- /dev/null
+++ b/irc/bitlbee-mastodon/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= bitlbee-mastodon
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.4.0
+CATEGORIES= irc
+
+MAINTAINER= tobias.rehbein@web.de
+COMMENT= Bitlbee plugin to communicate with Mastodon instances
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= bitlbee>=3.5:irc/bitlbee
+RUN_DEPENDS= bitlbee>=3.5:irc/bitlbee
+
+USES= autoreconf gnome libtool pkgconfig
+USE_GNOME= glib20
+USE_GITHUB= yes
+GH_ACCOUNT= kensanata
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-plugindir=${PREFIX}/lib/bitlbee
+
+PLIST_FILES= lib/bitlbee/mastodon.so \
+ share/bitlbee/mastodon-help.txt
+
+pre-configure:
+ cd ${WRKSRC} && ./autogen.sh
+
+.include <bsd.port.mk>