summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile7
-rw-r--r--graphics/iulib/Makefile57
-rw-r--r--graphics/iulib/distinfo2
-rw-r--r--graphics/iulib/files/patch-configure.ac33
-rw-r--r--graphics/iulib/files/patch-genAM.py67
-rw-r--r--graphics/iulib/files/patch-imglib_imgops.cc11
-rw-r--r--graphics/iulib/files/patch-imglib_imgops.h12
-rw-r--r--graphics/iulib/files/patch-utils__dgraphics.cc11
-rw-r--r--graphics/iulib/files/patch-utils__dgraphics_nosdl.cc15
-rw-r--r--graphics/iulib/files/patch-vidio__vidio.cc28
-rw-r--r--graphics/iulib/pkg-descr5
-rw-r--r--graphics/iulib/pkg-plist58
-rw-r--r--graphics/py-gchartwrapper/Makefile27
-rw-r--r--graphics/py-gchartwrapper/distinfo2
-rw-r--r--graphics/py-gchartwrapper/pkg-descr9
-rw-r--r--graphics/py-pyggel/Makefile56
-rw-r--r--graphics/py-pyggel/distinfo2
-rw-r--r--graphics/py-pyggel/files/patch-pyggel__include.py11
-rw-r--r--graphics/py-pyggel/pkg-descr5
-rw-r--r--graphics/qiviewer/Makefile40
-rw-r--r--graphics/qiviewer/distinfo2
-rw-r--r--graphics/qiviewer/files/patch-main.cpp13
-rw-r--r--graphics/qiviewer/pkg-descr4
-rw-r--r--graphics/rubygem-gemojione2/Makefile24
-rw-r--r--graphics/rubygem-gemojione2/distinfo3
-rw-r--r--graphics/rubygem-gemojione2/pkg-descr5
-rw-r--r--graphics/seam-carving-gui/Makefile29
-rw-r--r--graphics/seam-carving-gui/distinfo2
-rw-r--r--graphics/seam-carving-gui/files/patch-cair_CAIR.cpp38
-rw-r--r--graphics/seam-carving-gui/pkg-descr5
-rw-r--r--graphics/svgfig/Makefile26
-rw-r--r--graphics/svgfig/distinfo2
-rw-r--r--graphics/svgfig/pkg-descr21
33 files changed, 0 insertions, 632 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d55dd0a9f60d..ce878f7edc53 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -374,7 +374,6 @@
SUBDIR += intergif
SUBDIR += inventor
SUBDIR += ipe
- SUBDIR += iulib
SUBDIR += jalbum
SUBDIR += jasper
SUBDIR += jave6
@@ -845,7 +844,6 @@
SUBDIR += py-exifread
SUBDIR += py-exiv2
SUBDIR += py-freeimagepy
- SUBDIR += py-gchartwrapper
SUBDIR += py-gd
SUBDIR += py-gdal
SUBDIR += py-gimp
@@ -881,7 +879,6 @@
SUBDIR += py-pydot
SUBDIR += py-pygal
SUBDIR += py-pyganim
- SUBDIR += py-pyggel
SUBDIR += py-pyglet
SUBDIR += py-pygooglechart
SUBDIR += py-pygraphviz
@@ -909,7 +906,6 @@
SUBDIR += qcomicbook
SUBDIR += qgis
SUBDIR += qiv
- SUBDIR += qiviewer
SUBDIR += qslim
SUBDIR += qt4-iconengines
SUBDIR += qt4-imageformats
@@ -958,7 +954,6 @@
SUBDIR += rubygem-gd2
SUBDIR += rubygem-gdk_pixbuf2
SUBDIR += rubygem-gemojione
- SUBDIR += rubygem-gemojione2
SUBDIR += rubygem-geokit
SUBDIR += rubygem-gitlab_emoji
SUBDIR += rubygem-goocanvas
@@ -995,7 +990,6 @@
SUBDIR += sdl_image
SUBDIR += sdl_ttf
SUBDIR += sdump
- SUBDIR += seam-carving-gui
SUBDIR += seejpeg
SUBDIR += seexpr
SUBDIR += sekrit-twc-zimg
@@ -1021,7 +1015,6 @@
SUBDIR += svg2pdf
SUBDIR += svg2png
SUBDIR += svgalib
- SUBDIR += svgfig
SUBDIR += swfdec
SUBDIR += swfmill
SUBDIR += swftools
diff --git a/graphics/iulib/Makefile b/graphics/iulib/Makefile
deleted file mode 100644
index 42e570dd61a6..000000000000
--- a/graphics/iulib/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-# Created by: Hiroto Kagotani <hiroto.kagotani@gmail.com>
-# $FreeBSD$
-
-PORTNAME= iulib
-PORTVERSION= 0.4
-PORTREVISION= 18
-CATEGORIES= graphics
-MASTER_SITES= GOOGLE_CODE
-
-MAINTAINER= hiroto.kagotani@gmail.com
-COMMENT= Library of image understanding-related algorithms
-
-LICENSE= APACHE20
-
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
-
-LIB_DEPENDS= libpng.so:graphics/png \
- libtiff.so:graphics/tiff
-
-OPTIONS_DEFINE= SDL VIDIO
-SDL_DESC= Enable SDL for graphical debugging
-VIDIO_DESC= Enable Video Input/Output (using ffmpeg)
-
-USES= autoreconf jpeg libtool python:build tar:tgz
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-INSTALL_TARGET= install-strip
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSDL}
-USE_SDL= sdl gfx
-PLIST_SUB+= SDL=""
-.else
-CONFIGURE_ARGS+=--without-SDL
-PLIST_SUB+= SDL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MVIDIO}
-LIB_DEPENDS+= libavcodec.so:multimedia/ffmpeg
-.endif
-
-post-patch:
-.if ! ${PORT_OPTIONS:MVIDIO}
- @${REINPLACE_CMD} -e 's/novidio, 0/novidio, 1/' ${WRKSRC}/configure.ac
-.endif
- @${REINPLACE_CMD} -e 's/nov4l2, 0/nov4l2, 1/' ${WRKSRC}/configure.ac
-
-pre-configure:
- @(cd ${CONFIGURE_WRKSRC} \
- && ${SETENV} ${PYTHON_CMD} genAM.py > Makefile.am)
-
-.include <bsd.port.mk>
diff --git a/graphics/iulib/distinfo b/graphics/iulib/distinfo
deleted file mode 100644
index 074b3d7ea59e..000000000000
--- a/graphics/iulib/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (iulib-0.4.tgz) = c70dab420f5ce0ff0185c922881576f4a82eacec3feb0befa66bd7468151d99b
-SIZE (iulib-0.4.tgz) = 3288112
diff --git a/graphics/iulib/files/patch-configure.ac b/graphics/iulib/files/patch-configure.ac
deleted file mode 100644
index 4ec905a61331..000000000000
--- a/graphics/iulib/files/patch-configure.ac
+++ /dev/null
@@ -1,33 +0,0 @@
---- configure.ac.orig 2009-06-10 00:32:20.000000000 +0200
-+++ configure.ac 2010-07-24 18:02:39.000000000 +0200
-@@ -10,7 +10,7 @@
-
- AC_PROG_CXX
- AC_PROG_CC
--AC_PROG_RANLIB
-+AM_PROG_LIBTOOL
-
- AC_HEADER_STDC
- AC_HEADER_SYS_WAIT
-@@ -55,15 +55,15 @@
-
- # --- vidio (optional video in-/output) ---
- AC_SUBST(novidio, 0)
--AC_CHECK_HEADER(ffmpeg/avcodec.h,,AC_SUBST(novidio, 1))
--AC_CHECK_HEADER(ffmpeg/avformat.h,,AC_SUBST(novidio, 1))
--AC_TRY_COMPILE([#include <ffmpeg/avio.h>
-- #include <ffmpeg/avformat.h>],
-+AC_CHECK_HEADER(libavcodec/avcodec.h,,AC_SUBST(novidio, 1))
-+AC_CHECK_HEADER(libavformat/avformat.h,,AC_SUBST(novidio, 1))
-+AC_TRY_COMPILE([#include <libavformat/avio.h>
-+ #include <libavformat/avformat.h>],
- [AVFormatContext fc; url_fclose(fc.pb);],
-- [], [AC_DEFINE(HAVE_OLD_AVFORMAT)])
-+ [], [])
- AM_CONDITIONAL([have_vidio], [test "$novidio" != 1])
-
--AC_SUBST(nov4l2, 0)
-+AC_SUBST(nov4l2, 1)
- AC_CHECK_HEADER(linux/videodev2.h,,AC_SUBST(nov4l2, 1))
- AM_CONDITIONAL([have_v4l2], [test "$nov4l2" != 1])
-
diff --git a/graphics/iulib/files/patch-genAM.py b/graphics/iulib/files/patch-genAM.py
deleted file mode 100644
index b2e25b12d6ef..000000000000
--- a/graphics/iulib/files/patch-genAM.py
+++ /dev/null
@@ -1,67 +0,0 @@
---- ./genAM.py.orig 2009-06-10 07:32:20.000000000 +0900
-+++ ./genAM.py 2009-06-11 18:24:46.000000000 +0900
-@@ -25,12 +25,12 @@
- # Primary Repository: http://ocropus.googlecode.com/svn/trunk/
- # Web Sites: www.iupr.org, www.dfki.de
-
--AM_CPPFLAGS = -I$(srcdir)/colib -I$(srcdir)/imgio -I$(srcdir)/imglib
-+AM_CPPFLAGS = -I$(srcdir)/colib -I$(srcdir)/imgio -I$(srcdir)/imglib -I$(srcdir)/imgbits -I$(srcdir)/utils -I$(srcdir)/vidio
-
- includedir = ${prefix}/include/iulib
- colibdir = ${prefix}/include/colib
-
--lib_LIBRARIES = libiulib.a
-+lib_LTLIBRARIES = libiulib.la
- """
-
- dirs = """
-@@ -39,7 +39,7 @@
- imgbits
- """.split()
-
--print "libiulib_a_SOURCES = ",
-+print "libiulib_la_SOURCES = ",
- for d in dirs:
- print '\\'
- for cc in glob.glob(d + "/*.cc"):
-@@ -82,35 +82,23 @@
- print """
- # conditionals
- if have_sdl
-- libiulib_a_SOURCES += $(srcdir)/utils/dgraphics.cc
-- libiulib_a_SOURCES += $(srcdir)/utils/SDL_lines.cc
-+ libiulib_la_SOURCES += $(srcdir)/utils/dgraphics.cc
-+ libiulib_la_SOURCES += $(srcdir)/utils/SDL_lines.cc
- include_HEADERS += $(srcdir)/utils/SDL_lines.h
- else
-- libiulib_a_SOURCES += $(srcdir)/utils/dgraphics_nosdl.cc
-+ libiulib_la_SOURCES += $(srcdir)/utils/dgraphics_nosdl.cc
- endif
-
- if have_vidio
-- libiulib_a_SOURCES += $(srcdir)/vidio/vidio.cc
-+ libiulib_la_SOURCES += $(srcdir)/vidio/vidio.cc
- endif
-
- # We install it always because iulib.h always includes it.
- include_HEADERS += $(srcdir)/vidio/vidio.h
-
- if have_v4l2
-- libiulib_a_SOURCES += $(srcdir)/vidio/v4l2cap.cc
-+ libiulib_la_SOURCES += $(srcdir)/vidio/v4l2cap.cc
- endif
--
--# make installation of colib a separate target
--
--install-colib:
-- install -d $(colibdir)
-- install $(colib_HEADERS) $(colibdir)
--
--install: all install-colib
-- install -d $(includedir)
-- install -d $(libdir)
-- install $(include_HEADERS) $(includedir)
-- install $(lib_LIBRARIES) $(libdir)
- """
-
- print
diff --git a/graphics/iulib/files/patch-imglib_imgops.cc b/graphics/iulib/files/patch-imglib_imgops.cc
deleted file mode 100644
index d00e356d59ad..000000000000
--- a/graphics/iulib/files/patch-imglib_imgops.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- imglib/imgops.cc.orig 2009-06-09 22:32:20 UTC
-+++ imglib/imgops.cc
-@@ -133,7 +133,7 @@ namespace iulib {
-
- template<class T,class V>
- void addscaled(narray<T> &dest,narray<T> &src,
-- V scale=1,int dx=0,int dy=0) {
-+ V scale,int dx,int dy) {
- for (int i=0; i<dest.dim(0); i++)
- for (int j=0; j<dest.dim(1); j++)
- dest.unsafe_at(i,j) += (T)(scale*xref(src,i+dx,j+dy));
diff --git a/graphics/iulib/files/patch-imglib_imgops.h b/graphics/iulib/files/patch-imglib_imgops.h
deleted file mode 100644
index 471ffb32830a..000000000000
--- a/graphics/iulib/files/patch-imglib_imgops.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- imglib/imgops.h.orig 2009-06-09 22:32:20 UTC
-+++ imglib/imgops.h
-@@ -67,7 +67,8 @@ namespace iulib {
- }
-
- template<class T, class V>
-- void addscaled(colib::narray<T> &, colib::narray<T> &, V, int, int);
-+ void addscaled(colib::narray<T> &dest, colib::narray<T> &src,
-+ V scale=1, int dx=0, int dy=0);
- template<class T>
- void tighten(colib::narray<T> &image);
- template<class T>
diff --git a/graphics/iulib/files/patch-utils__dgraphics.cc b/graphics/iulib/files/patch-utils__dgraphics.cc
deleted file mode 100644
index bad03229f9f2..000000000000
--- a/graphics/iulib/files/patch-utils__dgraphics.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./utils/dgraphics.cc.orig 2009-06-10 07:32:20.000000000 +0900
-+++ ./utils/dgraphics.cc 2009-06-17 17:46:19.000000000 +0900
-@@ -25,7 +25,7 @@
-
- #include <SDL/SDL.h>
- #include <SDL/SDL_gfxPrimitives.h>
--#include <SDL/SDL_image.h>
-+//#include <SDL/SDL_image.h>
- #include <SDL/SDL_imageFilter.h>
- #include <SDL/SDL_rotozoom.h>
-
diff --git a/graphics/iulib/files/patch-utils__dgraphics_nosdl.cc b/graphics/iulib/files/patch-utils__dgraphics_nosdl.cc
deleted file mode 100644
index 56d42771a5c5..000000000000
--- a/graphics/iulib/files/patch-utils__dgraphics_nosdl.cc
+++ /dev/null
@@ -1,15 +0,0 @@
---- ./utils/dgraphics_nosdl.cc.orig 2009-06-10 07:32:20.000000000 +0900
-+++ ./utils/dgraphics_nosdl.cc 2009-06-17 18:21:05.000000000 +0900
-@@ -40,6 +40,12 @@
- }
- }
-
-+ bool dactive() {
-+ }
-+
-+ const char *dsection_set(const char *section) {
-+ }
-+
- template <class T>
- void dshow(narray<T> &data,const char *spec,double angle,int smooth,int rgb) {
- }
diff --git a/graphics/iulib/files/patch-vidio__vidio.cc b/graphics/iulib/files/patch-vidio__vidio.cc
deleted file mode 100644
index f55f19d91e79..000000000000
--- a/graphics/iulib/files/patch-vidio__vidio.cc
+++ /dev/null
@@ -1,28 +0,0 @@
---- vidio/vidio.cc.orig 2009-06-10 00:32:20.000000000 +0200
-+++ vidio/vidio.cc 2010-07-11 10:29:54.176325026 +0200
-@@ -27,7 +27,6 @@
- extern "C" {
- #include <assert.h>
- #include <math.h>
--#include <malloc.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <ctype.h>
-@@ -119,7 +118,7 @@
- AVStream *st);
- void closeOutputVideo(AVFormatContext *oc,
- AVStream *st);
-- AVFrame *allocOutputPicture(int pix_fmt, int width, int height);
-+ AVFrame *allocOutputPicture(PixelFormat pix_fmt, int width, int height);
-
- void copyToYUV(bytearray &red,
- bytearray &green,
-@@ -624,7 +623,7 @@
-
-
-
-- AVFrame *VidOutImpl::allocOutputPicture(int pix_fmt, int width, int height) {
-+ AVFrame *VidOutImpl::allocOutputPicture(PixelFormat pix_fmt, int width, int height) {
-
- AVFrame *picture;
- uint8_t *picture_buf;
diff --git a/graphics/iulib/pkg-descr b/graphics/iulib/pkg-descr
deleted file mode 100644
index d72bb82d9228..000000000000
--- a/graphics/iulib/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-A library of image understanding-related algorithms.
-Provides basic image processing, mathematical morphology,
-and machine learning algorithms.
-
-WWW: https://github.com/tmbdev/iulib
diff --git a/graphics/iulib/pkg-plist b/graphics/iulib/pkg-plist
deleted file mode 100644
index 4c2119e52a00..000000000000
--- a/graphics/iulib/pkg-plist
+++ /dev/null
@@ -1,58 +0,0 @@
-include/colib/checks.h
-include/colib/classifier.h
-include/colib/clib.h
-include/colib/colib.h
-include/colib/compat.h
-include/colib/coords.h
-include/colib/debugf.h
-include/colib/deprecation.h
-include/colib/env.h
-include/colib/hash.h
-include/colib/heap.h
-include/colib/iarith.h
-include/colib/iustring.h
-include/colib/misc.h
-include/colib/narray-ops.h
-include/colib/narray-util.h
-include/colib/narray.h
-include/colib/nbest.h
-include/colib/nustring.h
-include/colib/objlist.h
-include/colib/quicksort.h
-include/colib/rowarrays.h
-include/colib/smartptr.h
-include/colib/strbuf.h
-include/colib/unionfind.h
-include/colib/vec2.h
-include/iulib/autoinvert.h
-include/iulib/bithacks.h
-include/iulib/dgraphics.h
-include/iulib/imgbitptr.h
-include/iulib/imgbits.h
-include/iulib/imgbrushfire.h
-include/iulib/imgedges.h
-include/iulib/imgfilters.h
-include/iulib/imggauss.h
-include/iulib/imggraymorph.h
-include/iulib/imgio.h
-include/iulib/imglabels.h
-include/iulib/imglib.h
-include/iulib/imgmap.h
-include/iulib/imgmisc.h
-include/iulib/imgmorph.h
-include/iulib/imgops.h
-include/iulib/imgrescale.h
-include/iulib/imgrle.h
-include/iulib/imgthin.h
-include/iulib/imgtrace.h
-include/iulib/io_jpeg.h
-include/iulib/io_pbm.h
-include/iulib/io_png.h
-include/iulib/io_tiff.h
-include/iulib/iulib.h
-include/iulib/vidio.h
-%%SDL%%include/iulib/SDL_lines.h
-lib/libiulib.a
-lib/libiulib.so
-lib/libiulib.so.0
-lib/libiulib.so.0.0.0
diff --git a/graphics/py-gchartwrapper/Makefile b/graphics/py-gchartwrapper/Makefile
deleted file mode 100644
index 242c991312f1..000000000000
--- a/graphics/py-gchartwrapper/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-# Created by: Nicola Vitale <nivit@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= GChartWrapper
-PORTVERSION= 0.9
-PORTREVISION= 3
-CATEGORIES= graphics python
-MASTER_SITES= GOOGLE_CODE
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-
-MAINTAINER= nivit@FreeBSD.org
-COMMENT= Python Google Chart Wrapper
-
-LICENSE= BSD3CLAUSE
-
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
-
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow
-
-PROJECTHOST= google-chartwrapper
-
-USES= python
-USE_PYTHON= autoplist distutils
-
-.include <bsd.port.mk>
diff --git a/graphics/py-gchartwrapper/distinfo b/graphics/py-gchartwrapper/distinfo
deleted file mode 100644
index 5ed035366005..000000000000
--- a/graphics/py-gchartwrapper/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (GChartWrapper-0.9.tar.gz) = 0a6f4bad170569c443baf78d79af2fdb3f1b03431c466cef0785704c3a151bc4
-SIZE (GChartWrapper-0.9.tar.gz) = 25480
diff --git a/graphics/py-gchartwrapper/pkg-descr b/graphics/py-gchartwrapper/pkg-descr
deleted file mode 100644
index 6cef834a2b03..000000000000
--- a/graphics/py-gchartwrapper/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-Python wrapper for the Google Chart API.
-
-The wrapper can render the URL of the Google chart, based on your parameters,
-or it can render an HTML img tag to insert into webpages on the fly.
-Made for dynamic python websites (Django,Zope,CGI,etc.) that need on the fly
-chart generation without any extra modules. Can also grab the PIL Image
-instance of the chart for manipulation
-
-WWW: http://code.google.com/p/google-chartwrapper/
diff --git a/graphics/py-pyggel/Makefile b/graphics/py-pyggel/Makefile
deleted file mode 100644
index a06cbdccbda2..000000000000
--- a/graphics/py-pyggel/Makefile
+++ /dev/null
@@ -1,56 +0,0 @@
-# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= pyggel
-PORTVERSION= 0.08
-DISTVERSIONSUFFIX= -alpha4c
-PORTREVISION= 3
-CATEGORIES= graphics python
-MASTER_SITES= GOOGLE_CODE
-DISTNAME= ${PORTNAME:tu}-V${DISTVERSION}${DISTVERSIONSUFFIX}
-DIST_SUBDIR= python
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-
-MAINTAINER= koalative@gmail.com
-COMMENT= Python Graphical Game Engine and Libraries
-
-LICENSE= LGPL3 PD
-LICENSE_COMB= multi
-
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
-
-RUN_DEPENDS= ${PYNUMPY} \
- ${PYGAME} \
- ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL \
- ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow
-
-USES= dos2unix python:2 zip
-DOS2UNIX_GLOB= *.mtl *.py *.txt
-USE_PYTHON= autoplist distutils
-NO_BUILD= yes
-NO_ARCH= yes
-
-PORTDOCS= Readme.txt
-PORTEXAMPLES= *
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-post-patch:
- @${REINPLACE_CMD} -e 's|data_files =|#data_files =|' \
- ${WRKSRC}/setup.py
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
-post-install-EXAMPLES-on:
- @(cd ${WRKSRC}/examples_and_tutorials && ${COPYTREE_SHARE} . \
- ${STAGEDIR}${EXAMPLESDIR}/examples_and_tutorials)
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${STAGEDIR}${EXAMPLESDIR})
-.for f in test_FBO test_camera test_gui test_mesh test_particle test_texture_swap
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${f}.py ${STAGEDIR}${EXAMPLESDIR})
-.endfor
-
-.include <bsd.port.mk>
diff --git a/graphics/py-pyggel/distinfo b/graphics/py-pyggel/distinfo
deleted file mode 100644
index 845452212b57..000000000000
--- a/graphics/py-pyggel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (python/PYGGEL-V0.08-alpha4c.zip) = 492bafd20a8cb1af2de4c5142875371a5d6dd3f1223959b169c15b6196bbca92
-SIZE (python/PYGGEL-V0.08-alpha4c.zip) = 438750
diff --git a/graphics/py-pyggel/files/patch-pyggel__include.py b/graphics/py-pyggel/files/patch-pyggel__include.py
deleted file mode 100644
index 8b429a1d6caa..000000000000
--- a/graphics/py-pyggel/files/patch-pyggel__include.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- pyggel/include.py.orig 2014-10-07 16:52:11 UTC
-+++ pyggel/include.py
-@@ -27,7 +27,7 @@
- ANI_AVAILABLE = False
-
- try:
-- import Image as PIL
-+ from PIL import Image as PIL
- PIL_AVAILABLE = True
- except:
- PIL_AVAILABLE = False
diff --git a/graphics/py-pyggel/pkg-descr b/graphics/py-pyggel/pkg-descr
deleted file mode 100644
index e6ac25f7bffc..000000000000
--- a/graphics/py-pyggel/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-Pyggel (Python Graphical Game Engine + Libraries) will ease the learning curve
-of getting into 3d programming, while also having a strong enough framework
-for full-sized applications.
-
-WWW: https://code.google.com/p/pyggel/
diff --git a/graphics/qiviewer/Makefile b/graphics/qiviewer/Makefile
deleted file mode 100644
index 1c875be7a6c7..000000000000
--- a/graphics/qiviewer/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= qiviewer
-PORTVERSION= 0.5.0
-PORTREVISION= 4
-CATEGORIES= graphics
-MASTER_SITES= GOOGLE_CODE
-
-MAINTAINER= vg@FreeBSD.org
-COMMENT= Fast and lightweight image viewer
-
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKDIR}/${PORTNAME}/COPYING
-
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
-
-USES= desktop-file-utils qmake tar:bzip2
-USE_QT4= corelib gui imageformats_run linguisttools_build \
- moc_build rcc_build uic_build
-
-PLIST_FILES= bin/qiviewer \
- share/applications/qiviewer.desktop \
- share/qiviewer/locale/el.qm \
- share/qiviewer/locale/es_AR.qm \
- share/qiviewer/locale/es_ES.qm
-
-WRKSRC= ${WRKDIR}/${PORTNAME}/src
-
-OPTIONS_DEFINE= WEBP
-WEBP_DESC= Support for WebP image format (experimental)
-WEBP_QMAKE_ON= CONFIG+=enable-webp
-
-post-configure:
- @${REINPLACE_CMD} -e 's|lrelease|lrelease-qt4|g' \
- ${WRKSRC}/Makefile
-
-.include <bsd.port.mk>
diff --git a/graphics/qiviewer/distinfo b/graphics/qiviewer/distinfo
deleted file mode 100644
index 6f23e58c5447..000000000000
--- a/graphics/qiviewer/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (qiviewer-0.5.0.tar.bz2) = 99d997ea1b05187794c14773402215178d3a21198231edd95f309badbb73010d
-SIZE (qiviewer-0.5.0.tar.bz2) = 177201
diff --git a/graphics/qiviewer/files/patch-main.cpp b/graphics/qiviewer/files/patch-main.cpp
deleted file mode 100644
index e33b65228af9..000000000000
--- a/graphics/qiviewer/files/patch-main.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- main.cpp.orig 2011-05-19 03:38:25 UTC
-+++ main.cpp
-@@ -115,6 +115,10 @@ int main(int argc, char *argv[])
-
- else if (next_option == -1)
- {
-+ // Strip file://, added by some file browsers
-+ if ( memcmp(argv[1], "file://", 7) == 0 )
-+ memmove(argv[1], argv[1]+7, strlen(argv[1]) - 6);
-+ puts(argv[1]);
- MainWindow imageViewer;
- if (QApplication::arguments().size() > 1)
- imageViewer.openImageFromCommandLine(QApplication::arguments());
diff --git a/graphics/qiviewer/pkg-descr b/graphics/qiviewer/pkg-descr
deleted file mode 100644
index 508998307662..000000000000
--- a/graphics/qiviewer/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-This program has been written with help of Qt library, to be a
-lightweight image viewer, similar to eog or viewnior for Gnome.
-
-WWW: http://code.google.com/p/qiviewer/
diff --git a/graphics/rubygem-gemojione2/Makefile b/graphics/rubygem-gemojione2/Makefile
deleted file mode 100644
index b3b7a2fc576c..000000000000
--- a/graphics/rubygem-gemojione2/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= gemojione
-PORTVERSION= 2.6.1
-CATEGORIES= graphics rubygems
-MASTER_SITES= RG
-PKGNAMESUFFIX= 2
-
-MAINTAINER= ruby@FreeBSD.org
-COMMENT= Gem containing EmojiOne unicode/image assets
-
-LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-
-RUN_DEPENDS= rubygem-json>=0:devel/rubygem-json
-
-DEPRECATED= Use graphics/rubygem-gemojione instead
-EXPIRATION_DATE=2017-04-30
-
-NO_ARCH= yes
-USE_RUBY= yes
-USES= gem
-
-.include <bsd.port.mk>
diff --git a/graphics/rubygem-gemojione2/distinfo b/graphics/rubygem-gemojione2/distinfo
deleted file mode 100644
index 79db5f69f945..000000000000
--- a/graphics/rubygem-gemojione2/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1489960493
-SHA256 (rubygem/gemojione-2.6.1.gem) = 8837ca9eaf902f384623c23e6a488e101c9f5b1fa89c02c0f001aeb5773eac3c
-SIZE (rubygem/gemojione-2.6.1.gem) = 1671168
diff --git a/graphics/rubygem-gemojione2/pkg-descr b/graphics/rubygem-gemojione2/pkg-descr
deleted file mode 100644
index 7d7c7e264c75..000000000000
--- a/graphics/rubygem-gemojione2/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-This gem contains the EmojiOne unicode/image assets and also APIs for
-lookup of emoji names, their unicode characters or image assets and
-conversion between emoji representations.
-
-WWW: https://github.com/jonathanwiesel/gemojione
diff --git a/graphics/seam-carving-gui/Makefile b/graphics/seam-carving-gui/Makefile
deleted file mode 100644
index 67105c96cc9d..000000000000
--- a/graphics/seam-carving-gui/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-# Created by: buganini@gmail.com
-# $FreeBSD$
-
-PORTNAME= seam-carving-gui
-PORTVERSION= 1.11
-PORTREVISION= 2
-CATEGORIES= graphics
-MASTER_SITES= GOOGLE_CODE
-DISTNAME= SeamCarvingGui-Src-${PORTVERSION}
-
-MAINTAINER= buganini@gmail.com
-COMMENT= The Seam Carving GUI is a GUI front end to CAIR
-
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
-
-USES= dos2unix gmake qmake
-DOS2UNIX_GLOB= *.cpp
-USE_QT4= gui imageformats_run moc_build uic_build
-
-WRKSRC= ${WRKDIR}/Src\ Seam\ Carving\ GUI\ ${PORTVERSION}
-
-PLIST_FILES= bin/SeamCarvingGui
-
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/SeamCarvingGui ${STAGEDIR}${PREFIX}/bin
-
-.include <bsd.port.mk>
diff --git a/graphics/seam-carving-gui/distinfo b/graphics/seam-carving-gui/distinfo
deleted file mode 100644
index 75656738f401..000000000000
--- a/graphics/seam-carving-gui/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (SeamCarvingGui-Src-1.11.tar.gz) = 688e34b8e2934fe80f30d457d20feb3a599804aafe49d5acf6d26dfe81549c5c
-SIZE (SeamCarvingGui-Src-1.11.tar.gz) = 4334039
diff --git a/graphics/seam-carving-gui/files/patch-cair_CAIR.cpp b/graphics/seam-carving-gui/files/patch-cair_CAIR.cpp
deleted file mode 100644
index 9d6e31ba60dd..000000000000
--- a/graphics/seam-carving-gui/files/patch-cair_CAIR.cpp
+++ /dev/null
@@ -1,38 +0,0 @@
---- cair/CAIR.cpp.orig 2016-06-20 15:53:24 UTC
-+++ cair/CAIR.cpp
-@@ -276,7 +276,7 @@ inline CML_byte Grayscale_Pixel( CML_RGB
- //Our thread function for the Grayscale
- void * Gray_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
-
- while( true )
- {
-@@ -437,7 +437,7 @@ int Convolve_Pixel( CML_image_ptr * Sour
- //The thread function, splitting the image into strips
- void * Edge_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
-
- while( true )
- {
-@@ -744,7 +744,7 @@ CML_RGBA Average_Pixels( CML_RGBA Pixel1
- //This works like Remove_Quadrant, strips across the image.
- void * Add_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
- Thread_Params add_area;
-
- while( true )
-@@ -907,7 +907,7 @@ bool CAIR_Add( CML_image * Source, CML_i
- //the areas are not quadrants, rather, more like strips, but I keep the name convention
- void * Remove_Quadrant( void * id )
- {
-- int num = *((int *)id);
-+ long int num = *((long int *)id);
- Thread_Params remove_area;
-
- while( true )
diff --git a/graphics/seam-carving-gui/pkg-descr b/graphics/seam-carving-gui/pkg-descr
deleted file mode 100644
index e95fd54cbd15..000000000000
--- a/graphics/seam-carving-gui/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-The Seam Carving GUI is a GUI front end to CAIR, which is an implementation of
-Arial Shamir's seam carving algorithm (aka content aware image resizing, aka
-image retargeting).
-
-WWW: http://code.google.com/p/seam-carving-gui/
diff --git a/graphics/svgfig/Makefile b/graphics/svgfig/Makefile
deleted file mode 100644
index 1410be416d39..000000000000
--- a/graphics/svgfig/Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= SVGFig
-PORTVERSION= 1.1.6
-PORTREVISION= 1
-CATEGORIES= graphics python
-MASTER_SITES= GOOGLE_CODE
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME:tl}-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Draw mathematical figures in SVG using Python
-
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
-
-WRKSRC= ${WRKDIR}/${PORTNAME:tl}
-
-USES= python tar:tgz
-USE_PYTHON= distutils autoplist
-
-post-patch:
- @${REINPLACE_CMD} -e 's|1.1.2|${PORTVERSION}|' ${WRKSRC}/setup.py
-
-.include <bsd.port.mk>
diff --git a/graphics/svgfig/distinfo b/graphics/svgfig/distinfo
deleted file mode 100644
index 050665ee01e2..000000000000
--- a/graphics/svgfig/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (svgfig-1.1.6.tgz) = cfc98c662178011b4e5edf64a5bb4190eec523ddabfec3355e8e9101e499cd46
-SIZE (svgfig-1.1.6.tgz) = 25552
diff --git a/graphics/svgfig/pkg-descr b/graphics/svgfig/pkg-descr
deleted file mode 100644
index 4df03cf2f033..000000000000
--- a/graphics/svgfig/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-The SVGFig package lets you draw mathematical figures in Scalable
-Vector Graphics format (SVG), using the Python language.
-
-As a tool, its usefulness lies somewhere between freehand drawing
-programs, which don't give you quantitative control over your figures,
-and traditional plotting packages, which fit your data into a prescribed
-template. SVGFig allows you to draw anything you can express in Python.
-
-SVGFig is particularly suited to handle non-linear geometries. All
-lines, including the coordinate axis, curve if passed through a
-non-linear coordinate transformation, and coordinate systems can be
-nested in trees. This generalizes all the tools necessary for making
-plots, so it is easy to create polar plots of radial data, Hammer-Aitoff
-projections of the sky, translations in hyperbolic spaces, or experiment
-with new representations.
-
-SVGFig also maintains a convenient representation of SVG images as
-Python constructs, so you can load graphics from SVG files, dissect
-them, manipulate them with an automated script, and save them in batch.
-
-WWW: http://code.google.com/p/svgfig/