summaryrefslogtreecommitdiff
path: root/games/dcross/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/dcross/Makefile')
-rw-r--r--games/dcross/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/games/dcross/Makefile b/games/dcross/Makefile
deleted file mode 100644
index b84a966aaef3..000000000000
--- a/games/dcross/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= dcross
-PORTVERSION= 2.0
-PORTREVISION= 2
-CATEGORIES= games python
-MASTER_SITES= GOOGLE_CODE \
- SF/nemysisfreebsdp/games/:icons
-PROJECTHOST= double-cross
-DISTFILES= ${PORTNAME}_${DISTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}_icons${EXTRACT_SUFX}:icons
-DIST_SUBDIR= python
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Unconventional falling block game
-
-LICENSE= GPLv2
-
-BROKEN= Unfetchable (google code has gone away)
-DEPRECATED= Unfetchable for more than six months (google code has gone away)
-EXPIRATION_DATE= 2017-04-30
-
-RUN_DEPENDS= ${PYGAME}
-
-WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}/
-
-USES= dos2unix python zip
-DOS2UNIX_REGEX= .*.[^p][^n][^g]$
-DOS2UNIX_FILES= *.pyw
-
-INSTALLS_ICONS= yes
-ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
-
-SUB_FILES= ${PORTNAME}
-
-DESKTOP_ENTRIES="Double Cross" "" "${PORTNAME}" \
- "${PORTNAME}" "Game;ArcadeGame;" ""
-
-do-build:
- @${PYTHON_CMD} -m compileall ${WRKSRC}
- @${PYTHON_CMD} -O -m compileall ${WRKSRC}
-
-do-install:
- @${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
- ${WRKDIR}/${PORTNAME}
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
-
-.for s in ${ICON_SIZES}
- @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
- ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
-.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
-
-.include <bsd.port.mk>