summaryrefslogtreecommitdiff
path: root/emulators/vba/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/vba/Makefile')
-rw-r--r--emulators/vba/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index b4918986cd8d..df0c17d77d32 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -6,7 +6,7 @@
PORTNAME= vba
PORTVERSION= 1.7.2
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/VisualBoyAdvance/${PORTVERSION}
DISTNAME= VisualBoyAdvance-src-${PORTVERSION}
@@ -15,13 +15,16 @@ MAINTAINER= arundel@h3c.de
COMMENT= Open Source Gameboy Advance emulator
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
WANT_GNOME= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_SDL= sdl
-CONFIGURE_ARGS= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include" LIBS="-lintl"
+USE_GETTEXT= yes
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}" LIBS="-lintl"
WRKSRC= ${WRKDIR}/VisualBoyAdvance-${PORTVERSION}
PLIST_SUB= INSTALL_GTK2="@comment "