summaryrefslogtreecommitdiff
path: root/emulators/tpm-emulator/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/tpm-emulator/Makefile')
-rw-r--r--emulators/tpm-emulator/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/emulators/tpm-emulator/Makefile b/emulators/tpm-emulator/Makefile
index 56ffc4161823..8786332e580d 100644
--- a/emulators/tpm-emulator/Makefile
+++ b/emulators/tpm-emulator/Makefile
@@ -21,17 +21,17 @@ USE_RC_SUBR= tpmd
USE_LDCONFIG= YES
MAKE_JOBS_SAFE= YES
-CONFLICTS= trousers-tddl*
+CONFLICTS= trousers-tddl-[0-9d]*
WANTLIB= c
CMAKE_VERBOSE= YES
CMAKE_SOURCE_PATH= ${WRKSRC}
-NO_CONFIGURE= YES
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
CONFIGURE_WRKSRC= ${CMAKE_SOURCE_PATH}/build
-CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
+CMAKE_ENV= PREFIX=${PREFIX} ${CONFIGURE_ENV}
+CMAKE_ARGS= -DCMAKE_INCLUDE_PATH="${LOCALBASE}/include" \
-DCMAKE_EXE_LINKER_FLAGS="-L${LOCALBASE}/lib"
SUB_LIST= USERS=${USERS} GROUPS=${GROUPS}
@@ -42,9 +42,9 @@ GROUPS= _tss
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/README
-WRKSRC= ${WRKDIR}/${PORTNAME:S/-/_/}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${DISTNAME}
-post-patch:
+post-extract:
@${MKDIR} ${WRKSRC}/build
.include <bsd.port.mk>