summaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile81
1 files changed, 49 insertions, 32 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index dd665fd2aaed..d126766cc61f 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -2,28 +2,41 @@
# $FreeBSD$
PORTNAME= qemu
-DISTVERSION= 2.6.0
-PORTREVISION= 7
+PORTVERSION= 3.1.0
CATEGORIES= emulators
-MASTER_SITES= http://wiki.qemu.org/download/
+MASTER_SITES= https://download.qemu.org/
PKGNAMESUFFIX= -devel
+DIST_SUBDIR= qemu/${PORTVERSION}
MAINTAINER= bofh@FreeBSD.org
COMMENT= QEMU CPU Emulator - development version
LICENSE= GPLv2
-HAS_CONFIGURE= yes
-USES= cpe gmake pkgconfig bison perl5 python:2.7,build ssl tar:bzip2
+ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
+
+LIB_DEPENDS= libnettle.so:security/nettle \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libepoxy.so:graphics/libepoxy \
+ libpcre2-8.so:devel/pcre2
+
+USES= cpe gl gmake gnome pkgconfig bison perl5 python:2.7,build tar:xz
+USE_GNOME= cairo glib20 libxml2
USE_PERL5= build
USE_XORG= pixman
-USE_GNOME+= cairo glib20
-MAKE_ENV+= BSD_MAKE="${MAKE}"
-ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc64 hosts?
-OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
- CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
- STATIC_LINK DOCS
+#BROKEN_powerpc64= fails to compile: In function aio_bh_poll: internal compiler error: Segmentation fault
+
+#.if !defined(PKGNAMESUFFIX) || (${PKGNAMESUFFIX} != "-utils" && ${PKGNAMESUFFIX} != "-guest-agent")
+#.endif
+
+HAS_CONFIGURE= yes
+MAKE_ENV+= BSD_MAKE="${MAKE}" V=1
+
+OPTIONS_DEFINE= SAMBA X11 GTK3 OPENGL GNUTLS SASL JPEG PNG CURL \
+ VDE CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
+ STATIC_LINK DOCS NCURSES
SAMBA_DESC= samba dependency (for -smb)
GNUTLS_DESC= gnutls dependency (vnc encryption)
SASL_DESC= cyrus-sasl dependency (vnc encryption)
@@ -35,14 +48,16 @@ USBREDIR_DESC= usb device network redirection (experimental!)
GNS3_DESC= gns3 patches (promiscuous multicast)
X86_TARGETS_DESC= Build only x86 system targets
STATIC_LINK_DESC= Statically link the executables
-OPTIONS_DEFAULT=X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP GNS3
+VDE_DESC= vde dependency (for vde networking)
+OPTIONS_DEFAULT=X11 GTK3 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP GNS3 NCURSES VDE
OPTIONS_SUB= yes
X11_USE= SDL=sdl XORG=x11,xext GNOME=gdkpixbuf2
-X11_CONFIGURE_ON= --enable-sdl
-X11_CONFIGURE_OFF= --disable-sdl
-GTK2_USE= GNOME=gtk20,vte
-GTK2_USES= gettext
-GTK2_CONFIGURE_OFF= --disable-gtk --disable-vte
+X11_USES= sdl
+X11_CONFIGURE_ENABLE= sdl
+GTK3_LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon
+GTK3_USE= GNOME=gdkpixbuf2,gtk30,vte3 XORG=x11,xext
+GTK3_USES= gettext
+GTK3_CONFIGURE_OFF= --disable-gtk --disable-vte
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_CONFIGURE_OFF= --disable-gnutls
SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
@@ -53,37 +68,38 @@ PNG_LIB_DEPENDS= libpng.so:graphics/png
PNG_CONFIGURE_OFF= --disable-vnc-png
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_OFF= --disable-curl
-OPENGL_USE= GL=yes
+OPENGL_USE= GL=gl
OPENGL_CONFIGURE_OFF= --disable-opengl
USBREDIR_BUILD_DEPENDS= usbredir>=0.6:net/usbredir
USBREDIR_RUN_DEPENDS= usbredir>=0.6:net/usbredir
USBREDIR_CONFIGURE_OFF= --disable-usb-redir
PCAP_CONFIGURE_ON= --enable-pcap
-PCAP_EXTRA_PATCHES= ${FILESDIR}/pcap-patch ${FILESDIR}/pcap-patch-net_net.c
+PCAP_EXTRA_PATCHES= ${FILESDIR}/pcap-patch-qapi_net.json ${FILESDIR}/pcap-patch-net_net.c \
+ ${FILESDIR}/pcap-patch-net_clients.h
+VDE_LIB_DEPENDS= libvdeplug.so:net/vde2
+VDE_CONFIGURE_OFF= --disable-vde
STATIC_LINK_CONFIGURE_ON= --static
-STATIC_LINK_PREVENTS= GTK2 X11
+STATIC_LINK_PREVENTS= GTK3 X11
STATIC_LINK_PREVENTS_MSG= X11 ui cannot be built static
+NCURSES_USES= ncurses:base
SAMBA_USES= samba:run # smbd
+SAMBA_CONFIGURE_ON= --smbd=${LOCALBASE}/sbin/smbd
DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html
DOCS_USES= makeinfo
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=1
-PORTDOCS= docs qemu-doc.html qemu-tech.html qmp-commands.txt
+PORTDOCS= docs qemu-doc.html qemu-doc.txt qemu-ga-ref.html qemu-ga-ref.txt \
+ qemu-qmp-ref.html qemu-qmp-ref.txt
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
-LDFLAGS+= -L${OPENSSLLIB} -lcrypto
-CONFIGURE_ARGS+=--localstatedir=/var --extra-ldflags=-L\"${LOCALBASE}/lib\" \
- --disable-libssh2 --enable-debug \
- --prefix=${PREFIX} --cc=${CC} --enable-docs --disable-kvm \
+CONFIGURE_ARGS= --localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
+ --extra-ldflags=-L\"${LOCALBASE}/lib\" --disable-libssh2 --enable-debug \
+ --prefix=${PREFIX} --cc=${CC} --enable-netmap --enable-docs --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
- --smbd=${LOCALBASE}/sbin/smbd --enable-debug-info --python=${PYTHON_CMD} \
+ --enable-debug-info --python=${PYTHON_CMD} \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
-LIB_DEPENDS+= libnettle.so:security/nettle \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
-
.include <bsd.port.options.mk>
.if !defined(STRIP) || ${STRIP} == ""
@@ -106,6 +122,8 @@ MAKE_ARGS+= ARCH=ppc64
CONFIGURE_ARGS+= --sparc_cpu=v9
.endif
+PLIST_SUB+= LINUXBOOT_DMA=""
+
# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)
# but it shouldn't matter much
post-patch:
@@ -129,7 +147,7 @@ post-patch:
${WRKSRC}/scripts/texi2pod.pl
post-patch-CDROM_DMA-off:
- @${REINPLACE_CMD} -e '/USE_DMA_CDROM/d' ${WRKSRC}/hw/ide/internal.h
+ @${REINPLACE_CMD} -e '/USE_DMA_CDROM/d' ${WRKSRC}/include/hw/ide/internal.h
post-patch-GNS3-on:
@${REINPLACE_CMD} -e 's|(buf\[0\] & 1) && (rctl & E1000_RCTL_MPE)|buf[0] \& 1|' \
@@ -147,7 +165,6 @@ post-install:
${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifup.sample ${STAGEDIR}${PREFIX}/etc
${INSTALL_SCRIPT} ${FILESDIR}/qemu-ifdown.sample ${STAGEDIR}${PREFIX}/etc
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qemu-*
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ivshmem-*
post-install-DOCS-on:
@(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR}/)