summaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/calligra/Makefile2
-rw-r--r--editors/calligra/files/patch-kde_pr-41479569
-rw-r--r--editors/kile/Makefile2
-rw-r--r--editors/libreoffice/Makefile1
-rw-r--r--editors/libreoffice/files/patch-git_9065cd8d-poppler-0.8370
-rw-r--r--editors/openoffice-devel/Makefile2
-rw-r--r--editors/texstudio/Makefile1
-rw-r--r--editors/texworks/Makefile2
8 files changed, 145 insertions, 4 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 5289f7bdb5b7..cb285df07d4f 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -2,7 +2,7 @@
PORTNAME= calligra
DISTVERSION= 3.1.0
-PORTREVISION= 30
+PORTREVISION= 31
CATEGORIES= editors kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
diff --git a/editors/calligra/files/patch-kde_pr-414795 b/editors/calligra/files/patch-kde_pr-414795
new file mode 100644
index 000000000000..2a8e252f8c2d
--- /dev/null
+++ b/editors/calligra/files/patch-kde_pr-414795
@@ -0,0 +1,69 @@
+Source: Timo Gurr <timo.gurr@gmail.com>
+Upstream: Reported, https://bugs.kde.org/show_bug.cgi?id=414795
+Reason: Fix build with poppler 0.83.0
+
+diff -Naur calligra-3.1.0/filters/karbon/pdf/PdfImport.cpp calligra-3.1.0.new/filters/karbon/pdf/PdfImport.cpp
+--- filters/karbon/pdf/PdfImport.cpp 2019-12-04 12:41:13.000000000 +0100
++++ filters/karbon/pdf/PdfImport.cpp 2019-12-04 12:39:03.000000000 +0100
+@@ -60,19 +60,17 @@
+ }
+
+ // read config file
+- globalParams = new GlobalParams();
++ globalParams.reset(new GlobalParams());
+ if (! globalParams)
+ return KoFilter::NotImplemented;
+
+ GooString * fname = new GooString(QFile::encodeName(m_chain->inputFile()).data());
+ PDFDoc * pdfDoc = new PDFDoc(fname, 0, 0, 0);
+ if (! pdfDoc) {
+- delete globalParams;
+ return KoFilter::StupidError;
+ }
+
+ if (! pdfDoc->isOk()) {
+- delete globalParams;
+ delete pdfDoc;
+ return KoFilter::StupidError;
+ }
+@@ -99,7 +97,6 @@
+
+ delete dev;
+ delete pdfDoc;
+- delete globalParams;
+ globalParams = 0;
+
+ return KoFilter::OK;
+diff -Naur calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.cpp calligra-3.1.0.new/filters/karbon/pdf/SvgOutputDev.cpp
+--- filters/karbon/pdf/SvgOutputDev.cpp 2019-12-04 12:41:14.000000000 +0100
++++ filters/karbon/pdf/SvgOutputDev.cpp 2019-12-04 12:35:30.000000000 +0100
+@@ -172,7 +172,7 @@
+ *d->body << "/>" << endl;
+ }
+
+-QString SvgOutputDev::convertPath(GfxPath *path)
++QString SvgOutputDev::convertPath(const GfxPath *path)
+ {
+ if (! path)
+ return QString();
+@@ -180,7 +180,7 @@
+ QString output;
+
+ for (int i = 0; i < path->getNumSubpaths(); ++i) {
+- GfxSubpath * subpath = path->getSubpath(i);
++ const GfxSubpath * subpath = path->getSubpath(i);
+ if (subpath->getNumPoints() > 0) {
+ output += QString("M%1 %2").arg(subpath->getX(0)).arg(subpath->getY(0));
+ int j = 1;
+diff -Naur calligra-3.1.0/filters/karbon/pdf/SvgOutputDev.h calligra-3.1.0.new/filters/karbon/pdf/SvgOutputDev.h
+--- filters/karbon/pdf/SvgOutputDev.h 2019-12-04 12:41:14.000000000 +0100
++++ filters/karbon/pdf/SvgOutputDev.h 2019-12-04 12:30:41.000000000 +0100
+@@ -83,7 +83,7 @@
+ /// Dumps content to svg file
+ void dumpContent();
+ private:
+- QString convertPath(GfxPath *path);
++ QString convertPath(const GfxPath *path);
+ QString convertMatrix(const QMatrix &matrix);
+ QString convertMatrix(const double * matrix);
+ QString printFill();
diff --git a/editors/kile/Makefile b/editors/kile/Makefile
index f6f62b0386ee..7fe7fec6e8ef 100644
--- a/editors/kile/Makefile
+++ b/editors/kile/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kile
DISTVERSIONPREFIX= v
DISTVERSION= 3.0b3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors kde
MAINTAINER= kde@FreeBSD.org
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 672525ad8b43..e23a018291b3 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -1,4 +1,5 @@
# $FreeBSD$
+PORTREVISION= 1
.include "${.CURDIR}/Makefile.common"
diff --git a/editors/libreoffice/files/patch-git_9065cd8d-poppler-0.83 b/editors/libreoffice/files/patch-git_9065cd8d-poppler-0.83
new file mode 100644
index 000000000000..849e994dd895
--- /dev/null
+++ b/editors/libreoffice/files/patch-git_9065cd8d-poppler-0.83
@@ -0,0 +1,70 @@
+From 9065cd8d9a19864f6b618f2dc10daf577badd9ee Mon Sep 17 00:00:00 2001
+From: Martin Milata <martin@martinmilata.cz>
+Date: Wed, 4 Dec 2019 02:37:40 +0100
+Subject: [PATCH] Fix build with poppler-0.83
+
+Change-Id: I7a3684932b8f9c403a3368b42fa4d8039c67f1a9
+Reviewed-on: https://gerrit.libreoffice.org/84384
+Tested-by: Jenkins
+Reviewed-by: Michael Stahl <michael.stahl@cib.de>
+---
+ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 7 +++++++
+ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
+ sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx | 4 ++++
+ 3 files changed, 15 insertions(+)
+
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+index 26048177e87d..e9c2a407c279 100644
+--- sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
++++ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+@@ -491,11 +491,18 @@ void PDFOutDev::writeFontFile( GfxFont* gfxFont ) const
+ gfree(pBuf);
+ }
+
++#if POPPLER_CHECK_VERSION(0, 83, 0)
++void PDFOutDev::printPath( const GfxPath* pPath )
++#else
+ void PDFOutDev::printPath( GfxPath* pPath )
++#endif
+ {
+ int nSubPaths = pPath ? pPath->getNumSubpaths() : 0;
+ for( int i=0; i<nSubPaths; i++ )
+ {
++#if POPPLER_CHECK_VERSION(0, 83, 0)
++ const
++#endif
+ GfxSubpath* pSub = pPath->getSubpath( i );
+ const int nPoints = pSub->getNumPoints();
+
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+index 02f6b59f6f15..2e7d2186f9a1 100644
+--- sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
++++ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+@@ -149,7 +149,11 @@ namespace pdfi
+
+ int parseFont( long long nNewId, GfxFont* pFont, GfxState* state ) const;
+ void writeFontFile( GfxFont* gfxFont ) const;
++#if POPPLER_CHECK_VERSION(0, 83, 0)
++ static void printPath( const GfxPath* pPath );
++#else
+ static void printPath( GfxPath* pPath );
++#endif
+
+ public:
+ explicit PDFOutDev( PDFDoc* pDoc );
+diff --git a/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
+index 42178b650cdd..b1a54bd09c5f 100644
+--- sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
++++ sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
+@@ -68,7 +68,11 @@ int main(int argc, char **argv)
+ }
+
+ // read config file
++#if POPPLER_CHECK_VERSION(0, 83, 0)
++ globalParams = std::make_unique<GlobalParams>();
++#else
+ globalParams = new GlobalParams();
++#endif
+ globalParams->setErrQuiet(true);
+ #if defined(_MSC_VER)
+ globalParams->setupBaseFonts(nullptr);
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index a87a2b532789..a597b6bd2acd 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= apache-openoffice
PORTVERSION= ${AOOVERSION1}.${AOOVERSION2}.${TIMESTAMP}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 4
CATEGORIES= editors java
MASTER_SITES= https://dist.apache.org/repos/dist/dev/openoffice/${AOOVERSION}-${AOORC}-${TIMESTAMP}/source/ \
diff --git a/editors/texstudio/Makefile b/editors/texstudio/Makefile
index 96ca6eb5b713..a2f82cea694a 100644
--- a/editors/texstudio/Makefile
+++ b/editors/texstudio/Makefile
@@ -2,6 +2,7 @@
PORTNAME= texstudio
DISTVERSION= 2.12.18
+PORTREVISION= 1
CATEGORIES= editors
MAINTAINER= rigoletto@FreeBSD.org
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index 6a5bef574220..c77c0643989f 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -4,7 +4,7 @@
PORTNAME= texworks
DISTVERSIONPREFIX= release-
DISTVERSION= 0.6.2
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= editors
MAINTAINER= hrs@FreeBSD.org