summaryrefslogtreecommitdiff
path: root/editors/tea
diff options
context:
space:
mode:
Diffstat (limited to 'editors/tea')
-rw-r--r--editors/tea/Makefile3
-rw-r--r--editors/tea/distinfo6
-rw-r--r--editors/tea/files/patch-document.cpp11
3 files changed, 15 insertions, 5 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 36204346f982..bc2fcf7e3669 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tea
-PORTVERSION= 43.1.0
-PORTREVISION= 4
+PORTVERSION= 44.0.0
CATEGORIES= editors
MASTER_SITES= http://semiletov.org/tea/dloads/
diff --git a/editors/tea/distinfo b/editors/tea/distinfo
index daa6c5c58d57..ab84388a7c22 100644
--- a/editors/tea/distinfo
+++ b/editors/tea/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1474206271
-SHA256 (tea-43.1.0.tar.bz2) = 36fa3e28391d06f75f67926f5259999829c40c069fb76331a19f3528b463573a
-SIZE (tea-43.1.0.tar.bz2) = 398524
+TIMESTAMP = 1495472873
+SHA256 (tea-44.0.0.tar.bz2) = 3d4c4744b69ebe087e6947bd778a420db7fc5576c64f25a2962211f944c92dc1
+SIZE (tea-44.0.0.tar.bz2) = 404751
diff --git a/editors/tea/files/patch-document.cpp b/editors/tea/files/patch-document.cpp
new file mode 100644
index 000000000000..eedd21ddd106
--- /dev/null
+++ b/editors/tea/files/patch-document.cpp
@@ -0,0 +1,11 @@
+--- document.cpp.orig 2017-05-22 17:41:11 UTC
++++ document.cpp
+@@ -2570,7 +2570,7 @@ void CTEAEdit::rect_sel_cut (bool just_d
+ cursor.endEditBlock();
+
+ if (! just_del)
+- QApplication::clipboard()->setText (sl_copy.join ('\n'));
++ QApplication::clipboard()->setText (sl_copy.join ("\n"));
+ }
+
+