summaryrefslogtreecommitdiff
path: root/editors/tea/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/tea/Makefile')
-rw-r--r--editors/tea/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/editors/tea/Makefile b/editors/tea/Makefile
index 2a4f206072e0..18fb7ae45764 100644
--- a/editors/tea/Makefile
+++ b/editors/tea/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= tea
-PORTVERSION= 44.1.1
+PORTVERSION= 45.0.2
CATEGORIES= editors
-MASTER_SITES= http://semiletov.org/tea/dloads/
MAINTAINER= danilo@FreeBSD.org
COMMENT= Simple and powerful Qt-based text editor
@@ -20,10 +19,14 @@ OPTIONS_GROUP= SPELL
OPTIONS_GROUP_SPELL= ASPELL HUNSPELL
OPTIONS_DEFAULT= QT4 ASPELL HUNSPELL
-USES= pkgconfig:build qmake tar:bzip2
+USES= pkgconfig:build qmake
USE_GL= gl
USE_LOCALE= en_US.UTF-8
+USE_GITHUB= yes
+GH_ACCOUNT= psemiletov
+GH_PROJECT= ${PORTNAME}-qt
+
QT4_USES= qt:4
QT4_USE= qt=corelib,gui,moc_build,network,rcc_build
QT5_USES= qt:5
@@ -44,8 +47,6 @@ HUNSPELL_QMAKE_OFF= CONFIG+=nohunspell
post-patch:
@${REINPLACE_CMD} -e \
- 's|Q_OS_LINUX|Q_OS_UNIX|' ${WRKSRC}/document.cpp
- @${REINPLACE_CMD} -e \
's|/usr/include|${LOCALBASE}/include|' ${WRKSRC}/src.pro
do-install: