summaryrefslogtreecommitdiff
path: root/editors/lazarus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/lazarus/Makefile')
-rw-r--r--editors/lazarus/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 560abdc2b793..30a54a4fdafc 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -17,12 +17,13 @@ RUN_DEPENDS?= #
ONLY_FOR_ARCHS= i386 amd64
-USES= gmake
+USES= fpc gmake
USE_GNOME= #
USE_FPC?= cairo dblib fcl-base fcl-db fcl-fpcunit fcl-image fcl-json fcl-net \
fcl-registry fcl-res fcl-web fcl-xml gtk2 ibase iconvenc mysql \
numlib odbc openssl oracle pasjpeg postgres regexpr rtl-extra \
sqlite x11
+USE_XORG= x11
OPT?= "-Sgic "
MAKE_ENV= OPT=${OPT}
@@ -70,7 +71,7 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/gdb:devel/gdb
.endif
.if ${PORT_OPTIONS:MGTK2}
-USE_GNOME= gtk20 gdkpixbuf
+USE_GNOME= cairo gtk20 gdkpixbuf2
LCL_PLATFORM= gtk2
BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-gtk2
RUN_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-gtk2