summaryrefslogtreecommitdiff
path: root/editors/bingrok/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/bingrok/Makefile')
-rw-r--r--editors/bingrok/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/editors/bingrok/Makefile b/editors/bingrok/Makefile
new file mode 100644
index 000000000000..2b1cad00a7fa
--- /dev/null
+++ b/editors/bingrok/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= ${GH_PROJECT:tl}
+PORTVERSION= 0.0.1
+DISTVERSIONPREFIX= v
+CATEGORIES= editors
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Binary data editor for reverse engineering
+WWW= https://github.com/spuriousdata/BinGrok
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= qmake qt:5
+USE_QT= buildtools:build core gui widgets
+USE_GITHUB= yes
+GH_ACCOUNT= spuriousdata
+GH_PROJECT= BinGrok
+
+QMAKE_SOURCE_PATH= ${WRKSRC}/src
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${GH_PROJECT} \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>