summaryrefslogtreecommitdiff
path: root/dns/py-adns/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/py-adns/Makefile')
-rw-r--r--dns/py-adns/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
new file mode 100644
index 000000000000..176a0d71333c
--- /dev/null
+++ b/dns/py-adns/Makefile
@@ -0,0 +1,25 @@
+# Created by: Hye-Shik Chang <perky@fallin.lv>
+# $FreeBSD$
+
+PORTNAME= adns
+DISTVERSION= 1.4
+DISTVERSIONSUFFIX= -py1
+CATEGORIES= dns python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lebarondemerde@privacychain.ch
+COMMENT= Python module to resolve IPs to host names
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/GPL
+
+LIB_DEPENDS= libadns.so:dns/adns
+
+USES= localbase python:3.4+
+USE_PYTHON= autoplist distutils
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|1.4-py1|1.4|g' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>