summaryrefslogtreecommitdiff
path: root/devel/py-hatch-nodejs-version/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-hatch-nodejs-version/Makefile')
-rw-r--r--devel/py-hatch-nodejs-version/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/py-hatch-nodejs-version/Makefile b/devel/py-hatch-nodejs-version/Makefile
new file mode 100644
index 000000000000..7168be6e6c21
--- /dev/null
+++ b/devel/py-hatch-nodejs-version/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= hatch-nodejs-version
+DISTVERSION= 0.3.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= hatch_nodejs_version-${DISTVERSION}
+
+MAINTAINER= kai@FreeBSD.org
+COMMENT= Hatch plugin for versioning from a package.json file
+WWW= https://github.com/agoose77/hatch-nodejs-version
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0.21.0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0.21.0:devel/py-hatchling@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist pep517 pytest
+
+TEST_ENV= PYTHONPATH=${STAGEDIR}${PYTHON_SITELIBDIR}
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>