summaryrefslogtreecommitdiff
path: root/databases/mariadb100-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/mariadb100-server/Makefile')
-rw-r--r--databases/mariadb100-server/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/databases/mariadb100-server/Makefile b/databases/mariadb100-server/Makefile
index 67f59030b5a1..01b60786621f 100644
--- a/databases/mariadb100-server/Makefile
+++ b/databases/mariadb100-server/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME?= mariadb
-PORTVERSION= 10.0.27
-PORTREVISION= 3
+PORTVERSION= 10.0.29
CATEGORIES= databases ipv6
MASTER_SITES= http://ftp.osuosl.org/pub/${SITESDIR}/ \
http://mirrors.supportex.net/${SITESDIR}/ \
@@ -18,6 +17,7 @@ MAINTAINER= brnrd@FreeBSD.org
COMMENT?= Multithreaded SQL database (server)
LICENSE= GPLv2
+#LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_NAME_PerconaFT= PerconaFT patents license
LICENSE_FILE_PerconaFT= ${WRKSRC}/storage/tokudb/PerconaFT/PATENTS
LICENSE_PERMS_PerconaFT= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
@@ -117,6 +117,7 @@ ${ENGINE}_CMAKE_OFF= -DWITHOUT_${ENGINE}=1
MAXKEY_EXTRA_PATCHES+= ${FILESDIR}/extra-patch-include_my__compare.h
MROONGA_CMAKE_OFF= -DWITHOUT_MROONGA=1
+MROONGA_LIB_DEPENDS= liblz4.so:archivers/liblz4
OQGRAPH_LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libJudy.so:devel/judy
# Currently OQGraph does not build using clang.
@@ -132,9 +133,10 @@ post-install:
# These are "client" components, so there should be a switch that
# prevents them from being installed but it's unknown right now
. for f in bin/msql2mysql bin/mysql_config bin/mysql_find_rows \
- bin/mysqlaccess COPYING.AGPLv3 COPYING.GPLv2
+ bin/mysqlaccess COPYING.AGPLv3 COPYING.GPLv2 share/aclocal/mysql.m4
${RM} ${STAGEDIR}${PREFIX}/${f}
. endfor
+ ${RM} -r ${STAGEDIR}${DATADIR}/SELinux
.endif
.include <bsd.port.pre.mk>
@@ -146,8 +148,8 @@ CMAKE_ARGS+= -DWITH_JEMALLOC="no"
.endif
.if ${PORT_OPTIONS:MTOKUDB}
-NOT_FOR_ARCHS= i386
-NOT_FOR_ARCHS_REASON= TokuDB not supported on 32-bit platforms, see \
+NOT_FOR_ARCHS= i386
+NOT_FOR_ARCHS_REASON= TokuDB not supported on 32-bit platforms, see \
https://github.com/percona/PerconaFT/blob/master/README.md
.endif
@@ -169,4 +171,8 @@ post-patch:
${MV} ${WRKSRC}/storage/tokudb ${WRKSRC}/skip-tokudb
.endif
+post-configure-MROONGA-on:
+ ${REINPLACE_CMD} 's|-llz4|-L${LOCALBASE}/lib -llz4|' \
+ ${WRKSRC}/storage/mroonga/CMakeFiles/mroonga.dir/link.txt
+
.include <bsd.port.post.mk>