summaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/dsd/Makefile34
-rw-r--r--comms/dsd/distinfo3
-rw-r--r--comms/dsd/pkg-descr4
4 files changed, 42 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 5be917579df5..b5b9695f161b 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -35,6 +35,7 @@
SUBDIR += dfu-programmer
SUBDIR += dfu-util
SUBDIR += direwolf
+ SUBDIR += dsd
SUBDIR += dump1090
SUBDIR += ebook2cw
SUBDIR += ebook2cwgui
diff --git a/comms/dsd/Makefile b/comms/dsd/Makefile
new file mode 100644
index 000000000000..ba19c1553361
--- /dev/null
+++ b/comms/dsd/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= dsd
+PORTVERSION= 1.6.0
+CATEGORIES= comms hamradio
+
+MAINTAINER= takefu@airport.fm
+COMMENT= Decode several digital voice formats
+
+LICENSE= ISCL
+
+LIB_DEPENDS= libmbe.so:comms/mbelib
+
+USE_GITHUB= yes
+GH_ACCOUNT= szechyjs
+GH_TAGNAME= v${PORTVERSION}
+
+USE_LDCONFIG= yes
+PLIST_FILES= "@(,uucp,4555) bin/dsd"
+MAKE_ARGS= DEST_BASE=${STAGEDIR}${PREFIX}
+
+post-patch:
+ ${REINPLACE_CMD} 's|${PREFIX}|${LOCALBASE}|g;\
+ s|install|${INSTALL_PROGRAM}|g;\
+ s|gcc|${CC}|g'\
+ ${WRKSRC}/Makefile
+.for i in dsd.h dsd_file.c dsd_mbe.c
+ ${REINPLACE_CMD} 's|2250|2450|' ${WRKSRC}/${i}
+.endfor
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/comms/dsd/distinfo b/comms/dsd/distinfo
new file mode 100644
index 000000000000..7d85b7750b82
--- /dev/null
+++ b/comms/dsd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1486712916
+SHA256 (szechyjs-dsd-1.6.0-v1.6.0_GH0.tar.gz) = 44fa3ae108d2c11b4b67388d37fc6a63e8b44fc72fdd5db7b57d9eb045a9df58
+SIZE (szechyjs-dsd-1.6.0-v1.6.0_GH0.tar.gz) = 40959
diff --git a/comms/dsd/pkg-descr b/comms/dsd/pkg-descr
new file mode 100644
index 000000000000..029dfe79240f
--- /dev/null
+++ b/comms/dsd/pkg-descr
@@ -0,0 +1,4 @@
+DSD is able to decode several digital voice formats from discriminator
+tap audio and synthesize the decoded speech.
+
+WWW: https://github.com/szechyjs/dsd