summaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/quisk/Makefile2
-rw-r--r--comms/quisk/files/patch-quisk.py16
2 files changed, 17 insertions, 1 deletions
diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
index 6fb5d6b249b1..734e4b1d20be 100644
--- a/comms/quisk/Makefile
+++ b/comms/quisk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quisk
DISTVERSION= 4.1.40
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms hamradio
MASTER_SITES= CHEESESHOP
diff --git a/comms/quisk/files/patch-quisk.py b/comms/quisk/files/patch-quisk.py
new file mode 100644
index 000000000000..528a179c413e
--- /dev/null
+++ b/comms/quisk/files/patch-quisk.py
@@ -0,0 +1,16 @@
+--- quisk.py.orig 2019-06-18 23:38:53 UTC
++++ quisk.py
+@@ -23,6 +23,13 @@ os.chdir(os.path.normpath(os.path.dirnam
+ if sys.path[0] != "'.'": # Make sure the current working directory is on path
+ sys.path.insert(0, '.')
+
++# Hack to ensure unicode is available.
++import locale
++locale.setlocale(locale.LC_ALL, '')
++cloc = locale.getdefaultlocale()
++if locale.nl_langinfo(locale.CODESET) != 'UTF-8':
++ locale.setlocale(locale.LC_ALL, (cloc[0], 'UTF-8'))
++
+ import wx, wx.html, wx.lib.stattext, wx.lib.colourdb, wx.grid, wx.richtext
+ import math, cmath, time, traceback, string, select, subprocess
+ import threading, pickle, webbrowser