summaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
Diffstat (limited to 'comms')
-rw-r--r--comms/quisk/Makefile2
-rw-r--r--comms/quisk/files/patch-quisk__widgets.py7
2 files changed, 4 insertions, 5 deletions
diff --git a/comms/quisk/Makefile b/comms/quisk/Makefile
index 522ef53825a6..6a5544487342 100644
--- a/comms/quisk/Makefile
+++ b/comms/quisk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quisk
DISTVERSION= 4.1.40
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms hamradio
MASTER_SITES= CHEESESHOP
diff --git a/comms/quisk/files/patch-quisk__widgets.py b/comms/quisk/files/patch-quisk__widgets.py
index 26379d6eaf8c..4137747f96ac 100644
--- a/comms/quisk/files/patch-quisk__widgets.py
+++ b/comms/quisk/files/patch-quisk__widgets.py
@@ -1,6 +1,6 @@
---- quisk_widgets.py.orig 2019-06-19 06:35:39 UTC
+--- quisk_widgets.py.orig 2019-05-28 12:22:59 UTC
+++ quisk_widgets.py
-@@ -248,7 +248,16 @@ class SliderBoxH:
+@@ -248,7 +248,15 @@ class SliderBoxH:
else:
self.text_ctrl = wx.StaticText(parent, -1, t, pos=pos)
w2, h2 = self.text_ctrl.GetSize()
@@ -10,10 +10,9 @@
+ p2 = pos[1]
+ if h3 > h2:
+ p2 -= (h3 - h2) / 2
-+ h2 = h3
+ else:
+ p2 += (h2 - h3) / 2
-+ self.slider.SetSize((width - w2, h2))
++ self.slider.SetSize((width - w2, h3))
+ self.slider.SetPosition((pos[0] + w2, p2))
self.slider.Bind(wx.EVT_SCROLL, self.OnScroll)
self.text_ctrl.SetForegroundColour(parent.GetForegroundColour())