summaryrefslogtreecommitdiff
path: root/chinese/sourcehanserif-tc-otf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/sourcehanserif-tc-otf/Makefile')
-rw-r--r--chinese/sourcehanserif-tc-otf/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/chinese/sourcehanserif-tc-otf/Makefile b/chinese/sourcehanserif-tc-otf/Makefile
new file mode 100644
index 000000000000..eb1c8948734e
--- /dev/null
+++ b/chinese/sourcehanserif-tc-otf/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= sourcehanserif
+PORTVERSION= 1.001
+DISTVERSIONSUFFIX= R
+CATEGORIES= chinese x11-fonts
+PKGNAMESUFFIX= -tc-otf
+# Note: the following PKGNAMEPREFIX is here only for self-documenting purpose;
+# actual prefixing is done by the `chinese' category itself.
+#PKGNAMEPREFIX= zh-
+
+MAINTAINER= hyun@caffeinated.codes
+COMMENT= Traditional Chinese font by Adobe designed for user interfaces
+
+LICENSE= OFL11
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= fonts
+USE_GITHUB= yes
+GH_ACCOUNT= adobe-fonts
+GH_PROJECT= source-han-serif
+
+NO_ARCH= yes
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+OPTIONS_SINGLE= TYPE
+OPTIONS_SINGLE_TYPE= FULL SUBSET
+OPTIONS_DEFAULT= FULL
+OPTIONS_SUB= yes
+
+FULL_DESC= Install the full font (can display all CJK)
+SUBSET_DESC= Install the subset font (can display TC only)
+
+FULL_VARS= FONTNAME=SourceHanSerifTC SRCFONTSDIR=OTF/TraditionalChinese
+SUBSET_VARS= FONTNAME=SourceHanSerifTW SRCFONTSDIR=SubsetOTF/TW
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${SRCFONTSDIR}/*.otf ${STAGEDIR}${FONTSDIR}
+
+.include <bsd.port.mk>