summaryrefslogtreecommitdiff
path: root/audio/guspat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/guspat/Makefile')
-rw-r--r--audio/guspat/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/audio/guspat/Makefile b/audio/guspat/Makefile
new file mode 100644
index 000000000000..5e166c02bc1f
--- /dev/null
+++ b/audio/guspat/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: guspat
+# Date created: 2004/07/04
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= guspat
+PORTVERSION= 20000706
+CATEGORIES= audio
+MASTER_SITES= http://www.linet.gr.jp/~tamuki/timidity/eawplus/
+DISTFILES= ${PORTNAME}-${PORTVERSION}-required${EXTRACT_SUFX} \
+ ${PORTNAME}-${PORTVERSION}-optional${EXTRACT_SUFX}
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= Izumo collection of Gravis Ultrasound MIDI patches
+
+# Not useful without timidity.
+RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity++
+
+RESTRICTED= Some of the patches are marked no-commercial-use
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/timidity
+PLIST_SUB= TIMIDITY_DATADIR=${TIMIDITY_DATADIR}
+
+TIMIDITY_DATADIR= share/timidity
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @${CP} -pr ${WRKSRC}/* ${DATADIR}
+ @${MKDIR} ${PREFIX}/${TIMIDITY_DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/timidity.cfg ${PREFIX}/${TIMIDITY_DATADIR}/timidity.cfg-guspat
+
+.include <bsd.port.mk>