summaryrefslogtreecommitdiff
path: root/audio/creox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/creox/Makefile')
-rw-r--r--audio/creox/Makefile56
1 files changed, 21 insertions, 35 deletions
diff --git a/audio/creox/Makefile b/audio/creox/Makefile
index a66a62094d8d..e84e4443b181 100644
--- a/audio/creox/Makefile
+++ b/audio/creox/Makefile
@@ -1,49 +1,35 @@
-# New ports collection makefile for: Creox
-# Date created: 18 Aug 2009
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= creox
-DISTVERSION= 0.2.2rc2
-PORTREVISION= 5
+PORTVERSION= 0.3.0
CATEGORIES= audio kde
-MASTER_SITES= http://zyzstar.kosoru.com/projects/creox/downloads/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A real-time sound processor
+COMMENT= Realtime sound processor
-LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack
+LICENSE= GPLv2
-DEPRECATED= Depends on QT3; unmaintained
-EXPIRATION_DATE= 2013-07-01
+LIB_DEPENDS= jack:${PORTSDIR}/audio/jack
-USE_BZIP2= yes
-USE_AUTOTOOLS= libtool
-GNU_CONFIGURE= yes
-USE_GETTEXT= yes
-USE_KDELIBS_VER=3
-INSTALLS_ICONS= yes
+USE_GITHUB= yes
+GH_ACCOUNT= laudrup
+GH_PROJECT= Creox4
+GH_TAGNAME= 0.3
+GH_COMMIT= 8e27483
+
+USE_XORG= xft xpm
+USE_KDE4= automoc4 kdelibs kdeprefix
+USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_CMAKE= yes
+CMAKE_OUTSOURCE=yes
+MAKE_JOBS_SAFE= yes
post-patch:
-# Fix bogus test(1) syntax and remove superfluous -O2
- @${REINPLACE_CMD} -E 's,(if \[ [[:graph:]]+ )==,\1=, ; \
- s,-O2,,' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ '/-Wno-unused-but-set-variable/d' ${WRKSRC}/CMakeLists.txt
# FreeBSD does not have exp10f(3), use powf(3) instead
- @${REINPLACE_CMD} -e 's|exp10f(|powf(10., |' \
- ${WRKSRC}/creox/dsp_flow/threadeffector.cpp \
- ${WRKSRC}/creox/effects_dsp/tremoloprocessor.cpp \
- ${WRKSRC}/creox/effects_dsp/phaserprocessor.cpp \
- ${WRKSRC}/creox/effects_dsp/flangerprocessor.cpp \
- ${WRKSRC}/creox/effects_dsp/echoprocessor.cpp \
- ${WRKSRC}/creox/effects_dsp/distortionprocessor.cpp
-# Fix std::fmaf (remove std:: prefix)
- @${REINPLACE_CMD} -e 's,std::fmaf,fmaf,' \
- ${WRKSRC}/creox/effects_dsp/tremoloprocessor.cpp \
- ${WRKSRC}/creox/effects_dsp/echoprocessor.cpp
-# Add missing closing parentheses on line 186
- @${REINPLACE_CMD} -e '186s,);,)&,' \
- ${WRKSRC}/creox/effects_dsp/tremoloprocessor.cpp
+ @${GREP} -lR "exp10f(" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|exp10f(|powf(10.,|'
.include <bsd.port.mk>