summaryrefslogtreecommitdiff
path: root/archivers
diff options
context:
space:
mode:
Diffstat (limited to 'archivers')
-rw-r--r--archivers/py-borgbackup/Makefile3
-rw-r--r--archivers/py-borgbackup/files/patch-setup.py11
2 files changed, 12 insertions, 2 deletions
diff --git a/archivers/py-borgbackup/Makefile b/archivers/py-borgbackup/Makefile
index 0956f7557e7a..71e4c38ed241 100644
--- a/archivers/py-borgbackup/Makefile
+++ b/archivers/py-borgbackup/Makefile
@@ -12,8 +12,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.7:devel/py-setuptools_scm@${PY_FLAVOR}
LIB_DEPENDS= liblz4.so:archivers/liblz4 \
- libzstd.so:archivers/zstd \
- libxxhash.so:devel/xxhash
+ libzstd.so:archivers/zstd
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=19.0:devel/py-packaging@${PY_FLAVOR}
USES= python:3.5+ ssl
diff --git a/archivers/py-borgbackup/files/patch-setup.py b/archivers/py-borgbackup/files/patch-setup.py
new file mode 100644
index 000000000000..399dc0b58daa
--- /dev/null
+++ b/archivers/py-borgbackup/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2022-07-16 16:20:52 UTC
++++ setup.py
+@@ -23,7 +23,7 @@ prefer_system_libzstd = True
+ prefer_system_libb2 = True
+
+ # True: use the shared libxxhash (>= 0.6.5 [>= 0.7.2 on ARM]) from the system, False: use the bundled xxhash code
+-prefer_system_libxxhash = True
++prefer_system_libxxhash = False
+
+ # prefer_system_msgpack is another option, but you need to set it in src/borg/helpers.py.
+