summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/abiword-devel/Makefile26
-rw-r--r--editors/abiword-devel/pkg-plist16
-rw-r--r--editors/abiword-plugins-devel/Makefile2
3 files changed, 22 insertions, 22 deletions
diff --git a/editors/abiword-devel/Makefile b/editors/abiword-devel/Makefile
index 167369c5e1c5..3cf6a21af813 100644
--- a/editors/abiword-devel/Makefile
+++ b/editors/abiword-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= abiword
PORTVERSION= 2.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= http://www.abisource.com/downloads/%SUBDIR%/${PORTVERSION}/source/
MASTER_SITE_SUBDIR= abiword
@@ -28,7 +28,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
-USE_GNOME= gnomehier libglade2 libxml2
+USE_GNOME= libglade2 libxml2 libgnomeprintui desktopfileutils
WANT_GNOME= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
@@ -40,7 +40,8 @@ CONFIGURE_ARGS= --enable-xft \
--with-libpng=${LOCALBASE} \
--with-libiconv=${LOCALBASE} \
--with-libjpeg-prefix=${LOCALBASE} \
- --disable-peer-config
+ --disable-peer-config \
+ --enable-gnome
MAKEFILE= GNUmakefile
ABIVERSION= 2.4
@@ -62,13 +63,6 @@ PLIST_SUB+= DICT:=""
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mlibgnomeprintui}!=""
-USE_GNOME+= libgnomeprintui desktopfileutils
-CONFIGURE_ARGS+= --enable-gnome
-PKGNAMESUFFIX= -devel-gnome
-GNOME_ENABLED= yes
-.endif
-
.if defined(WITH_GUCHARMAP) || exists(${X11BASE}/libdata/pkgconfig/gucharmap.pc)
LIB_DEPENDS+= gucharmap.4:${PORTSDIR}/deskutils/gucharmap
.else
@@ -93,19 +87,23 @@ post-patch:
s|WV_INCLUDES = |#WV_INCLUDES = |g ; \
s|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
+ @${REINPLACE_CMD} -e 's|(bindir)/ttfadmin.sh|(bindir)/ttfadmin24.sh|g' \
+ ${WRKSRC}/src/tools/scripts/unix/GNUmakefile.in
+ @${REINPLACE_CMD} -e 's|(bindir)/ttftool|(bindir)/ttftool24|g' \
+ ${WRKSRC}/src/tools/ttftool/unix/GNUmakefile.in
post-install:
@${MKDIR} ${PREFIX}/lib/AbiWord-${ABIVERSION}/plugins
-.if defined(GNOME_ENABLED)
+ @${MKDIR} ${X11BASE}/share/applications
@${INSTALL_DATA} ${WRKSRC}/abiword.desktop \
- ${X11BASE}/share/gnome/applications/abiword24.desktop
+ ${X11BASE}/share/applications/abiword24.desktop
+ @${MKDIR} ${X11BASE}/share/pixmaps
@${LN} -sf ${PREFIX}/share/AbiSuite-${ABIVERSION}/icons/abiword_48.png \
- ${X11BASE}/share/gnome/pixmaps/abiword24_48.png
+ ${X11BASE}/share/pixmaps/abiword24_48.png
# @${INSTALL_DATA} ${WRKDIR}/abiword-${PORTVERSION}/abidistfiles/GNOME_AbiWord_Control_${ABIVERSION:S/./_/}.server \
# ${X11BASE}/libdata/bonobo/servers/
# @${INSTALL_DATA} ${WRKDIR}/abiword-${PORTVERSION}/abidistfiles/abi-nautilus-view-file.xml \
# ${X11BASE}/share/gnome/gnome-2.0/ui/
@-update-desktop-database
-.endif
.include <bsd.port.post.mk>
diff --git a/editors/abiword-devel/pkg-plist b/editors/abiword-devel/pkg-plist
index dedf3a71befb..2d18edd8ec19 100644
--- a/editors/abiword-devel/pkg-plist
+++ b/editors/abiword-devel/pkg-plist
@@ -1,6 +1,6 @@
bin/AbiWord-%%ABIVERSION%%
-bin/ttfadmin.sh
-bin/ttftool
+bin/ttfadmin24.sh
+bin/ttftool24
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Break.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_Field.glade
share/AbiSuite-%%ABIVERSION%%/AbiWord/glade/ap_UnixDialog_FormatFootnotes.glade
@@ -202,7 +202,7 @@ share/AbiSuite-%%ABIVERSION%%/icons/abiword_16.xpm
share/AbiSuite-%%ABIVERSION%%/icons/abiword_48.png
share/AbiSuite-%%ABIVERSION%%/icons/abiword_48.tif
share/AbiSuite-%%ABIVERSION%%/icons/abiword_48.xpm
-%%GNOME:%%share/AbiSuite-%%ABIVERSION%%/icons/abiword_logo.xpm
+share/AbiSuite-%%ABIVERSION%%/icons/abiword_logo.xpm
share/AbiSuite-%%ABIVERSION%%/templates/A4.awt
share/AbiSuite-%%ABIVERSION%%/templates/Business-Letter.awt
share/AbiSuite-%%ABIVERSION%%/templates/Business-Report.awt
@@ -274,8 +274,10 @@ share/AbiSuite-%%ABIVERSION%%/templates/normal.awt-ur_PK
share/AbiSuite-%%ABIVERSION%%/templates/normal.awt-yi
share/AbiSuite-%%ABIVERSION%%/templates/normal.awt-zh_CN
share/AbiSuite-%%ABIVERSION%%/templates/normal.awt-zh_TW
-%%GNOME:%%share/gnome/applications/abiword24.desktop
-%%GNOME:%%share/gnome/pixmaps/abiword24_48.png
+share/applications/abiword24.desktop
+share/pixmaps/abiword24_48.png
+@unexec rmdir %D/share/pixmaps 2> /dev/null || true
+@unexec rmdir %D/share/applications 2> /dev/null || true
@dirrm share/AbiSuite-%%ABIVERSION%%/templates
@dirrm share/AbiSuite-%%ABIVERSION%%/icons
@dirrm share/AbiSuite-%%ABIVERSION%%/dictionary
@@ -287,5 +289,5 @@ share/AbiSuite-%%ABIVERSION%%/templates/normal.awt-zh_TW
@dirrm share/AbiSuite-%%ABIVERSION%%
@dirrm lib/AbiWord-%%ABIVERSION%%/plugins
@dirrm lib/AbiWord-%%ABIVERSION%%
-%%GNOME:%%@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-%%GNOME:%%@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
diff --git a/editors/abiword-plugins-devel/Makefile b/editors/abiword-plugins-devel/Makefile
index dbbaf0c29dc6..d6f01e327354 100644
--- a/editors/abiword-plugins-devel/Makefile
+++ b/editors/abiword-plugins-devel/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --disable-all
MAKEFILE= GNUmakefile
WRKSRC= ${WRKDIR}/abiword-${PORTVERSION}/abiword-plugins
-MD5_FILE= ${.CURDIR}/../abiword/distinfo
+MD5_FILE= ${.CURDIR}/../abiword-devel/distinfo
ABIVERSION= 2.4
PLIST_SUB+= ABIVERSION=${ABIVERSION}