summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/showbeastie/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/sysutils/showbeastie/Makefile b/sysutils/showbeastie/Makefile
index e92885a7ea92..e7615e17f33b 100644
--- a/sysutils/showbeastie/Makefile
+++ b/sysutils/showbeastie/Makefile
@@ -23,22 +23,28 @@ ALL_TARGET= testmain
PLIST_FILES= bin/${PORTNAME}
# Make sure building succeeds on HEAD
+CFLAGS+= -I/usr/include # uses -nostdinc
MAKE_ARGS+= -m ${SRC_BASE}/share/mk
BROKEN_armv6= fails to link: testmain uses VFP register arguments, dict.o does not
-BROKEN_armv7= fails to install: tar: could not chdir to '/usr/src/sys/boot'
BROKEN_mips64= fails to link: relocation truncated to fit: R_MIPS_26 against `__assert@@FBSD_1.0'
WRKSRC_SUBDIR= ficl
+.if exists(${SRC_BASE}/sys/boot/ficl/testmain.c)
+SRC_STAND= ${SRC_BASE}/sys/boot
+.else
+SRC_STAND= ${SRC_BASE}/stand
+.endif
+
pre-patch:
@${MKDIR} ${WRKSRC}
- @${TAR} -C ${SRC_BASE}/sys/boot \
+ @${TAR} -C ${SRC_STAND} \
--exclude '*.o' --exclude '*.a' --exclude 'testmain' \
-cf - . | ${TAR} -C ${WRKSRC}/.. -xf -
post-patch:
- ${REINPLACE_CMD} 's|-I.*/\.\./common|-I${SRC_BASE}/sys/boot/common|g' \
+ ${REINPLACE_CMD} 's|-I.*/\.\./common|-I${SRC_STAND}/common|g' \
${WRKSRC}/Makefile
# Make sure building on FreeBSD 11.0/i386 works. Calls to biospci_* are not