summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--cad/adms/Makefile9
-rw-r--r--cad/gtkwave/Makefile2
-rw-r--r--cad/leocad/Makefile2
-rw-r--r--cad/pdnmesh/Makefile2
-rw-r--r--cad/repsnapper/Makefile2
-rw-r--r--chinese/librime/Makefile3
-rw-r--r--chinese/scim-tables/Makefile2
-rw-r--r--chinese/sunpinyin/Makefile8
-rw-r--r--comms/cwdaemon/Makefile8
-rw-r--r--comms/deforaos-phone/Makefile2
-rw-r--r--comms/efax-gtk/Makefile2
-rw-r--r--comms/fldigi/Makefile2
-rw-r--r--comms/libticables2/Makefile3
-rw-r--r--comms/libticalcs2/Makefile3
-rw-r--r--comms/qtel/Makefile2
-rw-r--r--comms/rtl-sdr/Makefile2
-rw-r--r--comms/tilp2/Makefile2
-rw-r--r--converters/gbase/Makefile8
-rw-r--r--converters/libticonv/Makefile3
-rw-r--r--converters/pdf2djvu/Makefile2
-rw-r--r--converters/wkhtmltopdf/Makefile2
21 files changed, 25 insertions, 46 deletions
diff --git a/cad/adms/Makefile b/cad/adms/Makefile
index 11292cf261da..416b5645a33f 100644
--- a/cad/adms/Makefile
+++ b/cad/adms/Makefile
@@ -1,10 +1,5 @@
-# New ports collection makefile for: adms
-# Date created: 2006-07-29
-# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
-#
-# $MBSDlabs$
+# Created by: Stanislav Sedov <ssedov@mbsd.msk.ru>
# $FreeBSD$
-#
PORTNAME= adms
PORTVERSION= 2.3.0
@@ -18,10 +13,10 @@ COMMENT= A model generator for SPICE simulators
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= pkgconfig
USE_GNOME= glib20
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_PKGCONFIG= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
diff --git a/cad/gtkwave/Makefile b/cad/gtkwave/Makefile
index d968b3cd5d2f..8438f881549d 100644
--- a/cad/gtkwave/Makefile
+++ b/cad/gtkwave/Makefile
@@ -10,10 +10,10 @@ DISTNAME= gtkwave-${PORTVERSION}
MAINTAINER= zeising@FreeBSD.org
COMMENT= Electronic Waveform Viewer
+USES= pkgconfig
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk20 desktopfileutils
-USE_PKGCONFIG= build
INSTALLS_ICONS= yes
OPTIONS_DEFINE= TCL
diff --git a/cad/leocad/Makefile b/cad/leocad/Makefile
index 4eb2c170519c..a24d0b64ca7a 100644
--- a/cad/leocad/Makefile
+++ b/cad/leocad/Makefile
@@ -18,9 +18,9 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= pkgconfig
USE_GL= gl
USE_GNOME= gtk20
-USE_PKGCONFIG= build
USE_GMAKE= yes
INSTALLS_ICONS= yes
MAKE_JOBS_SAFE= yes
diff --git a/cad/pdnmesh/Makefile b/cad/pdnmesh/Makefile
index 8db4f502f696..e0e13eab8346 100644
--- a/cad/pdnmesh/Makefile
+++ b/cad/pdnmesh/Makefile
@@ -26,12 +26,12 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
OPTIONS_DEFINE= ATLAS DOCS EXAMPLES
ATLAS_DESC= Enable ATLAS support
+USES= pkgconfig
USE_FORTRAN= yes
USE_GL= glu
USE_GETTEXT= yes
USE_ICONV= yes
USE_GNOME= gdkpixbuf2 gtk20
-USE_PKGCONFIG= build
USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
xfixes xmu xi xinerama xrandr xrender xt xxf86vm
GNU_CONFIGURE= yes
diff --git a/cad/repsnapper/Makefile b/cad/repsnapper/Makefile
index 36a930906a85..da940485785a 100644
--- a/cad/repsnapper/Makefile
+++ b/cad/repsnapper/Makefile
@@ -37,12 +37,12 @@ LIB_DEPENDS= gtkglext:${PORTSDIR}/x11-toolkits/gtkglext \
xcb:${PORTSDIR}/x11/libxcb
MAKE_JOBS_SAFE= yes
+USES= pkgconfig
USE_GNOME= gdkpixbuf2 gtk20 libxml2
USE_GL= glu glut
USE_AUTOTOOLS= automake libtool
USE_GMAKE= yes
USE_ICONV= yes
-USE_PKGCONFIG= build
USE_XORG= ice pixman sm x11 xau xcomposite xcursor xdamage xdmcp xext \
xfixes xi xinerama xmu xrandr xrender xt xxf86vm
diff --git a/chinese/librime/Makefile b/chinese/librime/Makefile
index 93b0a8e8b189..ad214722b757 100644
--- a/chinese/librime/Makefile
+++ b/chinese/librime/Makefile
@@ -18,9 +18,8 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
opencc:${PORTSDIR}/chinese/opencc \
yaml-cpp:${PORTSDIR}/devel/yaml-cpp
-USES= cmake
+USES= cmake pkgconfig
USE_GETTEXT= yes
-USE_PKGCONFIG= yes
USE_LDCONFIG= yes
USE_XORG= xproto
USE_PERL5_BUILD= yes
diff --git a/chinese/scim-tables/Makefile b/chinese/scim-tables/Makefile
index 927404c28b9a..635dc62dec7f 100644
--- a/chinese/scim-tables/Makefile
+++ b/chinese/scim-tables/Makefile
@@ -13,9 +13,9 @@ COMMENT= SCIM table based Chinese input methods
BUILD_DEPENDS= scim-make-table:${PORTSDIR}/textproc/scim-table-imengine
RUN_DEPENDS= scim-make-table:${PORTSDIR}/textproc/scim-table-imengine
+USES= pkgconfig
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_PKGCONFIG= build
.include <bsd.port.pre.mk>
diff --git a/chinese/sunpinyin/Makefile b/chinese/sunpinyin/Makefile
index 4d7c8de35dcc..210adf2d6fa4 100644
--- a/chinese/sunpinyin/Makefile
+++ b/chinese/sunpinyin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sunpinyin
-# Date created: 10 Nov 2011
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= sunpinyin
DISTVERSION= 2.0.4rc2
@@ -26,11 +22,11 @@ LIB_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
LICENSE_FILE_LGPL21= ${WRKSRC}/LGPL.LICENSE
LICENSE_FILE_CDDL= ${WRKSRC}/OPENSOLARIS.LICENSE
+USES= pkgconfig
USE_XZ= yes
USE_SCONS= yes
SCONS_ARGS+= --prefix=${PREFIX} --libdatadir=${PREFIX}/share
USE_LDCONFIG= yes
-USE_PKGCONFIG= yes
USE_GMAKE= yes
post-patch:
diff --git a/comms/cwdaemon/Makefile b/comms/cwdaemon/Makefile
index 6bd588051f7a..7c6f1f8db50a 100644
--- a/comms/cwdaemon/Makefile
+++ b/comms/cwdaemon/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: cwdaemon
-# Date created: 17 Mar 2005
-# Whom: Diane Bruce <db@db.net>
-#
+# Created by: Diane Bruce <db@db.net>
# $FreeBSD$
-#
PORTNAME= cwdaemon
PORTVERSION= 0.9.4
@@ -19,7 +15,7 @@ LIB_DEPENDS= cw:${PORTSDIR}/comms/unixcw
INSTALL_TARGET= install-exec
GNU_CONFIGURE= yes
-USE_PKGCONFIG= yes
+USES= pkgconfig
CONFIGURE_ARGS+= --datadir=${PREFIX}/share/doc
MAN8= cwdaemon.8
diff --git a/comms/deforaos-phone/Makefile b/comms/deforaos-phone/Makefile
index 2fa3cce8f97b..6f2dc2cf6223 100644
--- a/comms/deforaos-phone/Makefile
+++ b/comms/deforaos-phone/Makefile
@@ -22,8 +22,8 @@ LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
BUILD_DEPENDS= locker:${PORTSDIR}/x11/deforaos-locker \
${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
+USES= pkgconfig
USE_GNOME= gtk20 desktopfileutils
-USE_PKGCONFIG= build
USE_GETTEXT= yes
INSTALLS_ICONS= yes
MAKE_ARGS+= PREFIX=${PREFIX}
diff --git a/comms/efax-gtk/Makefile b/comms/efax-gtk/Makefile
index b1fb7817e049..d524cda6fdc3 100644
--- a/comms/efax-gtk/Makefile
+++ b/comms/efax-gtk/Makefile
@@ -27,11 +27,11 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS= ggv:${PORTSDIR}/print/ggv
+USES= pkgconfig
USE_ICONV= yes
USE_GHOSTSCRIPT_RUN=yes
USE_GNOME= gdkpixbuf2 gtk20
GNU_CONFIGURE= yes
-USE_PKGCONFIG= build
USE_GCC= 4.4+
USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext xfixes \
xi xinerama xrandr xrender
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index a45d2d395739..c7ed7a0dda92 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -19,8 +19,8 @@ LIB_DEPENDS= samplerate:${PORTSDIR}/audio/libsamplerate\
fltk:${PORTSDIR}/x11-toolkits/fltk
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GMAKE= yes
-USE_PKGCONFIG= build
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config"
MAN1= fldigi.1
diff --git a/comms/libticables2/Makefile b/comms/libticables2/Makefile
index cef175711bfc..5a5a898719d4 100644
--- a/comms/libticables2/Makefile
+++ b/comms/libticables2/Makefile
@@ -14,8 +14,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
-USES= pathfix
+USES= pathfix pkgconfig
OPTIONS_DEFINE= NLS
diff --git a/comms/libticalcs2/Makefile b/comms/libticalcs2/Makefile
index f42148ef158f..a3945f098788 100644
--- a/comms/libticalcs2/Makefile
+++ b/comms/libticalcs2/Makefile
@@ -18,8 +18,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
-USES= pathfix
+USES= pathfix pkgconfig
OPTIONS_DEFINE= NLS
diff --git a/comms/qtel/Makefile b/comms/qtel/Makefile
index fe40c589d064..bb757cc38bf4 100644
--- a/comms/qtel/Makefile
+++ b/comms/qtel/Makefile
@@ -35,10 +35,10 @@ MAN5= svxlink.conf.5 \
ModuleSelCallEnc.conf.5 \
remotetrx.conf.5
MANCOMPRESSED= yes
+USES= pkgconfig
USE_GMAKE= yes
USE_QT_VER= 3
USE_TCL= yes
-USE_PKGCONFIG= yes
USE_RC_SUBR= svxlink remotetrx
USE_LDCONFIG= ${LOCALBASE}/lib ${LOCALBASE}/lib/svxlink
diff --git a/comms/rtl-sdr/Makefile b/comms/rtl-sdr/Makefile
index b745456647f2..a46ee8390ca3 100644
--- a/comms/rtl-sdr/Makefile
+++ b/comms/rtl-sdr/Makefile
@@ -13,7 +13,7 @@ COMMENT= Commandline tool that performs SDR with RTL2832-based USB sticks
LICENSE= GPLv2
-USE_PKGCONFIG= yes
+USES= pkgconfig
USE_AUTOTOOLS= autoconf:env aclocal:env automake:env libtool
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/comms/tilp2/Makefile b/comms/tilp2/Makefile
index 8047429bb9d3..8f997629f710 100644
--- a/comms/tilp2/Makefile
+++ b/comms/tilp2/Makefile
@@ -15,10 +15,10 @@ LIB_DEPENDS= ticables2:${PORTSDIR}/comms/libticables2 \
ticalcs2:${PORTSDIR}/comms/libticalcs2 \
ticonv:${PORTSDIR}/converters/libticonv
+USES= pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gtk20
-USE_PKGCONFIG= build
OPTIONS_DEFINE= NLS
diff --git a/converters/gbase/Makefile b/converters/gbase/Makefile
index 91762c9615f1..eed5a7b6549f 100644
--- a/converters/gbase/Makefile
+++ b/converters/gbase/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gbase
-# Date created: Fri Sep 7 22:08:24 EDT 2001
-# Whom: Patrick Li <pat@databits.net>
-#
+# Created by: Patrick Li <pat@databits.net>
# $FreeBSD$
-#
PORTNAME= gbase
PORTVERSION= 0.5
@@ -19,7 +15,7 @@ LICENSE= ART10
OPTIONS_DEFINE= GTK2
PLIST_FILES= bin/${PORTNAME}
-USE_PKGCONFIG= yes
+USES= pkgconfig
.include <bsd.port.options.mk>
diff --git a/converters/libticonv/Makefile b/converters/libticonv/Makefile
index b72574161bec..d9ec3cd3ebfe 100644
--- a/converters/libticonv/Makefile
+++ b/converters/libticonv/Makefile
@@ -15,7 +15,6 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
-USES= pathfix
+USES= pathfix pkgconfig
.include <bsd.port.mk>
diff --git a/converters/pdf2djvu/Makefile b/converters/pdf2djvu/Makefile
index c0bd065c8f5a..dc9c6b89ef93 100644
--- a/converters/pdf2djvu/Makefile
+++ b/converters/pdf2djvu/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS+= djvulibre:${PORTSDIR}/graphics/djvulibre
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS=-pthread
CPPFLAGS+= -I${LOCALBASE}/include
+USES= pkgconfig
USE_GMAKE= yes
-USE_PKGCONFIG= yes
BROKEN= does not build
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index b0387e693542..032550f2c8f5 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -20,11 +20,11 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-qt
INSTALL_WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
WKQTVERSION= 6053b687
+USES= pkgconfig
USE_XORG= x11 xext xrender
USE_PERL5_BUILD= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_PKGCONFIG= build
HAS_CONFIGURE= yes
MAKE_JOBS_SAFE= yes