summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/hyprland-devel/Makefile2
-rw-r--r--x11-wm/hyprland/Makefile2
-rw-r--r--x11/hyprpaper/Makefile2
-rw-r--r--x11/hyprpicker/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/x11-wm/hyprland-devel/Makefile b/x11-wm/hyprland-devel/Makefile
index 59142f4c05d2..f3c69cfe63f7 100644
--- a/x11-wm/hyprland-devel/Makefile
+++ b/x11-wm/hyprland-devel/Makefile
@@ -44,7 +44,7 @@ post-patch:
# Extract (snapshot) version from the port instead of meson.build
@${REINPLACE_CMD} -i .nogit -e "/GIT_BRANCH/s/run_command.*/'main'/" \
-e "/GIT_COMMIT_HASH/s/run_command.*/'${DISTVERSIONFULL}'/" \
- -e "/GIT_COMMIT_MESSAGE/s/run_command.*/'?'/" \
+ -e "/GIT_COMMIT_MESSAGE/d" \
-e "/GIT_DIRTY/s/run_command.*/'portbld'/" \
-e "/version.*jq/s/run_command.*/'${DISTVERSIONFULL}',/" \
${WRKSRC}/meson.build
diff --git a/x11-wm/hyprland/Makefile b/x11-wm/hyprland/Makefile
index ae1f42316f7a..c1e6919c4302 100644
--- a/x11-wm/hyprland/Makefile
+++ b/x11-wm/hyprland/Makefile
@@ -48,7 +48,7 @@ post-patch:
# Extract (snapshot) version from the port instead of meson.build
@${REINPLACE_CMD} -i .nogit -e "/GIT_BRANCH/s/run_command.*/'main'/" \
-e "/GIT_COMMIT_HASH/s/run_command.*/'${DISTVERSIONFULL}'/" \
- -e "/GIT_COMMIT_MESSAGE/s/run_command.*/'?'/" \
+ -e "/GIT_COMMIT_MESSAGE/d" \
-e "/GIT_DIRTY/s/run_command.*/'portbld'/" \
-e "/version.*jq/s/run_command.*/'${DISTVERSIONFULL}',/" \
${WRKSRC}/meson.build
diff --git a/x11/hyprpaper/Makefile b/x11/hyprpaper/Makefile
index f037808c149d..1d5e15833ec1 100644
--- a/x11/hyprpaper/Makefile
+++ b/x11/hyprpaper/Makefile
@@ -28,7 +28,7 @@ post-patch:
@${REINPLACE_CMD} -i .nogit -e '/Get git info/,/^#$$/d' \
-e 's/$${GIT_BRANCH}/main/' \
-e 's/$${GIT_COMMIT_HASH}/${GH_TAGNAME}/' \
- -e 's/$${GIT_COMMIT_MESSAGE}/?/' \
+ -e '/$${GIT_COMMIT_MESSAGE}/d' \
-e 's/$${GIT_DIRTY}/portbld/' \
${WRKSRC}/CMakeLists.txt
# https://clang.llvm.org/cxx_status.html#cxx23
diff --git a/x11/hyprpicker/Makefile b/x11/hyprpicker/Makefile
index 181e78316ebb..487e3fced9e2 100644
--- a/x11/hyprpicker/Makefile
+++ b/x11/hyprpicker/Makefile
@@ -33,7 +33,7 @@ post-patch:
@${REINPLACE_CMD} -i .nogit -e '/Get git info/,/^#$$/d' \
-e 's/$${GIT_BRANCH}/main/' \
-e 's/$${GIT_COMMIT_HASH}/${GH_TAGNAME}/' \
- -e 's/$${GIT_COMMIT_MESSAGE}/?/' \
+ -e '/$${GIT_COMMIT_MESSAGE}/d' \
-e 's/$${GIT_DIRTY}/portbld/' \
${WRKSRC}/CMakeLists.txt
# https://clang.llvm.org/cxx_status.html#cxx23