summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/strawberry/Makefile2
-rw-r--r--biology/py-pandas-charm/Makefile3
-rw-r--r--databases/py-pymemcache/Makefile2
-rw-r--r--deskutils/hs-arbtt/Makefile1
-rw-r--r--devel/agar/Makefile5
-rw-r--r--devel/libsavitar/Makefile1
-rw-r--r--emulators/open-vm-tools/Makefile2
-rw-r--r--misc/darknet/Makefile2
-rw-r--r--science/Makefile2
-rw-r--r--www/fusionpbx/Makefile3
-rw-r--r--x11/Makefile2
11 files changed, 8 insertions, 17 deletions
diff --git a/audio/strawberry/Makefile b/audio/strawberry/Makefile
index dab96bec378f..f2886a7de091 100644
--- a/audio/strawberry/Makefile
+++ b/audio/strawberry/Makefile
@@ -48,8 +48,6 @@ OPTIONS_DEFINE= APPLEDEV AUDIOCD IPOD MOODBAR MTPDEV MUSICBRAINZ \
APPLEDEV_IMPLIES= IPOD
OPTIONS_DEFAULT= PULSEAUDIO
-BACKEND_DESC= Multimedia backend(s)
-
OPTIONS_MULTI= SOUND
OPTIONS_MULTI_SOUND= ALSA PULSEAUDIO
diff --git a/biology/py-pandas-charm/Makefile b/biology/py-pandas-charm/Makefile
index 88e67c4937c6..d01a4d16aa20 100644
--- a/biology/py-pandas-charm/Makefile
+++ b/biology/py-pandas-charm/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pandas-charm
DISTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= biology python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,7 @@ COMMENT= Library for getting character matrices into and out of pandas
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPEDNS= ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils autoplist
diff --git a/databases/py-pymemcache/Makefile b/databases/py-pymemcache/Makefile
index b7b1dba939e4..7561ee6412a6 100644
--- a/databases/py-pymemcache/Makefile
+++ b/databases/py-pymemcache/Makefile
@@ -19,8 +19,6 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-DEVELOPER= yes
-
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v
diff --git a/deskutils/hs-arbtt/Makefile b/deskutils/hs-arbtt/Makefile
index 25a294ac8894..60c5e4f86bdf 100644
--- a/deskutils/hs-arbtt/Makefile
+++ b/deskutils/hs-arbtt/Makefile
@@ -61,7 +61,6 @@ SUB_LIST= EXAMPLESDIR=${EXAMPLESDIR}
OPTIONS_DEFINE= MANPAGES
OPTIONS_SUB= yes
-MANPAGES_DESCRIBE= Build and/or install manpages
OPTIONS_DEFAULT= MANPAGES
diff --git a/devel/agar/Makefile b/devel/agar/Makefile
index 3566a5dfe246..3c982a929225 100644
--- a/devel/agar/Makefile
+++ b/devel/agar/Makefile
@@ -10,8 +10,8 @@ COMMENT= Cross-platform GUI toolkit
LICENSE= BSD2CLAUSE
-BROKEN_powerpc64_12= fails to compile: cpuinfo.c:289: error: 'IllegalInsn' undeclared (first use in this function)
-BROKEN_powerpc64_13= fails to compile: include/agar/core/byteswap.h:46:8: error: unsupported inline asm: input with type 'int' matching output with type 'u_int16_t' (aka 'unsigned short')
+BROKEN_FreeBSD_12_powerpc64= fails to compile: cpuinfo.c:289: error: 'IllegalInsn' undeclared (first use in this function)
+BROKEN_FreeBSD_13_powerpc64= fails to compile: include/agar/core/byteswap.h:46:8: error: unsupported inline asm: input with type 'int' matching output with type 'u_int16_t' (aka 'unsigned short')
USES= libtool pathfix perl5 pkgconfig jpeg
USE_PERL5= build
@@ -42,7 +42,6 @@ SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
SNDFILE_IMPLIES= PORTAUDIO
GUI_CONFIGURE_ENABLE= gui
-GUI_USE= JPEG=jpeg
GUI_CONFIGURE_ON= --with-jpeg=${LOCALBASE} \
--with-png=${LOCALBASE} \
diff --git a/devel/libsavitar/Makefile b/devel/libsavitar/Makefile
index 4298f63814b3..046ff79c058b 100644
--- a/devel/libsavitar/Makefile
+++ b/devel/libsavitar/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= libpugixml.so:textproc/pugixml
USES= cmake compiler:c++11-lang python:3.4+
USE_GITHUB= yes
GH_ACCOUNT= Ultimaker
-USE_GITHUB= yes
GH_TAGNAME= 96eba0e
USE_LDCONFIG= yes
CFLAGS+= "-I${LOCALBASE}/include"
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index ff69c5f9ebae..f2dc37294b07 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -27,7 +27,7 @@ OPTIONS_DEFAULT= DOCS LIBNOTIFY OPENSSL X11
OPTIONS_SUB=
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
-DOCS_CONFIGURE= docs
+DOCS_CONFIGURE_ENABLE= docs
LIBNOTIFY_DESC= Desktop notification support
diff --git a/misc/darknet/Makefile b/misc/darknet/Makefile
index faa0c0f1e631..95bb701a7b78 100644
--- a/misc/darknet/Makefile
+++ b/misc/darknet/Makefile
@@ -40,8 +40,6 @@ OPENCV_CMAKE_BOOL= ENABLE_OPENCV
OPENCV_LIB_DEPENDS= libopencv_video.so:graphics/opencv \
libopencv_core.so:graphics/opencv-core
-OPTIONS_GROUP= SIMD
-OPTIONS_GROUP_SIMD_amd64= SSE2 SSE3 SSE4 AVX
SSE2_DESC= Use SSE2 instructions
SSE2_CMAKE_ON= -DFREEBSD_SIMD="-msse2"
SSE3_DESC= Use SSE3 instructions
diff --git a/science/Makefile b/science/Makefile
index aec90583453c..b76fd30d96cd 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -76,8 +76,8 @@
SUBDIR += erkale
SUBDIR += erkale-pseudopotentials
SUBDIR += fastcap
- SUBDIR += fastjet
SUBDIR += fasthenry
+ SUBDIR += fastjet
SUBDIR += fisicalab
SUBDIR += fleur
SUBDIR += fsom
diff --git a/www/fusionpbx/Makefile b/www/fusionpbx/Makefile
index 2c52521bd2f6..ef956fb3dac5 100644
--- a/www/fusionpbx/Makefile
+++ b/www/fusionpbx/Makefile
@@ -25,7 +25,6 @@ USE_GITHUB= yes
VARBASE= var
-WRKSRC_SUBDIR= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
OPTIONS_DEFINE= PDOPGSQL
@@ -41,7 +40,7 @@ PDOPGSQL_USE= PHP=pgsql,pdo_pgsql
do-install:
@${MKDIR} ${STAGEDIR}${WWWDIR}
- @(cd ${WRKSRC_SUBDIR} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
@${MKDIR} ${STAGEDIR}/${VARBASE}/db/fusionpbx
@${MKDIR} ${STAGEDIR}/${VARBASE}/cache/fusionpbx
diff --git a/x11/Makefile b/x11/Makefile
index 3a445805d770..d3421e86c5f4 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -243,7 +243,7 @@
SUBDIR += pipeglade
SUBDIR += pixman
SUBDIR += plank
- SUBDIR += plasma-wayland-protocols
+ SUBDIR += plasma-wayland-protocols
SUBDIR += plasma5-kactivitymanagerd
SUBDIR += plasma5-kgamma5
SUBDIR += plasma5-kscreen