summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/mumble/Makefile2
-rw-r--r--chinese/gcin-qt5/Makefile12
-rw-r--r--databases/ldb12/Makefile2
-rw-r--r--databases/p5-Tie-LevelDB/Makefile2
-rw-r--r--databases/rocksdb/Makefile6
-rw-r--r--devel/astyle/Makefile2
-rw-r--r--devel/gdb/Makefile4
-rw-r--r--devel/libastylej/Makefile2
-rw-r--r--devel/llvm-cheri/Makefile4
-rw-r--r--devel/rapidjson/Makefile2
-rw-r--r--devel/thrift-cpp/Makefile2
-rw-r--r--editors/libreoffice/Makefile7
-rw-r--r--editors/openoffice-4/Makefile8
-rw-r--r--editors/openoffice-devel/Makefile2
-rw-r--r--games/rubix/Makefile2
-rw-r--r--games/stockfish/Makefile2
-rw-r--r--graphics/aaphoto/Makefile2
-rw-r--r--www/node/Makefile2
-rw-r--r--www/node10/Makefile2
-rw-r--r--www/node6/Makefile2
-rw-r--r--www/node8/Makefile2
-rw-r--r--x11-toolkits/fox17/Makefile2
22 files changed, 28 insertions, 45 deletions
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index 6fe88e8508d8..1de5f3aa0f0e 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -62,7 +62,7 @@ PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
.include <bsd.port.pre.mk>
# PCH is broken on GCC
-.if ${COMPILER_TYPE} == gcc
+.if ${CHOSEN_COMPILER_TYPE} == gcc
CONFIG+= no-pch
.endif
diff --git a/chinese/gcin-qt5/Makefile b/chinese/gcin-qt5/Makefile
index 52dc0bc29beb..48d40a02aa55 100644
--- a/chinese/gcin-qt5/Makefile
+++ b/chinese/gcin-qt5/Makefile
@@ -25,18 +25,8 @@ MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
PLIST_FILES= ${QT_PLUGINDIR}/platforminputcontexts/libgcinplatforminputcontextplugin.so
-.include <bsd.port.pre.mk>
-
-.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 60
-BUILD_DEPENDS+= ${LOCALBASE}/bin/clang60:devel/llvm60
-CPP= ${LOCALBASE}/bin/clang-cpp60
-CC= ${LOCALBASE}/bin/clang60
-CXX= ${LOCALBASE}/bin/clang++60
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g; \
s,%%MOC%%,${MOC},;' ${WRKSRC}/Makefile
- @${ECHO} "XXXX: ${COMPILER_VERSION}"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/ldb12/Makefile b/databases/ldb12/Makefile
index 9673603b639c..4564fa0647ad 100644
--- a/databases/ldb12/Makefile
+++ b/databases/ldb12/Makefile
@@ -133,7 +133,7 @@ BUILD_DEPENDS+= ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/do
xsltproc:textproc/libxslt
.endif
# No fancy color error messages
-.if ${COMPILER_TYPE} == "clang"
+.if ${CHOSEN_COMPILER_TYPE} == clang
CFLAGS+= -fno-color-diagnostics
.endif
CONFIGURE_ENV+= NOCOLOR=yes
diff --git a/databases/p5-Tie-LevelDB/Makefile b/databases/p5-Tie-LevelDB/Makefile
index 7cdd13abdbfd..77450daadeb0 100644
--- a/databases/p5-Tie-LevelDB/Makefile
+++ b/databases/p5-Tie-LevelDB/Makefile
@@ -26,7 +26,7 @@ MAKE_ARGS= CC="${CXX}"
.include <bsd.port.pre.mk>
-.if ${COMPILER_TYPE} == clang
+.if ${CHOSEN_COMPILER_TYPE} == clang
CFLAGS+= -Wno-reserved-user-defined-literal
.endif
diff --git a/databases/rocksdb/Makefile b/databases/rocksdb/Makefile
index e94430e45875..ada5df14058a 100644
--- a/databases/rocksdb/Makefile
+++ b/databases/rocksdb/Makefile
@@ -68,14 +68,10 @@ PLIST_SUB+= LITE=${PKGNAMESUFFIX}
.include <bsd.port.pre.mk>
-.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 36
+.if ${CHOSEN_COMPILER_TYPE} == clang
CXXFLAGS+= -Wno-inconsistent-missing-override
.endif
-.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} < 60
-CFLAGS+= -D_GLIBCXX_USE_C99
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/^dummy :=/d; /^all: / s| $$(TESTS)||' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's| -fno-builtin-memcmp||; s| -ltcmalloc||' ${WRKSRC}/build_tools/build_detect_platform
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index e6c951f365a4..03e6a845cfa0 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -22,7 +22,7 @@ USES= compiler:c++11-lang dos2unix gmake
ALL_TARGET= astyle
DOS2UNIX_GLOB= *.ini
-WRKSRC= ${WRKDIR}/astyle/build/${COMPILER_TYPE}
+WRKSRC= ${WRKDIR}/astyle/build/${CHOSEN_COMPILER_TYPE}
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 66ae0aafe799..058b8310b8db 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -92,11 +92,11 @@ EXCLUDE+= readline
EXCLUDE+= zlib
.endif
-.if ${ARCH} == "amd64"
+.if ${ARCH} == amd64
CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
-.if ${COMPILER_TYPE} == "clang"
+.if ${CHOSEN_COMPILER_TYPE} == clang
CFLAGS+= -Wno-extended-offsetof
.endif
diff --git a/devel/libastylej/Makefile b/devel/libastylej/Makefile
index 3b60317f7df0..4868cda3d897 100644
--- a/devel/libastylej/Makefile
+++ b/devel/libastylej/Makefile
@@ -20,7 +20,7 @@ USE_JAVA= yes
USE_LDCONFIG= yes
MAKE_ARGS+= JAVA_HOME=${JAVA_HOME}
-WRKSRC= ${WRKDIR}/astyle/build/${COMPILER_TYPE}
+WRKSRC= ${WRKDIR}/astyle/build/${CHOSEN_COMPILER_TYPE}
PLIST_FILES= lib/jni/libastylej${PKGNAMESUFFIX}.so lib/jni/libastylej${PKGNAMESUFFIX}.so.${PORTVERSION}
diff --git a/devel/llvm-cheri/Makefile b/devel/llvm-cheri/Makefile
index 87fd2db6c589..a04a331ceccc 100644
--- a/devel/llvm-cheri/Makefile
+++ b/devel/llvm-cheri/Makefile
@@ -195,13 +195,13 @@ MAN1SRCS+= bugpoint.1 dsymutil.1 llc.1 lli.1 llvm-ar.1 llvm-as.1 \
.include <bsd.port.pre.mk>
-.if ${OPSYS} == "FreeBSD" && ${COMPILER_TYPE} != clang
+.if ${OPSYS} == FreeBSD && ${CHOSEN_COMPILER_TYPE} != clang
# Evil hack around gcc48 not providing a usable c++11 environment on 9.x
PLIST_SUB:= ${PLIST_SUB:NLLDB=*} LLDB="@comment "
.endif
post-extract-LLDB-on:
-.if ${OPSYS} != "FreeBSD" || ${COMPILER_TYPE} == clang
+.if ${OPSYS} != FreeBSD || ${CHOSEN_COMPILER_TYPE} == clang
${MV} ${WRKSRC_lldb} ${PATCH_WRKSRC}/tools/lldb
.endif
diff --git a/devel/rapidjson/Makefile b/devel/rapidjson/Makefile
index cb3f043dd8b5..2e7db4608ab1 100644
--- a/devel/rapidjson/Makefile
+++ b/devel/rapidjson/Makefile
@@ -41,7 +41,7 @@ CXXFLAGS_powerpc= -Wno-error
CXXFLAGS_powerpcspe= -Wno-error
CXXFLAGS_powerpc64= -Wno-error
CXXFLAGS_sparc64= -Wno-error
-.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 50
+.if ${CHOSEN_COMPILER_TYPE} == clang
CXXFLAGS+= -Wno-zero-as-null-pointer-constant
.endif
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 1781f42599b9..652d67fe2808 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -63,7 +63,7 @@ EXPIRATION_DATE= 2019-03-15
.include <bsd.port.pre.mk>
-.if ${COMPILER_TYPE} == clang
+.if ${CHOSEN_COMPILER_TYPE} == clang
USE_CXXSTD= c++11
.endif
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index d8cf16de9351..a3ddd68ccb59 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -286,11 +286,8 @@ EXPIRATION_DATE= 2018-12-31
.include <bsd.port.pre.mk>
-.if ${COMPILER_TYPE} == "clang"
-CXXFLAGS_WARN= -Woverloaded-virtual -Wno-unused-parameter
-.if ${COMPILER_VERSION} >= 36
-CXXFLAGS_WARN+= -Wno-unused-local-typedefs
-.endif
+.if ${CHOSEN_COMPILER_TYPE} == clang
+CXXFLAGS_WARN= -Woverloaded-virtual -Wno-unused-parameter -Wno-unused-local-typedefs
.else
CXXFLAGS_WARN= -Wshadow -Woverloaded-virtual
.endif
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index ff0145744e25..1cbba62f64e3 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -207,9 +207,9 @@ CONFIGURE_ARGS+= --enable-symbols
.include <${FILESDIR}/Makefile.localized>
-.if ${COMPILER_TYPE} == clang
+.if ${CHOSEN_COMPILER_TYPE} == clang
CPPFLAGS+= -I${LOCALBASE}/include
-. if ${COMPILER_VERSION} >= 40 && ${ARCH} == amd64
+. if ${ARCH} == amd64
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-align16
. endif
.endif
@@ -368,7 +368,7 @@ post-patch:
${REINPLACE_CMD} -e "s|%%JAVA_HOME%%|${JAVA_HOME}|" \
${WRKSRC}/desktop/scripts/soffice.sh
${REINPLACE_CMD} -e '/^mkdir -p/,$$d' ${CREATE_TREE}
-.if ${COMPILER_TYPE} == gcc
+.if ${CHOSEN_COMPILER_TYPE} == gcc
# g++49 -Os sometimes leaves inline class methods undefined,
# affects fmgridif.cxx and ColumnControl.cxx
# See: <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65009>
@@ -376,7 +376,7 @@ post-patch:
${REINPLACE_CMD} -e "s/ := -Os/ := -Os -fno-devirtualize -fno-devirtualize-speculatively/" ${WRKSRC}/solenv/gbuild/platform/freebsd.mk; \
${REINPLACE_CMD} -e "s/=-Os /=-Os -fno-devirtualize -fno-devirtualize-speculatively /" ${WRKSRC}/solenv/inc/unxfbsdi.mk; \
fi
-.elif ${ARCH} == i386 && ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 36
+.elif ${ARCH} == i386 && ${CHOSEN_COMPILER_TYPE} == clang
# autodoc and uno (bridgetest) core dump when built with with -Os
# on i386, affects file.cxx and bridgetest.cxx (at least).
# Using -O2 optimiztion works, and -Os is essentially -O2 with out
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index a1bb8fd0f23b..1ebfd5d49355 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -241,7 +241,7 @@ CONFIGURE_ARGS+= --without-commons-logging
.include <${FILESDIR}/Makefile.localized>
-.if ${COMPILER_TYPE} == clang
+.if ${CHOSEN_COMPILER_TYPE} == clang
CPPFLAGS+= -I${LOCALBASE}/include
.endif
diff --git a/games/rubix/Makefile b/games/rubix/Makefile
index b3689a7604e7..97154cd89eed 100644
--- a/games/rubix/Makefile
+++ b/games/rubix/Makefile
@@ -24,7 +24,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if (${ARCH} == mips || ${ARCH} == mips64 || ${ARCH} == powerpc || ${ARCH} == powerpc64) && ${COMPILER_TYPE} == gcc
+.if (${ARCH} == mips || ${ARCH} == mips64 || ${ARCH} == powerpc || ${ARCH} == powerpc64) && ${CHOSEN_COMPILER_TYPE} == gcc
CFLAGS+= -fnested-functions
.endif
diff --git a/games/stockfish/Makefile b/games/stockfish/Makefile
index 1174d83766e3..00b4fabd8387 100644
--- a/games/stockfish/Makefile
+++ b/games/stockfish/Makefile
@@ -24,7 +24,7 @@ USES= compiler:c++11-lang gmake zip
NO_WRKSUBDIR= yes
WRKSRC_SUBDIR= src
MYARCH= ${ARCH}
-MYCC= ${COMPILER_TYPE}
+MYCC= ${CHOSEN_COMPILER_TYPE}
TGTBLD= build
PLIST_FILES= bin/stockfish
diff --git a/graphics/aaphoto/Makefile b/graphics/aaphoto/Makefile
index 915e14dd11e6..827f2af1e19c 100644
--- a/graphics/aaphoto/Makefile
+++ b/graphics/aaphoto/Makefile
@@ -28,7 +28,7 @@ PLIST_FILES= bin/aaphoto
.include <bsd.port.pre.mk>
-.if (${ARCH} == "amd64" || ${ARCH} == "i386") && ${COMPILER_TYPE} == gcc
+.if (${ARCH} == amd64 || ${ARCH} == i386) && ${CHOSEN_COMPILER_TYPE} == gcc
CFLAGS+= -fopenmp -D__OPENMP__
.endif
diff --git a/www/node/Makefile b/www/node/Makefile
index 7c8ef8d7b39e..2cbe61d2fd04 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -82,7 +82,7 @@ IGNORE= cannot build node.js with LibreSSL. You must enable BUNDLED_SSL
CONFIGURE_ARGS+=--openssl-no-asm
.endif
-.if ${COMPILER_TYPE} == gcc
+.if ${CHOSEN_COMPILER_TYPE} == gcc
# GCC does not expose std::snprintf() without this define
CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
diff --git a/www/node10/Makefile b/www/node10/Makefile
index 90c2ba943264..95ce32a9ad1b 100644
--- a/www/node10/Makefile
+++ b/www/node10/Makefile
@@ -83,7 +83,7 @@ IGNORE= cannot build node.js with LibreSSL. You must enable BUNDLED_SSL
CONFIGURE_ARGS+=--openssl-no-asm
.endif
-.if ${COMPILER_TYPE} == gcc
+.if ${CHOSEN_COMPILER_TYPE} == gcc
# GCC does not expose std::snprintf() without this define
CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
diff --git a/www/node6/Makefile b/www/node6/Makefile
index 409b8557e154..843e614ce2d9 100644
--- a/www/node6/Makefile
+++ b/www/node6/Makefile
@@ -74,7 +74,7 @@ IGNORE= cannot build node.js with LibreSSL. You must enable BUNDLED_SSL
CONFIGURE_ARGS+=--openssl-no-asm
.endif
-.if ${COMPILER_TYPE} == gcc
+.if ${CHOSEN_COMPILER_TYPE} == gcc
# GCC does not expose std::snprintf() without this define
CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
diff --git a/www/node8/Makefile b/www/node8/Makefile
index 5fad2021d524..62b23fcc56e1 100644
--- a/www/node8/Makefile
+++ b/www/node8/Makefile
@@ -78,7 +78,7 @@ IGNORE= cannot build node.js with LibreSSL. You must enable BUNDLED_SSL
CONFIGURE_ARGS+=--openssl-no-asm
.endif
-.if ${COMPILER_TYPE} == gcc
+.if ${CHOSEN_COMPILER_TYPE} == gcc
# GCC does not expose std::snprintf() without this define
CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 1cabc8806dde..35d5e543624e 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -69,7 +69,7 @@ CXXFLAGS+= -O2 -ffast-math
. if !${PORT_OPTIONS:MPROFILE}
CXXFLAGS+= -fomit-frame-pointer
. endif
-. if ${COMPILER_TYPE} == "gcc"
+. if ${CHOSEN_COMPILER_TYPE} == gcc
CXXFLAGS+= -fexpensive-optimizations -finline-functions
. endif
.endif