summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/pike74/Makefile4
-rw-r--r--textproc/p5-XML-Xerces/Makefile4
-rw-r--r--textproc/xalan-c/Makefile4
3 files changed, 12 insertions, 0 deletions
diff --git a/lang/pike74/Makefile b/lang/pike74/Makefile
index 8d7a2db40aa1..15c2d9654c1f 100644
--- a/lang/pike74/Makefile
+++ b/lang/pike74/Makefile
@@ -69,6 +69,10 @@ USE_REINPLACE= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
+.endif
+
PLIST_SUB+= PORTVERSION=${PORTVERSION}
# FreeBSD 5.0 Needs to have libgmp port to support gmp.
diff --git a/textproc/p5-XML-Xerces/Makefile b/textproc/p5-XML-Xerces/Makefile
index 5ea3a5acdfca..4a67f3e5292c 100644
--- a/textproc/p5-XML-Xerces/Makefile
+++ b/textproc/p5-XML-Xerces/Makefile
@@ -33,6 +33,10 @@ USE_GMAKE= yes
IGNORE= "requires perl 5.6.x or later. Install lang/perl5 and try again"
.endif
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
+.endif
+
post-patch:
@${PERL} -pi -e "s|-lpthread|${PTHREAD_LIBS}|" ${WRKSRC}/Makefile.PL
diff --git a/textproc/xalan-c/Makefile b/textproc/xalan-c/Makefile
index 6769c22b7d04..25c87ad79cdc 100644
--- a/textproc/xalan-c/Makefile
+++ b/textproc/xalan-c/Makefile
@@ -64,6 +64,10 @@ CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -z -I${LOCALBASE}/include -C --pr
.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
.endif
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
+.endif
+
.if defined(DEBUG)
CONFIGURE_ARGS+= -d
STRIP=