summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-SMPP/Makefile22
-rw-r--r--net/p5-Net-SMPP/distinfo1
-rw-r--r--net/p5-Net-SMPP/pkg-comment1
-rw-r--r--net/p5-Net-SMPP/pkg-descr4
-rw-r--r--net/p5-Net-SMPP/pkg-plist11
6 files changed, 40 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index fe1dc6f93fec..3c91a2d193d7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -326,6 +326,7 @@
SUBDIR += p5-Net-Pcap
SUBDIR += p5-Net-Radius
SUBDIR += p5-Net-RawIP
+ SUBDIR += p5-Net-SMPP
SUBDIR += p5-Net-SNMP
SUBDIR += p5-Net-SSH
SUBDIR += p5-Net-SSH-Perl
diff --git a/net/p5-Net-SMPP/Makefile b/net/p5-Net-SMPP/Makefile
new file mode 100644
index 000000000000..f07da4229a71
--- /dev/null
+++ b/net/p5-Net-SMPP/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Net-SMPP
+# Date created: 20 May 2002
+# Whom: jhay
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SMPP
+PORTVERSION= 1.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jhay@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::SMPP.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SMPP/distinfo b/net/p5-Net-SMPP/distinfo
new file mode 100644
index 000000000000..a00f75e17c0e
--- /dev/null
+++ b/net/p5-Net-SMPP/distinfo
@@ -0,0 +1 @@
+MD5 (Net-SMPP-1.01.tar.gz) = 32f37e09d1f149733af086cc69d65a00
diff --git a/net/p5-Net-SMPP/pkg-comment b/net/p5-Net-SMPP/pkg-comment
new file mode 100644
index 000000000000..9714e82ee048
--- /dev/null
+++ b/net/p5-Net-SMPP/pkg-comment
@@ -0,0 +1 @@
+Net::SMPP - pure Perl implementation of SMPP 3.4 over TCP
diff --git a/net/p5-Net-SMPP/pkg-descr b/net/p5-Net-SMPP/pkg-descr
new file mode 100644
index 000000000000..ad5e1b07d20f
--- /dev/null
+++ b/net/p5-Net-SMPP/pkg-descr
@@ -0,0 +1,4 @@
+Implements Short Message Peer to Peer protocol, which is frequently used to
+pass short messages between mobile operators implementing short message
+service (SMS). This is applicable to both european GSM and american CDMA/TDMA
+systems.
diff --git a/net/p5-Net-SMPP/pkg-plist b/net/p5-Net-SMPP/pkg-plist
new file mode 100644
index 000000000000..31e26f6e6cad
--- /dev/null
+++ b/net/p5-Net-SMPP/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SMPP/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Net/smsc.pl
+lib/perl5/site_perl/%%PERL_VER%%/Net/sendmessage.pl
+lib/perl5/site_perl/%%PERL_VER%%/Net/esme-rec.pl
+lib/perl5/site_perl/%%PERL_VER%%/Net/esme-hammer.pl
+lib/perl5/site_perl/%%PERL_VER%%/Net/SMPP.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/esme.pl
+lib/perl5/site_perl/%%PERL_VER%%/Net/bind-hammer.pl
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SMPP
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true