summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/py-sphinx-markdown-tables/Makefile3
-rw-r--r--textproc/py-sphinx-markdown-tables/files/patch-markdown13
2 files changed, 15 insertions, 1 deletions
diff --git a/textproc/py-sphinx-markdown-tables/Makefile b/textproc/py-sphinx-markdown-tables/Makefile
index 1585ba6e9bce..5f32eaf70f82 100644
--- a/textproc/py-sphinx-markdown-tables/Makefile
+++ b/textproc/py-sphinx-markdown-tables/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sphinx-markdown-tables
PORTVERSION= 0.0.15
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc python
MASTER_SITES= PYPI
@@ -12,7 +13,7 @@ WWW= https://github.com/ryanfox/sphinx-markdown-tables
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>=0:textproc/py-markdown@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>=3.4:textproc/py-markdown@${PY_FLAVOR}
USES= dos2unix python
USE_PYTHON= autoplist distutils concurrent
diff --git a/textproc/py-sphinx-markdown-tables/files/patch-markdown b/textproc/py-sphinx-markdown-tables/files/patch-markdown
new file mode 100644
index 000000000000..0e96c3cebafa
--- /dev/null
+++ b/textproc/py-sphinx-markdown-tables/files/patch-markdown
@@ -0,0 +1,13 @@
+Obtained from: https://github.com/ryanfox/sphinx-markdown-tables/commit/7d0bbd2c851efcc9ba25b1a851924333b923c023
+
+--- sphinx_markdown_tables/__init__.py.orig 2022-08-16 13:25:15 UTC
++++ sphinx_markdown_tables/__init__.py
+@@ -21,7 +21,7 @@ def process_tables(app, docname, source):
+ """
+ import markdown
+ md = markdown.Markdown(extensions=['markdown.extensions.tables'])
+- table_processor = markdown.extensions.tables.TableProcessor(md.parser)
++ table_processor = markdown.extensions.tables.TableProcessor(md.parser, {})
+
+ raw_markdown = source[0]
+ blocks = re.split(r'(\n{2,})', raw_markdown)