summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/zbar/Makefile106
-rw-r--r--graphics/zbar/distinfo2
-rw-r--r--graphics/zbar/files/patch-Makefile.in11
-rw-r--r--graphics/zbar/pkg-descr16
-rw-r--r--graphics/zbar/pkg-plist45
6 files changed, 181 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 6397b81d08a1..f580f18bcc20 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1027,6 +1027,7 @@
SUBDIR += yed
SUBDIR += yukon
SUBDIR += zathura
+ SUBDIR += zbar
SUBDIR += zgv
SUBDIR += zimg
SUBDIR += zint
diff --git a/graphics/zbar/Makefile b/graphics/zbar/Makefile
new file mode 100644
index 000000000000..fab58ffcaf93
--- /dev/null
+++ b/graphics/zbar/Makefile
@@ -0,0 +1,106 @@
+# New ports collection makefile for: zbar
+# Date created: 12 november 2010
+# Whom: Oliver Heesakkers <dev2@heesakkers.info>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zbar
+PORTVERSION= 0.10
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= dev2@heesakkers.info
+COMMENT= ZBar barcode reader
+
+LICENSE= LGPL21
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_ICONV= yes
+
+OPTIONS= X11 "Build with X support" on \
+ IMAGEMAGICK "ImageMagick graphics support" on \
+ V4L "Build zbarcam video scanner" off \
+ PYTHON "Build PyGTK widget" off \
+ GTK2 "Build GTK+2 widget" off \
+ QT4 "Build Qt4 widget" off
+
+.include <bsd.port.options.mk>
+
+.if exists(${LOCALBASE}/lib/libjpeg.so)
+CONFIGURE_ARGS+= --with-jpeg=yes
+LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+.else
+CONFIGURE_ARGS+= --with-jpeg=no
+.endif
+
+.if defined(WITH_X11)
+USE_XORG= ice sm x11 xau xdmcp xext xv
+LIBDEPENDS+= xcb.2:${PORTSDIR}/x11/libxcb
+CONFIGURE_ARGS+= --with-x=yes
+.else
+CONFIGURE_ARGS+= --with-x=no --without-xshm --without-xv
+.endif
+
+.if defined(WITH_IMAGEMAGICK)
+LIB_DEPENDS+= Magick++.4:${PORTSDIR}/graphics/ImageMagick
+CONFIGURE_ARGS+= --with-imagemagick=yes
+PLIST_SUB+= IMAGEMAGICK=""
+MAN1= zbarimg.1
+.else
+CONFIGURE_ARGS+= --with-imagemagick=no
+PLIST_SUB+= IMAGEMAGICK="@comment "
+.endif
+
+.if defined(WITH_V4L)
+BUILD_DEPENDS+= v4l_compat>=1.0.20101027:${PORTSDIR}/multimedia/v4l_compat
+CONFIGURE_ARGS+= --enable-video=yes
+PLIST_SUB+= V4L=""
+MAN1+= zbarcam.1
+.else
+CONFIGURE_ARGS+= --enable-video=no
+PLIST_SUB+= V4L="@comment "
+.endif
+
+.if defined(WITH_PYTHON)
+USE_PYTHON= any
+CONFIGURE_ARGS+= --with-python=yes
+PLIST_SUB+= PYTHON=""
+.else
+CONFIGURE_ARGS+= --with-python=no
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+.if defined(WITH_GTK2)
+USE_GNOME= gtk20
+CONFIGURE_ARGS+= --with-gtk=yes
+PLIST_SUB+= GTK2=""
+.else
+CONFIGURE_ARGS+= --with-gtk=no
+PLIST_SUB+= GTK2="@comment "
+.endif
+
+.if defined(WITH_QT4)
+USE_QT_VER= 4
+QT_COMPONENTS= gui
+CONFIGURE_ARGS+= --with-qt=yes
+PLIST_SUB+= QT4=""
+.else
+CONFIGURE_ARGS+= --with-qt=no
+PLIST_SUB+= QT4="@comment "
+.endif
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's|^pkgconfigdir = .*|pkgconfigdir = $$(prefix)/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} '/^install-data-am: /s/install-dist_docDATA//' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/zbar/distinfo b/graphics/zbar/distinfo
new file mode 100644
index 000000000000..3d98728feb35
--- /dev/null
+++ b/graphics/zbar/distinfo
@@ -0,0 +1,2 @@
+SHA256 (zbar-0.10.tar.gz) = 575fa82de699faa7bda2d2ebbe3e1af0a4152ec4d3ad72c0ab6712d7cc9b5dd2
+SIZE (zbar-0.10.tar.gz) = 714457
diff --git a/graphics/zbar/files/patch-Makefile.in b/graphics/zbar/files/patch-Makefile.in
new file mode 100644
index 000000000000..6c0ab69972af
--- /dev/null
+++ b/graphics/zbar/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2010-12-09 17:52:23.862954369 +0000
++++ Makefile.in 2010-12-09 17:53:00.865045766 +0000
+@@ -697,7 +697,7 @@
+ perl/t/Scanner.t perl/t/pod.t perl/t/pod-coverage.t
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = zbar.pc $(am__append_44) $(am__append_52)
+-dist_doc_DATA = COPYING HACKING INSTALL LICENSE NEWS README TODO \
++dist_doc_DATA = HACKING INSTALL NEWS README TODO \
+ $(am__append_61)
+ zincludedir = $(includedir)/zbar
+ include_HEADERS = include/zbar.h
diff --git a/graphics/zbar/pkg-descr b/graphics/zbar/pkg-descr
new file mode 100644
index 000000000000..e572476a8ed9
--- /dev/null
+++ b/graphics/zbar/pkg-descr
@@ -0,0 +1,16 @@
+ZBar is an open source software suite for reading bar codes from various
+sources, such as video streams, image files and raw intensity sensors. It
+supports many popular symbologies (types of bar codes) including EAN-13/UPC-A,
+UPC-E, EAN-8, Code 128, Code 39, Interleaved 2 of 5 and QR Code.
+
+The flexible, layered implementation facilitates bar code scanning and decoding
+for any application: use it stand-alone with the included GUI and command line
+programs, easily integrate a bar code scanning widget into your Qt, GTK+ or
+PyGTK GUI application, leverage one of the script or programming interfaces
+(Python, Perl, C++) ...all the way down to a streamlined C library suitable for
+embedded use.
+
+ZBar is licensed under the GNU LGPL 2.1 to enable development of both open
+source and commercial projects.
+
+WWW: http://zbar.sourceforge.net
diff --git a/graphics/zbar/pkg-plist b/graphics/zbar/pkg-plist
new file mode 100644
index 000000000000..02545a97c0e2
--- /dev/null
+++ b/graphics/zbar/pkg-plist
@@ -0,0 +1,45 @@
+%%V4L%%bin/zbarcam
+%%IMAGEMAGICK%%bin/zbarimg
+include/zbar.h
+include/zbar/Decoder.h
+include/zbar/Exception.h
+include/zbar/Image.h
+include/zbar/ImageScanner.h
+include/zbar/Processor.h
+%%QT4%%include/zbar/QZBar.h
+%%QT4%%include/zbar/QZBarImage.h
+include/zbar/Scanner.h
+include/zbar/Symbol.h
+include/zbar/Video.h
+include/zbar/Window.h
+%%GTK2%%include/zbar/zbargtk.h
+lib/libzbar.a
+lib/libzbar.la
+lib/libzbar.so
+lib/libzbar.so.2
+%%GTK2%%lib/libzbargtk.a
+%%GTK2%%lib/libzbargtk.la
+%%GTK2%%lib/libzbargtk.so
+%%GTK2%%lib/libzbargtk.so.0
+%%QT4%%lib/libzbarqt.a
+%%QT4%%lib/libzbarqt.la
+%%QT4%%lib/libzbarqt.so
+%%QT4%%lib/libzbarqt.so.0
+%%GTK2%%libdata/pkgconfig/zbar-gtk.pc
+%%QT4%%libdata/pkgconfig/zbar-qt.pc
+libdata/pkgconfig/zbar.pc
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/zbar.la
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/zbar.so
+%%PYTHON%%%%GTK2%%%%PYTHON_SITELIBDIR%%/zbarpygtk.la
+%%PYTHON%%%%GTK2%%%%PYTHON_SITELIBDIR%%/zbarpygtk.so
+%%PORTDOCS%%%%DOCSDIR%%/HACKING
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+@dirrmtry share/zbar
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry lib/python2.6/site-packages
+@dirrmtry lib/python2.6
+@dirrmtry lib/pkgconfig
+@dirrm include/zbar