summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-keystroke/Makefile53
-rw-r--r--print/latex-keystroke/distinfo10
-rw-r--r--print/latex-keystroke/pkg-descr5
-rw-r--r--print/latex-keystroke/pkg-plist15
5 files changed, 84 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index c3a95cac1b97..c915997b48a0 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -93,6 +93,7 @@
SUBDIR += kover
SUBDIR += latex
SUBDIR += latex-beamer
+ SUBDIR += latex-keystroke
SUBDIR += latex-pgf
SUBDIR += latex-xcolor
SUBDIR += latex2rtf
diff --git a/print/latex-keystroke/Makefile b/print/latex-keystroke/Makefile
new file mode 100644
index 000000000000..0b63efd51f3a
--- /dev/null
+++ b/print/latex-keystroke/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: latex-keystroke
+# Date created: 24 Jan 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= latex-keystroke
+PORTVERSION= 1.0.20001109
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= macros/latex/contrib/keystroke
+DISTFILES= ${DOC_FILES} ${CLASS_FILES}
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= #empty
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A LaTeX package for the graphical representation of the keys
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+
+NO_BUILD= YES
+PLIST_SUB= TEXMF=${TEXMF} MKTEXLSR=${MKTEXLSR}
+PLIST_SUB+= CLASSDIR=${CLASSDIR}
+
+TEXMF= share/texmf
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+CLASSDIR= ${TEXMF}/tex/latex/${PORTNAME:S/^latex-//}
+
+DOC_FILES= README
+
+CLASS_FILES+= key-test.pdf
+CLASS_FILES+= key-test.tex
+CLASS_FILES+= keystroke.sty
+CLASS_FILES+= keystroke_left.eps
+CLASS_FILES+= keystroke_left.pdf
+CLASS_FILES+= keystroke_middle.eps
+CLASS_FILES+= keystroke_middle.pdf
+CLASS_FILES+= keystroke_right.eps
+CLASS_FILES+= keystroke_right.pdf
+
+do-install:
+ ${MKDIR} ${PREFIX}/${CLASSDIR}
+ ${INSTALL_DATA} ${CLASS_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${PREFIX}/${CLASSDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S@^@${DISTDIR}/${DIST_SUBDIR}/@} ${DOCSDIR}
+.endif
+
+post-install:
+ ${MKTEXLSR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-keystroke/distinfo b/print/latex-keystroke/distinfo
new file mode 100644
index 000000000000..ec1a8e7cb412
--- /dev/null
+++ b/print/latex-keystroke/distinfo
@@ -0,0 +1,10 @@
+MD5 (latex-keystroke/README) = f46f59b757bceec991f4b59ef9a5a5ab
+MD5 (latex-keystroke/key-test.pdf) = 81d065687bb24ec6a5e65cb45d5f46de
+MD5 (latex-keystroke/key-test.tex) = 18c39209c9f8658b1ec69c149f2b3064
+MD5 (latex-keystroke/keystroke.sty) = 852b6c9010bf64a98223c3c9de324ca5
+MD5 (latex-keystroke/keystroke_left.eps) = d0479e61036736c9495d475bb040cba8
+MD5 (latex-keystroke/keystroke_left.pdf) = 7bfe34f26d8809c4ca4227976cfb7bae
+MD5 (latex-keystroke/keystroke_middle.eps) = 0587c77b7287d0d8053c47c517c3019b
+MD5 (latex-keystroke/keystroke_middle.pdf) = b9a82be2d65c7aab2c1216e7b3adddcf
+MD5 (latex-keystroke/keystroke_right.eps) = 2907ec13b1fad2aeceedb757285cb1a5
+MD5 (latex-keystroke/keystroke_right.pdf) = 1bc7624c17109916ff64d92375342ddb
diff --git a/print/latex-keystroke/pkg-descr b/print/latex-keystroke/pkg-descr
new file mode 100644
index 000000000000..c101c85cf171
--- /dev/null
+++ b/print/latex-keystroke/pkg-descr
@@ -0,0 +1,5 @@
+TeX package `keystroke' provides macros for the graphical
+representation of the keys on a computer keyboard. `keystroke' is
+based on macros which were used in a previous edition of the Linux
+manual published by the SuSE G.m.b.H. distributor, and is licensed
+under the GPL.
diff --git a/print/latex-keystroke/pkg-plist b/print/latex-keystroke/pkg-plist
new file mode 100644
index 000000000000..273aeef09a5e
--- /dev/null
+++ b/print/latex-keystroke/pkg-plist
@@ -0,0 +1,15 @@
+@comment $FreeBSD$
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%CLASSDIR%%/key-test.pdf
+%%CLASSDIR%%/key-test.tex
+%%CLASSDIR%%/keystroke.sty
+%%CLASSDIR%%/keystroke_left.eps
+%%CLASSDIR%%/keystroke_left.pdf
+%%CLASSDIR%%/keystroke_middle.eps
+%%CLASSDIR%%/keystroke_middle.pdf
+%%CLASSDIR%%/keystroke_right.eps
+%%CLASSDIR%%/keystroke_right.pdf
+@dirrm %%CLASSDIR%%
+@exec %%MKTEXLSR%%
+@unexec %%MKTEXLSR%%