summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/py-borgbackup/Makefile3
-rw-r--r--archivers/py-borgbackup/files/patch-setup.py11
2 files changed, 2 insertions, 12 deletions
diff --git a/archivers/py-borgbackup/Makefile b/archivers/py-borgbackup/Makefile
index 0638addb75a3..ec020d2659a9 100644
--- a/archivers/py-borgbackup/Makefile
+++ b/archivers/py-borgbackup/Makefile
@@ -13,7 +13,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.7:devel/py-setuptools_scm@${PY_FLAVOR}
LIB_DEPENDS= liblz4.so:archivers/liblz4 \
- libzstd.so:archivers/zstd
+ libzstd.so:archivers/zstd \
+ libxxhash.so:devel/xxhash
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=19.0:devel/py-packaging@${PY_FLAVOR}
USES= python ssl
diff --git a/archivers/py-borgbackup/files/patch-setup.py b/archivers/py-borgbackup/files/patch-setup.py
deleted file mode 100644
index 399dc0b58daa..000000000000
--- a/archivers/py-borgbackup/files/patch-setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig 2022-07-16 16:20:52 UTC
-+++ setup.py
-@@ -23,7 +23,7 @@ prefer_system_libzstd = True
- prefer_system_libb2 = True
-
- # True: use the shared libxxhash (>= 0.6.5 [>= 0.7.2 on ARM]) from the system, False: use the bundled xxhash code
--prefer_system_libxxhash = True
-+prefer_system_libxxhash = False
-
- # prefer_system_msgpack is another option, but you need to set it in src/borg/helpers.py.
-