summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/Makefile1
-rw-r--r--irc/znc-push/Makefile44
-rw-r--r--irc/znc-push/distinfo3
-rw-r--r--irc/znc-push/files/patch-Makefile9
-rw-r--r--irc/znc-push/pkg-descr23
5 files changed, 80 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 81a00a9aebd5..572d5b283125 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -125,5 +125,6 @@
SUBDIR += weechat-otr
SUBDIR += xaric
SUBDIR += znc
+ SUBDIR += znc-push
.include <bsd.port.subdir.mk>
diff --git a/irc/znc-push/Makefile b/irc/znc-push/Makefile
new file mode 100644
index 000000000000..fab0466a52a9
--- /dev/null
+++ b/irc/znc-push/Makefile
@@ -0,0 +1,44 @@
+# $FreeBSD$
+
+PORTNAME= znc-push
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0-165
+DISTVERSIONSUFFIX= -g0a36b1c
+CATEGORIES= irc
+
+MAINTAINER= dor.bsd@xm0.uk
+COMMENT= Push notification service module for ZNC
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= znc:irc/znc
+LIB_DEPENDS= libicudata.so:devel/icu
+RUN_DEPENDS= znc:irc/znc
+
+USES= gmake ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= jreese
+
+MAKE_ENV= version=${PORTVERSION}
+
+PLIST_FILES= lib/znc/push.so
+PORTDOCS= *.md
+
+OPTIONS_DEFINE= CURL DOCS
+
+CURL_DESC= Use curl for HTTP requests
+CURL_LIB_DEPENDS= libcurl.so:ftp/curl
+CURL_MAKE_ENV= curl=yes
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/lib/znc
+ ${INSTALL_PROGRAM} ${WRKSRC}/push.so ${STAGEDIR}${PREFIX}/lib/znc/push.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/znc/push.so
+
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README.md ${WRKSRC}/doc/*.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/irc/znc-push/distinfo b/irc/znc-push/distinfo
new file mode 100644
index 000000000000..f2678080795e
--- /dev/null
+++ b/irc/znc-push/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1541547602
+SHA256 (jreese-znc-push-v1.0.0-165-g0a36b1c_GH0.tar.gz) = c0f1ccf8634424828ac70a37d560044bd8ff2bf2a9b046ac412b1bacfa68a097
+SIZE (jreese-znc-push-v1.0.0-165-g0a36b1c_GH0.tar.gz) = 497827
diff --git a/irc/znc-push/files/patch-Makefile b/irc/znc-push/files/patch-Makefile
new file mode 100644
index 000000000000..8c7a79616187
--- /dev/null
+++ b/irc/znc-push/files/patch-Makefile
@@ -0,0 +1,9 @@
+--- Makefile.orig 2018-08-27 02:38:08 UTC
++++ Makefile
+@@ -1,5 +1,4 @@
+-version = $(shell git describe --dirty || echo dev)
+-curl=no
++curl?=no
+
+ ifneq ($(curl),no)
+ flags=-DUSE_CURL -lcurl
diff --git a/irc/znc-push/pkg-descr b/irc/znc-push/pkg-descr
new file mode 100644
index 000000000000..4c16fdd8ad3a
--- /dev/null
+++ b/irc/znc-push/pkg-descr
@@ -0,0 +1,23 @@
+ZNC Push is a module for ZNC that will send notifications to multiple push
+notification services, or SMS for any private message or channel highlight that
+matches a configurable set of conditions. ZNC Push current supports the
+following services:
+
+ Boxcar
+ Boxcar 2
+ Discord
+ Faast
+ Nexmo
+ Notify My Android (NMA)
+ Prowl
+ Pushalot
+ PushBullet
+ Pushjet
+ Pushover
+ Pushsafer
+ Slack
+ Supertoasty
+ Telegram
+ Custom URL GET requests
+
+WWW: https://github.com/jreese/znc-push