summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--audio/Makefile1
-rw-r--r--audio/id3ed/Makefile28
-rw-r--r--audio/id3ed/distinfo2
-rw-r--r--audio/id3ed/pkg-descr4
5 files changed, 35 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index bfcdebb8c6ca..ece133ad3ac1 100644
--- a/MOVED
+++ b/MOVED
@@ -2302,7 +2302,6 @@ archivers/zipios++||2011-08-01|Has expired: No more public distfiles
astro/sattrack||2011-08-01|Has expired: No more public distfiles
audio/bladeenc||2011-08-01|Has expired: Looks like an abandonware
audio/cdplayer.app||2011-08-01|Has expired: Looks like an abandonware, no more public distfile
-audio/id3ed||2011-08-01|Has expired: No more public distfiles, looks like an abandonware
audio/linux-vsound||2011-08-01|Has expired: Abandonware
audio/mpegaudio||2011-08-01|Has expired: No more public distfiles
audio/mpmf20||2011-08-01|Has expired: Abandonware
diff --git a/audio/Makefile b/audio/Makefile
index 04167848f1dc..1f31894159f0 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -310,6 +310,7 @@
SUBDIR += ices
SUBDIR += ices0
SUBDIR += id3el
+ SUBDIR += id3ed
SUBDIR += id3lib
SUBDIR += id3mtag
SUBDIR += id3ren
diff --git a/audio/id3ed/Makefile b/audio/id3ed/Makefile
new file mode 100644
index 000000000000..c11f954c1b84
--- /dev/null
+++ b/audio/id3ed/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: id3ed
+# Date created: 05 June 1999
+# Whom: Chris Piazza <cpiazza@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= id3ed
+PORTVERSION= 1.10.4
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_NETBSD} \
+ ${MASTER_SITE_OPENBSD}
+
+MAINTAINER= turutani@scphys.kyoto-u.ac.jp
+COMMENT= An id3 tag editor for mp3 files
+
+LICENSE= GPLv2
+
+GNU_CONFIGURE= yes
+
+MAN1= id3ed.1
+PLIST_FILES= bin/id3ed
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/id3ed ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/id3ed.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/audio/id3ed/distinfo b/audio/id3ed/distinfo
new file mode 100644
index 000000000000..e8551d61a506
--- /dev/null
+++ b/audio/id3ed/distinfo
@@ -0,0 +1,2 @@
+SHA256 (id3ed-1.10.4.tar.gz) = 56f26dfde7b6357c5ad22644c2a379f25fce82a200264b5d4ce62f2468d8431b
+SIZE (id3ed-1.10.4.tar.gz) = 31610
diff --git a/audio/id3ed/pkg-descr b/audio/id3ed/pkg-descr
new file mode 100644
index 000000000000..ccf2febdd61b
--- /dev/null
+++ b/audio/id3ed/pkg-descr
@@ -0,0 +1,4 @@
+A command line tool to edit id3 tags in mp3 files interactively or
+on the fly.
+
+WWW: http://code.fluffytapeworm.com/projects/id3ed