summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/pulseaudio/Makefile7
-rw-r--r--devel/gconf2/Makefile5
-rw-r--r--print/texlive-base/Makefile13
3 files changed, 17 insertions, 8 deletions
diff --git a/audio/pulseaudio/Makefile b/audio/pulseaudio/Makefile
index f68b3e246616..7183f6249e31 100644
--- a/audio/pulseaudio/Makefile
+++ b/audio/pulseaudio/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pulseaudio
PORTVERSION= 10.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://freedesktop.org/software/pulseaudio/releases/
@@ -27,7 +27,7 @@ USE_GNOME= glib20 intltool
USE_XORG= ice sm x11 xcb xtst
USE_LDCONFIG= yes
USES= compiler:c11 cpe execinfo gettext gmake gnome iconv libtool \
- pathfix pkgconfig shebangfix ssl tar:xz
+ pathfix pkgconfig python:run shebangfix ssl tar:xz
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_LIBS="-lpthread" \
OPENSSL_CFLAGS="-I${OPENSSLINC}" \
@@ -38,7 +38,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-SHEBANG_FILES= shell-completion/bash/pulseaudio
+SHEBANG_FILES= shell-completion/bash/pulseaudio \
+ src/utils/qpaeq
bash_CMD= ${SETENV} bash
SUB_FILES= pkg-message
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index cc9f7ebb0bb5..2372408d4594 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gconf2
PORTVERSION= 3.2.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel gnome
MASTER_SITES= GNOME/sources/GConf/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= GConf-${PORTVERSION}
@@ -23,7 +23,7 @@ USES= tar:xz
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libpolkit-gobject-1.so:sysutils/polkit
-USES+= gettext gmake libtool pathfix pkgconfig
+USES+= gettext gmake libtool pathfix pkgconfig python:run shebangfix
USE_GNOME= orbit2 gtk20 libxml2 \
referencehack intlhack dconf introspection:build
USE_LDCONFIG= yes
@@ -34,6 +34,7 @@ CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
+SHEBANG_FILES= gsettings/gsettings-schema-convert
DOCSDIR= ${PREFIX}/share/doc/gconf
diff --git a/print/texlive-base/Makefile b/print/texlive-base/Makefile
index 31a025fd985d..f288e4c4b829 100644
--- a/print/texlive-base/Makefile
+++ b/print/texlive-base/Makefile
@@ -2,7 +2,7 @@
PORTNAME= texlive
PORTVERSION= 20150521
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= print
MASTER_SITES= TEX_CTAN/systems/texlive/Source/
PKGNAMESUFFIX= -base
@@ -28,7 +28,7 @@ LIB_DEPENDS= libicuio.so:devel/icu \
CONFLICTS_INSTALL= texlive-texmf-201[234]*
USE_TEX= web2c kpathsea ptexenc tlmgr texhash-bootstrap
-USES= ghostscript pkgconfig perl5 shebangfix tar:xz
+USES= ghostscript pkgconfig perl5 python:run shebangfix tar:xz
USE_PERL5= run
# during build phase gnu configure is run a lot
MAKE_ENV+= CONFIG_SITE=${CONFIG_SITE}
@@ -86,27 +86,32 @@ SHEBANG_FILES= texk/texlive/linked_scripts/accfonts/mkt1font \
texk/texlive/linked_scripts/bibexport/bibexport.sh \
texk/texlive/linked_scripts/convbkmk/convbkmk.rb \
texk/texlive/linked_scripts/ctanupload/ctanupload.pl \
- texk/texlive/linked_scripts/de-macro/de-macro \
+ texk/texlive/linked_scripts/ebong/*.py \
texk/texlive/linked_scripts/dtxgen/dtxgen \
+ texk/texlive/linked_scripts/dviasm/*.py \
texk/texlive/linked_scripts/exceltex/exceltex \
texk/texlive/linked_scripts/findhyph/findhyph \
texk/texlive/linked_scripts/fragmaster/fragmaster.pl \
texk/texlive/linked_scripts/installfont/installfont-tl \
texk/texlive/linked_scripts/kotex-utils/jamo-normalize.pl \
texk/texlive/linked_scripts/latexpand/latexpand \
+ texk/texlive/linked_scripts/lilyglyphs/*.py \
texk/texlive/linked_scripts/ltxfileinfo/ltxfileinfo \
texk/texlive/linked_scripts/lua2dox/lua2dox_filter \
texk/texlive/linked_scripts/mathspic/mathspic.pl \
texk/texlive/linked_scripts/mf2pt1/mf2pt1.pl \
texk/texlive/linked_scripts/multibibliography/multibibliography.pl \
+ texk/texlive/linked_scripts/pythontex/*.py \
texk/texlive/linked_scripts/rubik/rubikrotation.pl \
texk/texlive/linked_scripts/splitindex/splitindex.pl \
texk/texlive/linked_scripts/svn-multi/svn-multi.pl \
texk/texlive/linked_scripts/texdirflatten/texdirflatten \
+ texk/texlive/linked_scripts/texliveonfly/texliveonfly.py \
texk/texlive/linked_scripts/ulqda/ulqda.pl \
texk/texlive/linked_scripts/urlbst/urlbst \
texk/texlive/linked_scripts/yplan/yplan
+
INFO= dvipng tlbuild
OPTIONS_DEFINE= X11
@@ -120,6 +125,8 @@ post-patch:
linked_scripts/texlive/fmtutil-sys.sh \
tl_scripts/texconfig-sys.sh \
linked_scripts/texlive/updmap-sys.sh
+ ${REINPLACE_CMD} -e 's|/usr/bin/python -O|${python_CMD}|' \
+ ${WRKSRC}/texk/texlive/linked_scripts/de-macro/de-macro \
post-install-fmtutil:
for D in ${TEXHASHDIRS}; do \