summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/cjs/Makefile2
-rw-r--r--lang/spidermonkey17/Makefile2
-rw-r--r--lang/spidermonkey185/Makefile2
-rw-r--r--lang/spidermonkey24/Makefile2
4 files changed, 0 insertions, 8 deletions
diff --git a/lang/cjs/Makefile b/lang/cjs/Makefile
index 45a53fbaa10e..5eb5fe68cc3d 100644
--- a/lang/cjs/Makefile
+++ b/lang/cjs/Makefile
@@ -14,8 +14,6 @@ BUILD_DEPENDS= gnome-autogen.sh:devel/gnome-common
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libmozjs-24.so:lang/spidermonkey24
-CONFLICTS_BUILD=spidermonkey17-1.7.*
-
USES= autoreconf compiler:c11 gettext gmake gnome libtool pathfix \
pkgconfig python:build shebangfix
USE_GNOME= cairo glib20 gnomeprefix introspection:build
diff --git a/lang/spidermonkey17/Makefile b/lang/spidermonkey17/Makefile
index 22a382aa0978..52b6571297d4 100644
--- a/lang/spidermonkey17/Makefile
+++ b/lang/spidermonkey17/Makefile
@@ -13,8 +13,6 @@ COMMENT= Standalone JavaScript interpreter from the Mozilla project
LIB_DEPENDS= libnspr4.so:devel/nspr
-CONFLICTS= njs-[0-9]*
-
MAKE_ARGS+= JS_THREADSAFE=YES \
PROG_LIBS="-lreadline -lncurses -lm -lpthread" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/lang/spidermonkey185/Makefile b/lang/spidermonkey185/Makefile
index e6a3510b2a27..263096f3e96d 100644
--- a/lang/spidermonkey185/Makefile
+++ b/lang/spidermonkey185/Makefile
@@ -15,8 +15,6 @@ BUILD_DEPENDS= zip:archivers/zip \
autoconf-2.13:devel/autoconf213
LIB_DEPENDS= libnspr4.so:devel/nspr
-CONFLICTS= njs-[0-9]*
-
USES= gmake pathfix perl5 pkgconfig python:2.7,build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/lang/spidermonkey24/Makefile b/lang/spidermonkey24/Makefile
index 7503a7383588..8472e48fe901 100644
--- a/lang/spidermonkey24/Makefile
+++ b/lang/spidermonkey24/Makefile
@@ -15,8 +15,6 @@ COMMENT= Standalone JavaScript based from Mozilla 24-esr
BUILD_DEPENDS= zip:archivers/zip
LIB_DEPENDS= libnspr4.so:devel/nspr
-CONFLICTS= njs-[0-9]*
-
GNU_CONFIGURE= yes
USES= compiler:c++11-lib gmake pathfix perl5 python:2.7,build \
readline tar:bzip2