summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile2
-rw-r--r--sysutils/bareos-traymonitor/Makefile34
-rw-r--r--sysutils/bareos-traymonitor/pkg-descr8
-rw-r--r--sysutils/bareos-traymonitor/pkg-plist7
-rw-r--r--sysutils/bareos17-client-static/Makefile (renamed from sysutils/bareos-client-static/Makefile)4
5 files changed, 52 insertions, 3 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 17dea5d3954a..a1eaf8f29f81 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -81,13 +81,13 @@
SUBDIR += baloo-widgets
SUBDIR += bamf
SUBDIR += bareos-client
- SUBDIR += bareos-client-static
SUBDIR += bareos-docs
SUBDIR += bareos-server
SUBDIR += bareos16-client
SUBDIR += bareos16-client-static
SUBDIR += bareos16-server
SUBDIR += bareos17-client
+ SUBDIR += bareos17-client-static
SUBDIR += bareos17-server
SUBDIR += bastille
SUBDIR += batmon
diff --git a/sysutils/bareos-traymonitor/Makefile b/sysutils/bareos-traymonitor/Makefile
new file mode 100644
index 000000000000..20be5d1792a0
--- /dev/null
+++ b/sysutils/bareos-traymonitor/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= bareos
+
+PKGNAMESUFFIX= -traymonitor
+
+COMMENT= Backup archiving recovery open sourced (traymonitor)
+
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE= 2019-03-15
+
+LIB_DEPENDS+= libqwt.so:x11-toolkits/qwt5 \
+ libbareos.so:sysutils/bareos-client
+
+CONFLICTS= bacula*-bat-* bareos16-traymonitor-*
+
+USES= pkgconfig gettext-runtime desktop-file-utils qt:4
+USE_QT= qmake_build uic_build moc_build rcc_build gui corelib
+WITH_BAT= yes
+
+PLIST= ${.CURDIR}/pkg-plist
+MAKE_ENV+= MAKEOBJDIRPREFIX=/
+
+MASTERDIR= ${.CURDIR}/../../sysutils/bareos-server
+
+CONFIGURE_ARGS+= --enable-traymonitor=yes \
+ --with-qwt=${LOCALBASE}/lib \
+ --disable-build-dird \
+ --disable-build-stored \
+ --enable-client-only \
+ --with-jansson=${LOCALBASE} \
+ --enable-nls=yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/bareos-traymonitor/pkg-descr b/sysutils/bareos-traymonitor/pkg-descr
new file mode 100644
index 000000000000..6a18fe88fe3a
--- /dev/null
+++ b/sysutils/bareos-traymonitor/pkg-descr
@@ -0,0 +1,8 @@
+traymonitor inteface for Bareos.
+
+Bareos (BackupArchivingRecoveryOpenSourced) is a reliable network open source
+software to backup, archive and restore files from all major operating systems.
+The fork was founded 2010 out of the bacula.org project. The fork has been
+actively developed and many new features have been added.
+
+WWW: http://www.bareos.org/
diff --git a/sysutils/bareos-traymonitor/pkg-plist b/sysutils/bareos-traymonitor/pkg-plist
new file mode 100644
index 000000000000..6b010213de0b
--- /dev/null
+++ b/sysutils/bareos-traymonitor/pkg-plist
@@ -0,0 +1,7 @@
+@sample %%ETCDIR%%/tray-monitor.d/client/FileDaemon-local.conf.sample
+@sample %%ETCDIR%%/tray-monitor.d/director/Director-local.conf.sample
+@sample %%ETCDIR%%/tray-monitor.d/monitor/bareos-mon.conf.sample
+@sample %%ETCDIR%%/tray-monitor.d/storage/StorageDaemon-local.conf.sample
+share/applications/bareos-tray-monitor.desktop
+share/pixmaps/bareos-tray-monitor.xpm
+bin/bareos-tray-monitor
diff --git a/sysutils/bareos-client-static/Makefile b/sysutils/bareos17-client-static/Makefile
index 4d16a398afcc..b6855572b9c5 100644
--- a/sysutils/bareos-client-static/Makefile
+++ b/sysutils/bareos17-client-static/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTNAME= bareos
+PORTNAME= bareos17
PKGNAMESUFFIX= -client-static
COMMENT= Backup archiving recovery open sourced (static client)
@@ -8,7 +8,7 @@ COMMENT= Backup archiving recovery open sourced (static client)
CONFLICTS= bareos16-client-static-*
PLIST= ${.CURDIR}/pkg-plist
-MASTERDIR= ${.CURDIR}/../../sysutils/bareos-server
+MASTERDIR= ${.CURDIR}/../../sysutils/bareos17-server
PLIST_FILES= sbin/bareos-fd-static \
sbin/bconsole-static