summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-open4/Makefile19
-rw-r--r--devel/rubygem-open4/distinfo3
-rw-r--r--devel/rubygem-open4/pkg-descr4
-rw-r--r--devel/rubygem-open4/pkg-plist15
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 169489dd55d4..bec8fab16929 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2163,6 +2163,7 @@
SUBDIR += rubygem-inline
SUBDIR += rubygem-json
SUBDIR += rubygem-needle
+ SUBDIR += rubygem-open4
SUBDIR += rubygem-parsetree
SUBDIR += rubygem-ptreloaded
SUBDIR += rubygem-rake
diff --git a/devel/rubygem-open4/Makefile b/devel/rubygem-open4/Makefile
new file mode 100644
index 000000000000..2dc7546915eb
--- /dev/null
+++ b/devel/rubygem-open4/Makefile
@@ -0,0 +1,19 @@
+# Ports collection makefile for: rubygem-open4
+# Date created: 2007-12-17
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= open4
+PORTVERSION= 0.9.6
+CATEGORIES= devel rubygems
+MASTER_SITES= http://codeforpeople.com/lib/ruby/open4/${DISTNAME}/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Open4 manages child processes and their io handles
+
+USE_RUBY= yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/rubygem-open4/distinfo b/devel/rubygem-open4/distinfo
new file mode 100644
index 000000000000..ff81602b6eb9
--- /dev/null
+++ b/devel/rubygem-open4/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/open4-0.9.6.gem) = f46f57cc533ac8d5bc73dd69819d5c30
+SHA256 (rubygem/open4-0.9.6.gem) = 205d2eb31856cd8dbf96087b4e010218c0705dd1c850745a7207b8c725d89378
+SIZE (rubygem/open4-0.9.6.gem) = 11264
diff --git a/devel/rubygem-open4/pkg-descr b/devel/rubygem-open4/pkg-descr
new file mode 100644
index 000000000000..0aba4d12dce1
--- /dev/null
+++ b/devel/rubygem-open4/pkg-descr
@@ -0,0 +1,4 @@
+open child process with handles on pid, stdin, stdout, and stderr: manage
+child processes and their io handles easily.
+
+WWW: http://codeforpeople.com/lib/ruby/open4/
diff --git a/devel/rubygem-open4/pkg-plist b/devel/rubygem-open4/pkg-plist
new file mode 100644
index 000000000000..287a53e037bd
--- /dev/null
+++ b/devel/rubygem-open4/pkg-plist
@@ -0,0 +1,15 @@
+%%GEM_CACHE%%
+%%GEM_LIB_DIR%%/lib/open4.rb
+%%GEM_LIB_DIR%%/README
+%%GEM_LIB_DIR%%/sample/bg.rb
+%%GEM_LIB_DIR%%/sample/block.rb
+%%GEM_LIB_DIR%%/sample/exception.rb
+%%GEM_LIB_DIR%%/sample/simple.rb
+%%GEM_LIB_DIR%%/sample/spawn.rb
+%%GEM_LIB_DIR%%/sample/stdin_timeout.rb
+%%GEM_LIB_DIR%%/sample/timeout.rb
+%%GEM_LIB_DIR%%/white_box/leak.rb
+%%GEM_SPEC%%
+@dirrm %%GEM_LIB_DIR%%/lib/
+@dirrm %%GEM_LIB_DIR%%/sample
+@dirrm %%GEM_LIB_DIR%%/white_box