summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/libsigrok/Makefile6
-rw-r--r--devel/p5-IO-AIO/files/patch-AIO.xs16
-rw-r--r--x11/libinput/files/patch-tools_libinput-record.c20
-rw-r--r--x11/mako/Makefile6
-rw-r--r--x11/swayimg/Makefile6
-rw-r--r--x11/sxmo-wayout/Makefile6
-rw-r--r--x11/wmenu/Makefile6
-rw-r--r--x11/xdg-desktop-portal-wlr/Makefile6
8 files changed, 2 insertions, 70 deletions
diff --git a/devel/libsigrok/Makefile b/devel/libsigrok/Makefile
index 7f422ac63552..d635d2134e31 100644
--- a/devel/libsigrok/Makefile
+++ b/devel/libsigrok/Makefile
@@ -30,12 +30,6 @@ MAKE_JOBS_UNSAFE= yes
INSTALL_TARGET= install-strip
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
-CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
-.endif
-
post-patch:
# libusb can be disabled via src.conf(5), so detect via pkg-config
@${REINPLACE_CMD} -e 's/\(libusb-1\.0\) >= 1\.0\.[0-9]*/\1/' \
diff --git a/devel/p5-IO-AIO/files/patch-AIO.xs b/devel/p5-IO-AIO/files/patch-AIO.xs
index b1df75c1ed23..cf26e3bbb7a5 100644
--- a/devel/p5-IO-AIO/files/patch-AIO.xs
+++ b/devel/p5-IO-AIO/files/patch-AIO.xs
@@ -1,18 +1,6 @@
---- AIO.xs.orig 2022-09-28 08:22:50 UTC
+--- AIO.xs.orig 2022-09-25 16:29:50 UTC
+++ AIO.xs
-@@ -169,9 +169,11 @@
- # include <sys/eventfd.h>
- #endif
-
-+#define cv condvar_cv
- #if HAVE_TIMERFD
- # include <sys/timerfd.h>
- #endif
-+#undef cv
-
- #if HAVE_RLIMITS
- #include <sys/time.h>
-@@ -2926,7 +2928,7 @@ fexecve (SV *fh, SV *args, SV *envs = &PL_sv_undef)
+@@ -2924,7 +2924,7 @@ fexecve (SV *fh, SV *args, SV *envs = &PL_sv_undef)
OUTPUT: RETVAL
int
diff --git a/x11/libinput/files/patch-tools_libinput-record.c b/x11/libinput/files/patch-tools_libinput-record.c
deleted file mode 100644
index 0b67efceed08..000000000000
--- a/x11/libinput/files/patch-tools_libinput-record.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- tools/libinput-record.c.orig 2023-03-25 17:59:47 UTC
-+++ tools/libinput-record.c
-@@ -2577,7 +2577,7 @@ enum fposition {
-
- enum fposition {
- ERROR,
-- NOFILE,
-+ NO_FILE,
- FIRST,
- LAST,
- };
-@@ -2633,7 +2633,7 @@ find_output_file(int argc, char *argv[], const char **
- return ERROR;
- }
- #undef _m
-- return NOFILE;
-+ return NO_FILE;
- }
-
- enum options {
diff --git a/x11/mako/Makefile b/x11/mako/Makefile
index 90ee554be7fa..e34c522d0167 100644
--- a/x11/mako/Makefile
+++ b/x11/mako/Makefile
@@ -37,12 +37,6 @@ MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz \
PIXBUF_USE= GNOME=gdkpixbuf2
PIXBUF_MESON_ENABLED= icons
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
-CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
-.endif
-
post-patch:
# Respect PREFIX for icons
@${REINPLACE_CMD} 's,/usr/share,${DATADIR:H},g' \
diff --git a/x11/swayimg/Makefile b/x11/swayimg/Makefile
index 3732aac874ed..120c871b57c7 100644
--- a/x11/swayimg/Makefile
+++ b/x11/swayimg/Makefile
@@ -78,12 +78,6 @@ WEBP_MESON_ENABLED= webp
ZSH_MESON_ENABLED= zsh
ZSH_PLIST_FILES= share/zsh/site-functions/_${PORTNAME}
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
-CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
-.endif
-
post-patch:
# Respect PREFIX for system-wide config
@${REINPLACE_CMD} 's,/etc,${PREFIX}&,' \
diff --git a/x11/sxmo-wayout/Makefile b/x11/sxmo-wayout/Makefile
index ba76da8c22db..103d4b125b8e 100644
--- a/x11/sxmo-wayout/Makefile
+++ b/x11/sxmo-wayout/Makefile
@@ -30,12 +30,6 @@ MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
MANPAGES_MESON_ENABLED= man-pages
MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
-CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
-.endif
-
post-install:
# Rename to avoid conflict with x11/wayout
${MV} ${STAGEDIR}${PREFIX}/bin/${PORTNAME} \
diff --git a/x11/wmenu/Makefile b/x11/wmenu/Makefile
index 277d9948eef3..8764a8ffe766 100644
--- a/x11/wmenu/Makefile
+++ b/x11/wmenu/Makefile
@@ -29,10 +29,4 @@ LDFLAGS+= `pkg-config --libs epoll-shim`
PLIST_FILES= bin/wmenu \
man/man1/wmenu.1.gz
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
-CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
-.endif
-
.include <bsd.port.mk>
diff --git a/x11/xdg-desktop-portal-wlr/Makefile b/x11/xdg-desktop-portal-wlr/Makefile
index 0007c79c55e4..73f5f4d78183 100644
--- a/x11/xdg-desktop-portal-wlr/Makefile
+++ b/x11/xdg-desktop-portal-wlr/Makefile
@@ -45,12 +45,6 @@ MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
MANPAGES_MESON_ENABLED= man-pages
MANPAGES_PLIST_FILES= man/man5/${PORTNAME}.5.gz
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400097
-CFLAGS+= -D__BSD_VISIBLE -D__XSI_VISIBLE
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's,/etc,${PREFIX}&,' \
${WRKSRC}/${PORTNAME}.5.scd