summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/py-gd/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/py-gd/Makefile b/graphics/py-gd/Makefile
index cd329e7d44d3..f4410588afc5 100644
--- a/graphics/py-gd/Makefile
+++ b/graphics/py-gd/Makefile
@@ -16,7 +16,9 @@ COMMENT= Python interface to the GD library
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+.if defined(WITHOUT_X11)
USE_XPM= yes
+.endif
USE_REINPLACE= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -29,6 +31,10 @@ post-patch:
-e 's,/usr/X11R6,${X11BASE},g' \
-e 's,/usr/include/X11,${LOCALBASE}/include,g' \
${WRKSRC}/${PYSETUP}
+.if defined(WITHOUT_X11)
+ ${REINPLACE_CMD} -e 's/"X11", "Xpm",//' \
+ -e 's/"ttf", "freetype",//' ${WRKSRC}/${PYSETUP}
+.endif
post-install:
.if !defined(NOPORTDOCS)