summaryrefslogtreecommitdiff
path: root/x11
diff options
context:
space:
mode:
authorDaniel Baker <dbaker@FreeBSD.org>1999-07-23 05:34:54 +0000
committerDaniel Baker <dbaker@FreeBSD.org>1999-07-23 05:34:54 +0000
commit99250c0e09ca900a7c8ed5a3dc481a7577ab4894 (patch)
tree561bcd9b8342f32ecbf63dbbe33294345a178e2a /x11
parent3334445bde9de850f2bf85a6da71714259618d80 (diff)
downloadfreebsd-ports-99250c0e09ca900a7c8ed5a3dc481a7577ab4894.zip
makefile's check for existance of DISPLAY only checked if the variable
was defined, and didn't not check the possibility of an empty DISPLAY, which was the cause of the packages building error.
Diffstat (limited to 'x11')
-rw-r--r--x11/emu/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11/emu/Makefile b/x11/emu/Makefile
index 5da700351d1f..15b4e61ff924 100644
--- a/x11/emu/Makefile
+++ b/x11/emu/Makefile
@@ -3,7 +3,7 @@
# Date created: 13 September 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.12 1998/08/20 07:35:23 asami Exp $
+# $Id: Makefile,v 1.13 1998/10/05 05:17:56 steve Exp $
#
DISTNAME= emu-1.31
@@ -14,9 +14,10 @@ MASTER_SITE_SUBDIR= applications
MAINTAINER= me@FreeBSD.org
-.if !defined(DISPLAY)
-BROKEN= Requires an X Display to build
+.if !defined(DISPLAY) || ${DISPLAY} == ""
+BROKEN= "Requires an active X session (and DISPLAY variable) to run xrdb. Please compile this while running X."
.endif
+
USE_IMAKE= yes
WRKSRC= ${WRKDIR}/emu
MAN1= emu.1