summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-06-08 14:49:53 +0200
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-06-08 22:18:19 +0200
commitd631449922df1f12590bdd282ea21f2cbf885109 (patch)
treef76f030091271ccb630c42090d5c03553b9618f2 /x11-wm
parentafc34de8e3e18e6ce82f8949f65aff64be5931a8 (diff)
downloadfreebsd-ports-d631449922df1f12590bdd282ea21f2cbf885109.zip
compiz: disable gconf support
Approved by: maintainer (private email)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/compiz-plugins-extra/Makefile33
-rw-r--r--x11-wm/compiz-plugins-main/Makefile32
-rw-r--r--x11-wm/compiz-plugins-unsupported/Makefile14
-rw-r--r--x11-wm/compiz/Makefile41
-rw-r--r--x11-wm/compiz/pkg-plist4
-rw-r--r--x11-wm/compizconfig-backend-gconf/Makefile30
-rw-r--r--x11-wm/compizconfig-backend-gconf/distinfo2
-rw-r--r--x11-wm/compizconfig-backend-gconf/pkg-descr3
-rw-r--r--x11-wm/compizconfig-backend-gconf/pkg-plist3
10 files changed, 14 insertions, 149 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 3c2ee70e2451..56f462979a67 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -19,7 +19,6 @@
SUBDIR += compiz-plugins-extra
SUBDIR += compiz-plugins-main
SUBDIR += compiz-plugins-unsupported
- SUBDIR += compizconfig-backend-gconf
SUBDIR += compton
SUBDIR += ctwm
SUBDIR += cwm
diff --git a/x11-wm/compiz-plugins-extra/Makefile b/x11-wm/compiz-plugins-extra/Makefile
index 13503cda963e..82a2537cccc6 100644
--- a/x11-wm/compiz-plugins-extra/Makefile
+++ b/x11-wm/compiz-plugins-extra/Makefile
@@ -2,7 +2,7 @@
PORTNAME= compiz-plugins-extra
PORTVERSION= 0.8.8
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/
@@ -26,41 +26,14 @@ USES= gettext-tools gmake gl gnome libtool:keepla localbase:ldflags \
pathfix pkgconfig tar:bzip2 xorg
USE_GL= glu
USE_CSTD= gnu89
-USE_GNOME= gconf2 gdkpixbuf2 intltool libxslt
+USE_GNOME= gdkpixbuf2 intltool libxslt
USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama xorgproto xrandr xrender
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --enable-schemas
+CONFIGURE_ARGS= --disable-schemas
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-GCONF_SCHEMAS= compiz-3d.schemas \
- compiz-addhelper.schemas \
- compiz-animationaddon.schemas \
- compiz-bench.schemas \
- compiz-bicubic.schemas \
- compiz-crashhandler.schemas \
- compiz-cubeaddon.schemas \
- compiz-extrawm.schemas \
- compiz-fadedesktop.schemas \
- compiz-firepaint.schemas \
- compiz-gears.schemas \
- compiz-grid.schemas \
- compiz-group.schemas \
- compiz-loginout.schemas \
- compiz-maximumize.schemas \
- compiz-mblur.schemas \
- compiz-notification.schemas \
- compiz-reflex.schemas \
- compiz-scalefilter.schemas \
- compiz-shelf.schemas \
- compiz-showdesktop.schemas \
- compiz-showmouse.schemas \
- compiz-splash.schemas \
- compiz-trailfocus.schemas \
- compiz-wallpaper.schemas \
- compiz-widget.schemas
-
OPTIONS_DEFINE= NLS
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
diff --git a/x11-wm/compiz-plugins-main/Makefile b/x11-wm/compiz-plugins-main/Makefile
index e6fe95820571..a2c74c70a2fc 100644
--- a/x11-wm/compiz-plugins-main/Makefile
+++ b/x11-wm/compiz-plugins-main/Makefile
@@ -2,7 +2,7 @@
PORTNAME= compiz-plugins-main
PORTVERSION= 0.8.8
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= x11-wm
MASTER_SITES= https://BSDforge.com/projects/source/x11-wm/compiz-plugins-main/
@@ -25,40 +25,14 @@ USES= gettext-tools gl gmake gnome jpeg libtool:keepla localbase:ldflags pathfi
pkgconfig tar:bzip2 xorg
USE_CSTD= gnu89
USE_GL= glu
-USE_GNOME= gconf2 intltool libxslt
+USE_GNOME= intltool libxslt
USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama xorgproto xrandr xrender
USE_LDCONFIG= yes
# Fix build with clang11
CFLAGS+= -fcommon
-GCONF_SCHEMAS= compiz-animation.schemas \
- compiz-colorfilter.schemas \
- compiz-expo.schemas \
- compiz-ezoom.schemas \
- compiz-imgjpeg.schemas \
- compiz-kdecompat.schemas \
- compiz-mag.schemas \
- compiz-mousepoll.schemas \
- compiz-neg.schemas \
- compiz-opacify.schemas \
- compiz-put.schemas \
- compiz-resizeinfo.schemas \
- compiz-ring.schemas \
- compiz-staticswitcher.schemas \
- compiz-session.schemas \
- compiz-snap.schemas \
- compiz-text.schemas \
- compiz-thumbnail.schemas \
- compiz-wall.schemas \
- compiz-winrules.schemas \
- compiz-workarounds.schemas \
- compiz-scaleaddon.schemas \
- compiz-titleinfo.schemas \
- compiz-vpswitch.schemas \
- compiz-shift.schemas
-
-CONFIGURE_ARGS= --enable-schemas
+CONFIGURE_ARGS= --disable-schemas
OPTIONS_DEFINE= NLS
diff --git a/x11-wm/compiz-plugins-unsupported/Makefile b/x11-wm/compiz-plugins-unsupported/Makefile
index 1b7c9c813781..069a4eaad4b1 100644
--- a/x11-wm/compiz-plugins-unsupported/Makefile
+++ b/x11-wm/compiz-plugins-unsupported/Makefile
@@ -2,7 +2,7 @@
PORTNAME= compiz-plugins-unsupported
PORTVERSION= 0.8.8
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= x11-wm
MASTER_SITES= http://releases.compiz.org/${PORTVERSION}/ \
https://BSDforge.com/prolects/source/x11-wm/compiz-plugins-unsupported/
@@ -25,19 +25,11 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= gettext-tools gmake gnome libtool:keepla localbase:ldflags pathfix \
pkgconfig tar:bzip2 xorg
-USE_GNOME= gconf2 intltool libxslt
+USE_GNOME= intltool libxslt
USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama xorgproto xrandr
USE_LDCONFIG= yes
-GCONF_SCHEMAS= compiz-atlantis.schemas \
- compiz-cubemodel.schemas \
- compiz-elements.schemas \
- compiz-fakeargb.schemas \
- compiz-mswitch.schemas \
- compiz-snow.schemas \
- compiz-tile.schemas
-
-CONFIGURE_ARGS= --enable-schemas
+CONFIGURE_ARGS= --disable-schemas
OPTIONS_DEFINE= NLS
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index f7bab6c16648..430a68623a47 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -1,6 +1,6 @@
PORTNAME= compiz
PORTVERSION= 0.8.8
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= x11-wm
MASTER_SITES= https://BSDforge.com/projects/source/x11-wm/compiz/
@@ -26,7 +26,7 @@ RUN_DEPENDS_i386= nvidia-settings:x11/nvidia-settings
USES= gettext-runtime gettext-tools gl gmake gnome libtool \
localbase pathfix tar:bzip2 xorg xorg-cat:app
USE_GL= gl glu
-USE_GNOME= cairo gconf2 intltool libxslt
+USE_GNOME= cairo intltool libxslt
USE_LDCONFIG= yes
USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama \
xorgproto xrandr xrender
@@ -34,9 +34,11 @@ USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-kde4 \
--disable-kde \
+ --disable-gconf \
--disable-gnome \
--disable-gnome-keybindings \
- --disable-metacity
+ --disable-metacity \
+ --disable-inotify
INSTALL_TARGET= install-strip
SUB_FILES= compiz-manager
@@ -46,39 +48,6 @@ DESKTOP_ENTRIES= "Compiz Manager" \
"compiz-manager" \
"System;Core;" \
false
-GCONF_SCHEMAS= gwd.schemas \
- compiz-annotate.schemas \
- compiz-blur.schemas \
- compiz-clone.schemas \
- compiz-commands.schemas \
- compiz-core.schemas \
- compiz-cube.schemas \
- compiz-dbus.schemas \
- compiz-decoration.schemas \
- compiz-fade.schemas \
- compiz-fs.schemas \
- compiz-gconf.schemas \
- compiz-glib.schemas \
- compiz-gnomecompat.schemas \
- compiz-ini.schemas \
- compiz-inotify.schemas \
- compiz-kconfig.schemas \
- compiz-minimize.schemas \
- compiz-move.schemas \
- compiz-obs.schemas \
- compiz-place.schemas \
- compiz-png.schemas \
- compiz-regex.schemas \
- compiz-resize.schemas \
- compiz-rotate.schemas \
- compiz-scale.schemas \
- compiz-screenshot.schemas \
- compiz-svg.schemas \
- compiz-switcher.schemas \
- compiz-video.schemas \
- compiz-water.schemas \
- compiz-wobbly.schemas \
- compiz-zoom.schemas
OPTIONS_DEFINE= DBUS FUSE GTK2 SVG
OPTIONS_DEFAULT=DBUS GTK2 SVG
diff --git a/x11-wm/compiz/pkg-plist b/x11-wm/compiz/pkg-plist
index a4f90c804adb..a5f6cfc0bd3f 100644
--- a/x11-wm/compiz/pkg-plist
+++ b/x11-wm/compiz/pkg-plist
@@ -26,8 +26,6 @@ lib/compiz/libfade.a
lib/compiz/libfade.so
%%FUSE%%lib/compiz/libfs.a
%%FUSE%%lib/compiz/libfs.so
-lib/compiz/libgconf.a
-lib/compiz/libgconf.so
lib/compiz/libglib.a
lib/compiz/libglib.so
lib/compiz/libgnomecompat.a
@@ -71,7 +69,6 @@ lib/libdecoration.so
lib/libdecoration.so.0
lib/libdecoration.so.0.0.0
libdata/pkgconfig/compiz-cube.pc
-libdata/pkgconfig/compiz-gconf.pc
libdata/pkgconfig/compiz-scale.pc
libdata/pkgconfig/compiz.pc
libdata/pkgconfig/libdecoration.pc
@@ -102,7 +99,6 @@ libdata/pkgconfig/libdecoration.pc
%%DATADIR%%/resize.xml
%%DATADIR%%/rotate.xml
%%DATADIR%%/scale.xml
-%%DATADIR%%/schemas.xslt
%%DATADIR%%/screenshot.xml
%%DATADIR%%/svg.xml
%%DATADIR%%/switcher.xml
diff --git a/x11-wm/compizconfig-backend-gconf/Makefile b/x11-wm/compizconfig-backend-gconf/Makefile
deleted file mode 100644
index 92738c4d3dbd..000000000000
--- a/x11-wm/compizconfig-backend-gconf/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# Created by: Robert Noland <rnoland@FreeBSD.org>
-
-PORTNAME= compizconfig-backend-gconf
-PORTVERSION= 0.8.8
-PORTREVISION= 4
-CATEGORIES= x11-wm
-MASTER_SITES= https://BSDforge.com/projects/source/x11-wm/compizconfig-backend-gconf/
-
-MAINTAINER= portmaster@BSDforge.com
-COMMENT= GConf backend for CompizConfig
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:x11-wm/compiz
-LIB_DEPENDS= libcompizconfig.so:x11-wm/libcompizconfig \
- libstartup-notification-1.so:x11/startup-notification
-
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USES= gmake gnome libtool:keepla pathfix pkgconfig tar:bzip2 xorg
-USE_GNOME= gconf2 glib20 libxslt
-USE_LDCONFIG= yes
-USE_XORG= ice sm x11 xcomposite xdamage xext xfixes xinerama xrandr
-
-post-patch:
- @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
- ${WRKSRC}/settings-backend/gconf.c \
-
-.include <bsd.port.mk>
diff --git a/x11-wm/compizconfig-backend-gconf/distinfo b/x11-wm/compizconfig-backend-gconf/distinfo
deleted file mode 100644
index 38fd8c31cbac..000000000000
--- a/x11-wm/compizconfig-backend-gconf/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (compizconfig-backend-gconf-0.8.8.tar.bz2) = 19a8df7f417535db80945cabb9a09c532241e6308406352d12cb5cbc6a1322cc
-SIZE (compizconfig-backend-gconf-0.8.8.tar.bz2) = 248650
diff --git a/x11-wm/compizconfig-backend-gconf/pkg-descr b/x11-wm/compizconfig-backend-gconf/pkg-descr
deleted file mode 100644
index 53dcdeb21343..000000000000
--- a/x11-wm/compizconfig-backend-gconf/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-The gconf backend for CompizConfig. It uses the
-Gnome configuration system and provides integration into the Gnome desktop
-environment.
diff --git a/x11-wm/compizconfig-backend-gconf/pkg-plist b/x11-wm/compizconfig-backend-gconf/pkg-plist
deleted file mode 100644
index 4dc77a1b44e4..000000000000
--- a/x11-wm/compizconfig-backend-gconf/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-lib/compizconfig/backends/libgconf.so
-lib/compizconfig/backends/libgconf.la
-lib/compizconfig/backends/libgconf.a