summaryrefslogtreecommitdiff
path: root/x11-wm/sway
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-03-11 03:56:24 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-03-11 05:05:58 +0000
commit6feac27b7b1c271e52540d2e01d5a35b1d80095c (patch)
treef2c19f91086d20fabc6625b95ce3ee88b4fdcfac /x11-wm/sway
parent9d1d55394976b91ecfc07287716c413749f5a05d (diff)
downloadfreebsd-ports-6feac27b7b1c271e52540d2e01d5a35b1d80095c.zip
x11-wm/swayfx: add new port
Sway is an incredible window manager, and certainly one of the most well established wayland window managers. However, it is restricted to only include the functionality that existed in i3. This fork ditches the simple wlr_renderer, and replaces it with our fx_renderer, capable of rendering with fancy GLES2 effects. This, along with a couple of minor changes, expands sway's featureset to include the following: + Anti-aliased rounded corners, borders, and titlebars + Shadows + Dim unfocused windows + Per application saturation control: Allows the user to set the saturation (Digital Vibrance) for specific applications. Great for some FPS games! + Scratchpad treated as minimize: Allows docks, or panels with a taskbar, to correctly interpret minimize / unminimize requests https://github.com/WillPower3309/swayfx/
Diffstat (limited to 'x11-wm/sway')
-rw-r--r--x11-wm/sway/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/x11-wm/sway/Makefile b/x11-wm/sway/Makefile
index 729f745945b2..8151edd6c261 100644
--- a/x11-wm/sway/Makefile
+++ b/x11-wm/sway/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sway
-DISTVERSION= 1.8.1
+DISTVERSION?= 1.8.1
+PORTREVISION?= 0
CATEGORIES= x11-wm wayland
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -7,8 +8,8 @@ PATCHFILES+= cd9d1038a822.patch:-p1 # https://github.com/swaywm/sway/pull/5090
PATCHFILES+= f98ca3ab7ca1.patch:-p1 # https://github.com/swaywm/sway/pull/5090
MAINTAINER= jbeich@FreeBSD.org
-COMMENT= i3-compatible Wayland compositor
-WWW= https://swaywm.org/
+COMMENT?= i3-compatible Wayland compositor
+WWW?= https://swaywm.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -27,12 +28,14 @@ LIB_DEPENDS= libjson-c.so:devel/json-c \
USES= compiler:c11 gl gnome meson pkgconfig xorg
USE_GITHUB= yes
-USE_GL= glesv2
+USE_GL+= glesv2
USE_GNOME= cairo pango
USE_XORG= pixman
-GH_ACCOUNT= swaywm
+GH_ACCOUNT?= swaywm
MESON_ARGS= -Dsd-bus-provider=basu
+CONFLICTS_INSTALL?= ${PORTNAME}fx
+
OPTIONS_DEFINE= BASU MANPAGES PIXBUF SWAYBG X11
OPTIONS_DEFAULT=BASU MANPAGES PIXBUF SWAYBG X11
OPTIONS_SUB= yes