summaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorKiriyama Kazuhiko <kiri@FreeBSD.org>2003-05-08 07:43:45 +0000
committerKiriyama Kazuhiko <kiri@FreeBSD.org>2003-05-08 07:43:45 +0000
commit0615eaed4c265a360411df45e4af9335c1dc6271 (patch)
tree057552e0f179ff7a6347c14b3f2fa783f67d82e3 /x11-fm
parent2bcca35202ba1aeba224d5ef0d78d33f6a6b1951 (diff)
downloadfreebsd-ports-0615eaed4c265a360411df45e4af9335c1dc6271.zip
Set MASTER_SITES fetchable and correct reinplace commands.
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/binder/Makefile10
-rw-r--r--x11-fm/binder/pkg-descr2
-rw-r--r--x11-fm/binder/pkg-plist1
-rw-r--r--x11-fm/binder/scripts/post-install16
4 files changed, 17 insertions, 12 deletions
diff --git a/x11-fm/binder/Makefile b/x11-fm/binder/Makefile
index d1a1319631c9..bfa606a19cd9 100644
--- a/x11-fm/binder/Makefile
+++ b/x11-fm/binder/Makefile
@@ -8,11 +8,13 @@
PORTNAME= binder
PORTVERSION= 1.3
CATEGORIES+= ${CATEGORY_LIST}
-MASTER_SITES= http://www.aaa-int.or.jp/~jfactory/JDE/dist/
+MASTER_SITES= http://www.aaa-int.or.jp/~jfactory/JDE/dist/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= . kiri
DISTNAME= Binder-${PORTVERSION}
EXTRACT_ONLY= # extracted directly in install target
-MAINTAINER= kiri@pis.toba-cmt.ac.jp
+MAINTAINER= kiri@FreeBSD.org
COMMENT= A file manager on X window with TkStep
RUN_DEPENDS= ${RUN_DEP_LIST}
@@ -21,7 +23,9 @@ LIB_DEPENDS= ${LIB_DEP_LIST}
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_X_PREFIX= yes
-SCRIPTS_ENV= LANG=C LN=${LN} PERL=${PERL} LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
+USE_REINPLACE= yes
+SCRIPTS_ENV= LANG=C LN=${LN} REINPLACE_CMD="${REINPLACE_CMD}" \
+ LANGUAGE=${LANGUAGE} VERSION=${TKSTEPVERSION}
PLIST_SUB= PIXMAP_PATH=${PIXMAPPATH:S@^${PREFIX}/@@}
# This port is for both x11-fm/binder and japanese/binder.
diff --git a/x11-fm/binder/pkg-descr b/x11-fm/binder/pkg-descr
index ac05ad8cfb09..a87f3653c220 100644
--- a/x11-fm/binder/pkg-descr
+++ b/x11-fm/binder/pkg-descr
@@ -5,4 +5,4 @@ Note that both x11-fm/binder and japanese/binder are mutually exclusive and
SHOULD NOT BE INSTALLED SIMULTANEOUSLY!
-KIRIYAMA Kazuhiko
-<kiri@pis.toba-cmt.ac.jp>
+<kiri@FreeBSD.org>
diff --git a/x11-fm/binder/pkg-plist b/x11-fm/binder/pkg-plist
index 81b99dcb57b8..70d63fdbec89 100644
--- a/x11-fm/binder/pkg-plist
+++ b/x11-fm/binder/pkg-plist
@@ -181,3 +181,4 @@ bin/Processes.app
@dirrm JDE/Binder/modules
@dirrm JDE/Binder/tools
@dirrm JDE/Binder
+@unexec rmdir %D/JDE 2>/dev/null || true
diff --git a/x11-fm/binder/scripts/post-install b/x11-fm/binder/scripts/post-install
index 68d6db344e2a..a746119ec114 100644
--- a/x11-fm/binder/scripts/post-install
+++ b/x11-fm/binder/scripts/post-install
@@ -5,9 +5,9 @@ installdir=${PREFIX}/JDE/Binder; export installdir
case ${LANGUAGE} in
Japanese)
for f in bin/Binder.app bin/Processes.app misc/Mounter/Mounter.app; do
- ${PERL} -pi -e '
- s/^(exec[ \t]+)wishstep[^ \t]*([ \t]+.*)$/$1wishstep$ENV{VERSION}jp$2/
- ' ${installdir}/${f}
+ ${REINPLACE_CMD} -E -e \
+ "s/^(exec[[:space:]]+)wishstep[[:space:]]*([[:space:]]+.*)\$/\1wishstep${VERSION}jp\2/" \
+ ${installdir}/${f}
done
;;
*)
@@ -28,11 +28,11 @@ for f in Binder Binder.app Processes.app Mounter.app shortcut; do
target=${installdir}/lib/${f}
;;
esac
- ${PERL} -pi -e '
- s/^([ \t]*set[ \t]+ttblibPath[ \t]+)"[^"]*"$/$1"$ENV{installdir}"/;
- s/^([ \t]*set[ \t]+ttblibPath[ \t]+)\{[^\}]*\}$/$1\{$ENV{installdir}\}/;
- s@^([a-zA-Z.]+;)/usr/local/([a-zA-Z/.]+;[a-zA-Z]+)$@$1$ENV{PREFIX}/$2@;
- ' ${target}
+ ${REINPLACE_CMD} -E \
+ -e "s@^([[:space:]]*set[[:space:]]+ttblibPath[[:space:]]+)\"[^\"]*\"\$@\1\"${installdir}\"@" \
+ -e "s@^([[:space:]]*set[[:space:]]+ttblibPath[[:space:]]+)\{[^\}]*\}\$@\1\{${installdir}\}@" \
+ -e "s@^([a-zA-Z.]+;)/usr/local/([a-zA-Z/.]+;[a-zA-Z]+)\$@\1${PREFIX}/\2@" \
+ ${target}
done
${LN} -sf ${installdir}/bin/Binder.app ${PREFIX}/bin